Captive Portal on WRT54GL

Discussion in 'Tomato Firmware' started by Donny72, Mar 22, 2013.

  1. Donny72

    Donny72 Serious Server Member

    This is my first post ... so: hello forum :), Hi to all !

    I have here a WRT54GL, powered with Tomato RAF K26-1.28.9006 with NOCAT behind a Fritzbox Internet router.
    I searched this forum and others too, googled etc. but I don't find the final answer to this:

    is is possible to run my WRT54GL with nocatsplash BEHIND my Internet Router? I configured Tomato Wlan settings with DHCP, AP Mode, and Nocat of cause and tried:

    Internet => WanPort(Fritzbox) => LanPort(WRT54GL)
    Internet => WanPort(Fritzbox) => WanPort(WRT54GL)

    Clients can connect via Wlan to the WRT but no splash screen is showing up. Client goes directly to the net.This "bug" is confirmed here: and here:

    I simply need a Splash-Screen for my guests with bandwidth management. I tried so many firmwares: openwrt, cova, some commercial etc. but all of them failed (need external servers, need directly connected to the internet)

    Can anyone help? A simple "its NOT possible" would be OK and I would switch to Microtic or others. Otherwise any hint is appreciated :rolleyes:

    Cheers Donny
  2. Victek

    Victek Network Guru Member

  3. Donny72

    Donny72 Serious Server Member

    Thanks @Victek
    Bandwidth-control is only the second of my first question above :) I don't get the NoCat/Dog splash-screen in my config above => WLan Clients goes direct to the i-net without spash-screen. What do I do wrong and is my so called "special scenario" possible ? Think, many people are intrerested in this ...

    See: "Caveat Concerning the Operation of Nocatsplash"

  4. Victek

    Victek Network Guru Member

    Nocat (and Nodog) use dhcp, traffic control (iptables), so from this starting point Tomato needs to be the manager of any user trying to connect Internet using the splash welcome banner. I tested now and it works:

    Internet--->WAN | FTTH Router | LAN ----> Auto DHCP WAN | Tomato Router | Nocat enabled | DHCP LAN -----> users.

    But in next release you may have the posibility to redirect traffic to lighttpd and be the server or proxy...
  5. Donny72

    Donny72 Serious Server Member

    Hi Victek,
    just to nail your settings down: this is exactly my config2 from my first post. See images. Wlan client connects using IP but no splash welcome -> instead they went directly to the net. Did you do do anything else? Can you please post your complete settings here.

    Thanks for your help :)


    Attached Files:

  6. Victek

    Victek Network Guru Member

    Set your IP LAN address in another subnet .. you have it in the same subnet as your Internet router... i.e: .. then it should work.
  7. Donny72

    Donny72 Serious Server Member

    Noop, sorry. Just check this out and switched the Tomato- LAN port to range Still no splash. Also tried different a subnet: no splash.
    Btw: I did all the time a reboot of both routers, cleared the browser cache of the clients... etc. can't understand this :(your config is working in your lan but not in my w-lan.

    Nevertheless, thanks for your time and support. Great job. Do we get this things up and running? Any idea? Did you change something to the listening port manually at the nocat.config ?

    Cheers Donny
  8. Victek

    Victek Network Guru Member

    Configured as it's on defaults,.. let's do as dummies .. reset WRT54G from back button, connect to your Internet router (WRT54G Wan port to LAN port in your Internet router), access WRT54G as it's default IP, go to Captive Portal label and enable, save, wait 20 seconds and then try to navigate from one machine connected to wrt54g, simple as it..

  9. Donny72

    Donny72 Serious Server Member

    Hey Vitek,
    sorry for getting back so late.
    Followed your "dummy steps" :) Still the same. :confused: and I was already going to erase the firmware. Just seconds before I want to give it a last try and telnet to the wrt to check the nocat.config file for the listening interface since this is not displayed on the tomato-web interface (see post 5, cap2.jpg) . Dont find that config! Where this is stored? Further the splash.html is inside the ...www/ folder - NOT in tmp/splashd/
    Tried changing the path but still no luck. Now I think something is wrong with the firmware-file itself. I use the "tomato-K26-1.28.9006MIPSR1_RAF-VPN-NOCAT.trx" Can you confirm this? and what should I do now?

    Thanks for your patience and have a nice easter ;)
  10. Victek

    Victek Network Guru Member

    The config file is saved in nvram, you can access by typing nvram show | grep NC_ the you can see the configuration and change what you want by nvram set [value]= and then nvram commit to save. Firmware works.

  11. radionerd

    radionerd Networkin' Nut Member

    I have been struggling to get NC going too. Mine won't splash with QOS turned on. BW limiter on is hit and miss.
    You might turn the nocat "log info level" up to 10 and get some hints from the logs. I got mine working, but it won't redirect to the splash when an https site is in the go to bar. Google won't work since it I have to put something like or, they are both http:// then it will redirect to the splash.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice