Changelog for Thibor 17rc1?

Discussion in 'HyperWRT Firmware' started by phinn, Jan 28, 2007.

  1. phinn

    phinn Network Guru Member

  2. phinn

    phinn Network Guru Member

    Found it in the zip: (note: its for SL routers only)

    Changes from 16b to 17rc1

    Fixed abusive DDNS behaviour
    more web cleanup code
    UPnP now fully working, thanks Jim :)
    Updated Proftpd to latest version

    thanks again Thibor : )
  3. bkmo

    bkmo LI Guru Member

    I tried this version, but it really messed up my router. Factory resets, nvram clears and all. I loose access to the router, and internet after about a minute or less.. The ddns page is all messed up visually. Windows did notify me of a new upnp device on the network. Back to 16b and working like a charm.
  4. phinn

    phinn Network Guru Member

    17rc1 works great here
  5. Vincenzov72

    Vincenzov72 Network Guru Member

    Hi , error disk management and log web management
  6. Thibor

    Thibor Super Moderator Staff Member Member

    Vincenzov: what the hell do you expect me to do with that? tut
    bkmo: i've had one other report of this type of thing, but it's not happening here so i can't faultfind it. can you flash back to stock, and from there to 17rc1 and see if it helps? it could be that the size of the bin is at the upper limits now, in which case i can look at streamlining(removing) some features.
  7. Vincenzov72

    Vincenzov72 Network Guru Member

    sorry , hi speak only italian
  8. bkmo

    bkmo LI Guru Member

    I have flashed to linksys 2.06, and then to 17RC1 with the same nasty results. I am typing this running 17RC1, but as soon as I hit the storage or ddns pages, it locks me out of the router, and kills the internet connection.
  9. Thibor

    Thibor Super Moderator Staff Member Member

    i've pulled the file. although i don't see the error, i'll do everything i can to track it down.
  10. Thibor

    Thibor Super Moderator Staff Member Member

    ok, bug squashed. sorry for the inconvenience guys. i didn't expect a small change in UPnP to destroy the web interface, but there ya go.
    it'll be up on my website shortly, along with new sources
    **Edit** rc2 is up on my site now, and accompanied by the sources. Changelog, all 1 line of it, is included in the zip file.
  11. phinn

    phinn Network Guru Member

    Wow, I didn't have that problem but amazingly fast fix:

    Changes from 17rc1 to 17rc2
    replaced gena.c in UPnP with version that doesn't kill httpd.

    I just backed up and restored my config file this time... Any reason why that would be a problem?
  12. Thibor

    Thibor Super Moderator Staff Member Member

    none that i can think of. btw, you may have had the problem and just not noticed it. i didn't see it here until i checked Log.asp, then all hell broke loose.
  13. bkmo

    bkmo LI Guru Member

    Thanks Thibor for the RC2 fixes. HTTPD is not crashing, and alls seems very smooth again.
    Dyndns behavior seems much better too.
  14. Thibor

    Thibor Super Moderator Staff Member Member

    ya, it should be lacking in abusive updates now :)
  15. frenchy2k1

    frenchy2k1 LI Guru Member

    Updated this morning and reconfigured my router.
    17rc2 seems to work great so far.
    DDNS works (so far, we'll see for the update, but i dont think i ever kept a connection going straight for 4+ weeks), which was my main problem with 15b.

    As a result, I could happily use the Paypal button on your site ;)
  16. Thibor

    Thibor Super Moderator Staff Member Member

    thank you for that, it's much appreciated. rc3 following shortly, 2 bugfixes; 1 very minor, and 1 more major.
  17. bkmo

    bkmo LI Guru Member

    Before the 17 series I was able to set my wireless channel to 13 and connect to the router. I can only use up to 11 now and have it recognized. Has anyone else noticed this?
  18. shadow2k6

    shadow2k6 LI Guru Member

    After applying 17rc1, my router pages seemed to become very slow (I see that their were issues and 17rc2 is now out with rc3 coming soon, but I have one question:

    After applying rc1 and waiting quite awhile, I believed that my router was no longer responsing so I wanted to TFTP linksys firmware and then bring back latest 17rc release. The GUI is working fine so I'm not in rough shape, but when I TFTP, I get prompted to login. I haven't seen this before and this does not appear to be my router password. Anybody familiar with this. I don't want to be behind the 8-ball if the GUI fails in the future and I am still not able to TFTP. Thanks in advance for any suggestions.
  19. Thibor

    Thibor Super Moderator Staff Member Member

    rc3 is on my website now.
  20. zerosc

    zerosc LI Guru Member

    what are the changes from RC2 to RC3?

    Edit: Scratch that, downloaded and opened the changelog.
  21. mitku

    mitku Network Guru Member

    On the Thibor's page is described that 16xx & 17xx firmwares are just for WRTSL54GS and NOT for WRT54G (G/GS v4 and below & GL).
    Is it compatible with WRT54GL or not... or are there a plans to build a new version (newer than 15c) for other models from a "good old" WRT54G series?
  22. mstombs

    mstombs Network Guru Member

    This has been asked once or twice if you search here!

    This firmware is NOT for the WRT54G/L/GS. But Thibor has stated he will do one more version for those when the WRTSL54GS is done - this will be an upgrade to incorporate the latest Linksys source code and updated modules/ fixes (ie DDNS expiry) functions from the WRTSL54GS where appropriate.

    If you want frequent updates with lots of new features you should now be looking at Tomato. Hyperwrt Thibor for the WRT54G/L/GS should continue to be the reliable firmware it is today - so no rush!
  23. phinn

    phinn Network Guru Member

    Here is the 17rc3 changelog of Thibor's great firmware:
    rc3 can be downloaded on his website. (note: again, for SL routers only)

    rc2 to rc3 changes:

    Fixed web page bug that force Media Server status to show as Disabled.
    Fixed routing bug that caused the power led to flash when internet connection was disabled.
    Fixed Management.asp bug that cause Wireless Access Web disabled radio button to not show checked or bold status.
  24. spepi

    spepi Network Guru Member

    I have tried 16a, 16b and I cant get anything but my wireless laptop to connect to the wifi. My Xbox 360 wont connect, and its ethernet to the router. My Wii sees the AP, but ont connect to the internet. I had to reload the Linksys Firmare on my WRTSL54GS, because nothing worked.
    My wifi devices are Wii, IPAQ and Sony Laptop.

    Will 17rc3 work for me? Are there any files I can get to see why its not working for 16a or 16b?
  25. Thibor

    Thibor Super Moderator Staff Member Member

    will it work for you? dunno, i'm not a psychic.
    you'll have to try it yourself and tell me the result. fyi though, i'm using an xbox 360 and it's ok here. turn off wireless encryption and set network mode to mixed until you have all devices connecting properly.
  26. spepi

    spepi Network Guru Member

    OK, I downloaded and flashed the WRTSL54GS, reset all nvram and default settings.

    Every wireless device connected first try.

    Then I enabled WEP to keep it simple, and things still worked.

    I am so happy....I hated the Generic Bland Linksys Firmware.....Love the Thibor 17rc3
  27. frenchy2k1

    frenchy2k1 LI Guru Member

    Bad news: DynDNS does not work for me. (17rc2)
    If I connect the first time, the address updates, but if I disconnect and reconnect (hence changing IP), it says that DynDNS does not require updating.

    Actually, the IP that is showed on "internet IP address" does not match the reported IP on the "Status" page. The DynDNS page catches my real IP.

    How do you check the internet IP and how do you compare it to the DynDNS one? It seems there is a problem in that routine... I would guess the imternet IP is not updated after a reconnect.

    edit: also, i cant force update, It tells me some of the settings are incorrect.
  28. Turbe

    Turbe LI Guru Member

    "Fixed routing bug that caused the power led to flash when internet connection was disabled."

    hmmm bug? I would like this as a feature or option.
  29. Turbe

    Turbe LI Guru Member

    Try to use WPA Personal (with AES) instead of WEP....
  30. spepi

    spepi Network Guru Member

    I thought about it, but the only reason I am not using it, is then I have to type in this long key on the's easy to copy andf paste on a laptop....WEP is fine...its working.....and that is my main goal. Now I am going to try to get my Western Digital 250GB My Book hooked up...
  31. ka9yhd

    ka9yhd LI Guru Member

    15c works quite well on my WRT54GL ver. 1.1

    If I remember correctly, Thibor has stated that he could be working on a newer version for the G/GS/GL versions after he has finished with the SL. But I think he has a WRT350 on order, so it might be a while longer.

    Great things come to those who have patience. :)
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice