Changing NAS200 firmware to Jac4

Discussion in 'Cisco/Linksys Network Storage Devices' started by GnFi, Aug 27, 2010.

  1. GnFi

    GnFi Networkin' Nut Member

    If i change the V3.4R79 firmware of NAS200 with Jac4 will i loose my pre-configured hard disks that are as Striping (RAID 0) (Non-Journaled)?

    I already have 800Gb of data in them and transferring them will take me.......a week maybe? with the speed of the NAS200

    If i loose the volume is it possible to reconstruct in in the NAS200 after the update?

    Thanks in advance.

    By the way fantastic job mr. jac_goudsmit's
  2. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    Installing my firmware will make no changes to your configuration, all your data should be retained. Also, once you install my firmware you can flash the original V3.4R79 firmware back if you wish to do so. I reflashed the firmware on my NAS200 many times and never had any problems with data getting lost.

    Nevertheless... in the unlikely event that something goes wrong, you can make a backup, by connecting the disks directly to a PC that's running SystemRescueCD. Before you take the drives out of the NAS, use the power button to shut it down cleanly. The NAS doesn't support hot swapping.

  3. GnFi

    GnFi Networkin' Nut Member

    I did the upgrade to jac4 with success.

    I logged in with ssh after 5-6 minutes as root and i changed the root passw.
    After that i run
    "for x in 1 2 3 4 5 6; do cp /etc/passwd /harddisk/volume_$x/conf/; done"

    The volumes remained the same with no problem and i can normally find my files.

    Ftp does not work any more with error
    220: FTP server at ready.
    550:Fail to get group info

    After that i logged in at the webgui to see the settings. While i can normally log in at (i had the port changed from before the upgrade) and see every page when i press the System Options page i get the following message
    "HTTP port number of this server has been changed, the web page will reloaded in 10 seconds"

    Then it try to connect at

    I was using a static ip address with port for the webui at 8081
    While it try to refresh to the new ip i can see that in system options the system is now trying to get an ip from DHCP and the webui port is the default 80.

    Still my DHCP server does not get an ip request. And i can ping The webui is reachable from this address and port 8081.
    What the heck?

    Any ideas?

    Thanks in advance

    Also the hardware shutdown button is not working anymore. Via SSH i write this "/etc/rc.d/rc.reboot" and i get in return "-sh: /etc/rc.d/rc.reboot: not found"

    Bah forget it mate. Its working after i pulled the plug and start it again. All my settings returned to normal, ftp is working, reboot via SSH is ok.

    One last question. Will i need NFS only for linux network? Or do i need it for something else also?

    By the way the system looks much more responsive in my eyes with jac4. Maybe its just my idea
  4. GnFi

    GnFi Networkin' Nut Member

    Nice i also think i got a minor transfer speed upgrade. Nothing much but still it is something.

    Any idea why the who command always returns an emtpy value?
    I would love to be able to see who is logged in and via what means.

    Netstat returns the ssh or ftp connection but i cannot see who is using that connection. Only the ip they connect from.
  5. jackito

    jackito LI Guru Member

    Yes. The problem with "who" is that is uses the file /var/log/wtmp and this file doesn´t exists by default in jac´s or stock firmware. As far as I can remember the stock busybox doesn´t have support for this file (even if you create it manually it will not be updated when a user logs in, this is what I mean with "support" in this case).
    I installed a newer version of busybox in my NAS200 with support for this file and it´s working almost completelly since it is only updated when a user logs in through SSH for instance, but is not updated on log out. :frown:
    I will try to investigate someday.

  6. jackito

    jackito LI Guru Member

    Actually you probably don´t need NFS at all. Even if the client computers are not running Windows except if you are running any application that requires to access the NAS200 share ONLY with NFS protocol.
    Today, all GNU/Linux distros have SAMBA support so you can access your shared drives in the same way (using the same protocol) as if you are using a machine running Windows.

  7. GnFi

    GnFi Networkin' Nut Member

    Both your answers where very helpful.

    I understand what you say about busybox and the who command.

    I totally forget about samba support in linux.Damn i have completely forgot a lot of things.
    Truly this way i am in no need of NFS support.

    Really thanks for the super fast answers sir.
  8. raybie

    raybie Networkin' Nut Member

    root password lost, but reset to default did not work

    hi, I have lost my root password, and already tried to reset the password by restoring to default but without any succes. Can you please advise on what to do.
  9. dispose256

    dispose256 Networkin' Nut Member

    Hi Jac,

    Got the usual dumb problem (lost root password).
    Now, resetting the password via gui does not work (works only for the gui password)

    Since I dont have a password anymore, I cant ssh into the box to change the password !

    Am I correct in saying the following method will work:
    Take disk1 out
    Mount it on some linux box
    Access and create the password reset script file in rc.d (the one you gave)
    Put the disk back in the NAS and reboot.
    Then the password will be definitely back to root.

    Is it ok and is there a shorter way to do that without all the hair pulling.

    Thanks ! By the way your firmware is sooooo much better than the original.
  10. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    If you have access to the rc.d directory through a file share, you don't have to take any disk out of the NAS200 to put the script there. Just make sure the script has "line-feed only" line endings, not "carriage return+line feed" which is what Windows uses. Then you can just shut the NAS down with the power button, and start it up again, also with the power button.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice