Changleg for dd-wrt 23 + sp1

Discussion in 'DD-WRT Firmware' started by TheCoseyExpress, Mar 5, 2006.

  1. SP1 beta/&download=changelog.txt

    big thanx for pierre belanger, Eko, LawnMowerGuy1, for providing my many patches


    0000816 Info Site password protection has no effect
    0000827 ASUS WL-500G Deluxe Router Bricked
    0000285 New QoS Service Requires Reboot & Not Sorted
    0000722 Unable to connect to the PPTP server after Feb 9 firmware
    0000378 Client Bridged mode is not included in Help (/help/HWireless.asp)
    0000518 Wrong help page link : link are false or page doesn't exist - a complete inventory ...
    0000596 Minor help page changes

    0000761 QoS service class filter does not work properly
    0000722 Unable to connect to the PPTP server after Feb 9 firmware
    0000816 Info Site password protection has no effect
    0000453 Xirian GUI style broken
    0000779 BrainSlayer style web interface issues


    Please note that the username at gui login is now "root" and not empty anymore. additionally i can be possible
    that this can cause troubles with old settings. i will implement a nvram conversion tomorrow

    0000811 ipkg fails to install as it uses wrong tar syntax
    0000808 SiPath Seems to be broken in 2.27.06 build
    0000812 nocatsplash doesent work (note. SplashURL must now include the html page too http://yoursite/splash.html for example)

    overclocking feature added for safe overclocking (please use with care if you dont want to create a brick)
    some help files added
    ack timing can now be disabled too

    0000805 Web GUI : QoS; Netmask Priority; there's one dot too much, please change to slash /
    0000806 nocatsplash upgrade not good

    ACK timing setting added (by atheros like distance setting)
    many big thanks to Nbd/OpenWRT for providing me the way

    0000790 Upgrade NoCatSplash to .93
    0000593 Hraduath.asp uses old-style help page
    0000732 GUI error in spanish Language
    0000662 Web-Admin tweaks
    0000771 UPnP stays Disabled
    0000775 Client bridge reboot loop or BRICK
    0000747 PPTP Client mode Fatal 11
    0000755 RP-PPPOE broken in 17/02 build
    0000787 GUI Bug, 2/24/06 mini
    0000781 2/24 build will not accept UTC+9
    0000777 'Join' button on the 'Site Survey' does not work

    chillispot changes for
    0000769 WAN IP stays set after changing "conection type" to "disabled"
    0000772 Little typo Services-page


    pptp signal 11 should be solved now too
    mac proxy mode added for client bridge (should solve the most dhcp problems)

    0000381 UPNP Forwarding has fixed values 11/24 WRT54G v4
    0000757 Site Survey Fails if SSID contains a single quote

    0000694 Using the 'Join' button on the 'Site Survey' popup window does not exit the popup window (control panel opens in popup)
    0000523 Wrong help container in Access Restrictions tab
    0000719 SP1 20060209: Not all L7 patterns showing
    0000751 Cannot commit changes (like "Send presentation URL") to UPnP

    httpd translation memory leak fixed
    french language file updated
    0000707 HOST field for static leases: maxlength is too small
    0000751 Cannot commit changes (like "Send presentation URL") to UPnP
    0000748 Spelling error (build 02/17/06 and 02/16/06)
    0000547 Web GUI : Port Triggering's Help Container
    0000546 Web GUI : Access Restrictions's Help Container
    0000505 Wireless channel Range not really readable
    0000743 DNS not working in build 16/02
    0000723 rflow doesn't launch in the Feb 9 build
    0000655 Setup CVS for DD-WRT
    0000726 UPnP problems with 02/09/06
    0000735 logo-help.png file corrupt
    0000180 Problems setting timezone

    Many structural changes for full gpl compliance. so be careful while testing
    svn:// introduced which contains the very latest sources
    memory optimization (should solve various SE505 problems)

    Buffalo-WHR-G54S support added (tested)
    Buffalo-WHR-HP-G54s support added (should work)
    0000665 Problems setting timezone
    0000709 Access Restrictions tab disappears in Web Interface
    0000517 Wireless Active Client List : bug in the max. clients number

    fully b44 driver integration (thx nbd/openwrt)
    buffalo wzr-rs g54 support now a little bit more officially
    iptables upgraded to latest version
    ipp2p module updated
    some filter default definitions like soulseek,gnutella,ares etc. converted from l7 to p2p
    (reset your config to get them to work)

    save workflow enhanced. everything is much more smooth now

    0000698 QoS still doesn't work properly in SP1 02/02/06
    0000669 QoS doesn't work in SP1 01/27/06 and 01/31/06


    0000669 QoS doesn't work in SP1 01/27/06 and 01/31/06
    0000690 GZIP, TAR broken (CLI command GZIP = IP ????? build 31-01-2006)
    0000661 WRT54GS v1.1 doesn't reboot from console
    0000678 WDS p2p mode can't be configured in Firefox if more then 1 MAC is used - web GUI problem

    adsense finally removed again

    0000656 Build 0123 & 0125 (SP1): httpd crash when saving managment or service tabs

    google adsense added to the firmware (please discuss in the forum if you dont like it)
    firmware downsized a little bit again
    httpd code bug fixed (causes crashes under some not direct reproducable conditions)

    0000653 DNSMasq as DHCP server NAKs lease renewal request - v23 sp1 16/01/06
    0000386 Memoryleak httpd status page
    0000589 PPPoE (standard) Connect on demand is broken
    0000641 sp1: 13.&16.jan: All "Additional filters" turned ON by default

    0000170 WRT54G or GS hangs when (mtd erase nvram) then (reboot) from a telnet session
    0000602 PPTP Internet connections drop due to ipables rules
    0000301 WOL in WebGUI is out of Work
    0000610 v23SP1: Rflow interface: web interface is broken

    dhcpc client interval fixes (connect now faster in client mode)
    dhcpc lease update fixes (does not disconnect on lease update anymore)
    wOL patch by Pierre Belanger implemented who finally got it to work

    0000585 DD-WRT: Rflow support should include choice of interface
    0000416 06/12 build: DNSMasq crashes and restarts by itself
    0000579 Please Reconsider: Remote Management Is Enabled By Default in v23 final
    0000536 Client doesn't get WINS when using DNSMasq as dhcp server - v23 final
    0000529 SNMP sysUpTime wrong after reboot
    0000336 epi_ttcp default port is correct, but text is wrong in "usage"
    0000577 Channel changing turns on Frame Burst setting in Mixed and B-only mode
    0000550 WDS P2pP can't be configured in Firefox
    0000553 search DOMAINNAME missing in /tmp/resolv.conf

    CHRISTMAS 2005:
    0000503 2 bugs in HTML headers of the web interface
    0000530 Solution to Opera Status page problem
    0000506 DHCP Client table with DNSMasq is empty (I know, again)

    0000515 21/12 build: WRT54G 1.1: NO ETHERNET LAN
    0000038 DMZ LED doesn't work on WRT54G v.1.1 with all v23b2 builds
    0000514 21/12 build: WRT54G 1.1 RESET button does not work !

    the firmware does now support GSv4 firmwares for backflashing to linksys

    0000514 21/12 build: WRT54G 1.1 RESET button does not work !
    0000517 Wireless Active Client List : bug in the max. clients number
    0000507 Wrong Version Number in Firmware
    0000509 Address spelled wrong

    0000170 WRT54G or GS hangs when (mtd erase nvram) then (reboot) from a telnet session
    0000498 HTML error on Sys-info page
    0000482 DHCP server broken again in 191205 version
    0000286 trivial text change for router reboot message

    0000472 16/12 build: Client or client-bridge mode won't connect to AP !!!
    0000243 UPnP status closes in Windows XP
    0000363 /tmp/resolv.conf not set properly in Client Bridge mode
    0000479 DynDNS broken "Domain name resolv fail"
    0000468 16/12 build: SSH daemon (dropbear) broken
    0000466 DNS problems with builds from 12&14.12.05!
    0000356 03/12 build: DHCP Clients table shows empty


    0000399 ebtables broken
    0000243 UPnP status closes in Windows XP
    0000445 Changing the 'TCP Timeout' setting does not take effect immediately
    0000451 Afterburner does not work on v 23 - 2005.12.11

    This release needs a full reset of all nvram settings to get everything in the right place

    - ASUS WL500G-Deluxe support fixed
    0000442 DNS problems with 12.12.05
    0000450 12/12 build: Calling ntpclient manually sets time to UTC
    0000446 UDP Timeout option broken
    0000129 L7 protocol for half-life 2:DM applied ? (where are additional l7 filters ?)

    0000091 connections/ports get extremely long TTL and stay for days
    0000263 Input field value checking does not prevent to save settings
    0000433 extra line break on setup screen

    0000363 /tmp/resolv.conf not set properly in Client Bridge mode
    0000382 Various JavaScript Warnings and Errors
    0000332 Index.asp unusable in Safari
    0000394 Access Restrictions > Inbound traffic policy not working
    0000422 Turning TFTPD off
    0000421 Firmware Upgrade page changes
    0000417 06/12 build: /sbin/check_ps doesn't work properly

    some statement about the long delay between the release. currently i'm heavy working
    various issues like l7 filter problems etc. which eating up my time. the l7 filter problem
    for example (access restriction services, qos etc.) is caused by simply bad l7 protocol
    definitions. i tested various protocols today and some are not working from scratch.
    this release includes a debug enabled version of l7proto, so you can check if something works
    or not, or is caused by dd-wrt itself.

    0000385 Some pages don't open help files in new window - problem to return
    0000410 AP Watchdog kills WPA wireless LAN
    0000374 03/12 build: "uptime" doesn't give current time

    0000282 Remote Router Access : https check box disabled
    0000356 03/12 build: DHCP Clients table shows empty
    0000289 Wireless Clients -> Radio Signal RSSI -> Status not resetting when no signal
    0000337 2/12/05 moto mini version upgrade does not work
    0000098 JOIN does not work when SSID contains a <space>
    0000340 LAN port 4 and WAN port mixed up on 02.12.2005 std release
    0000372 Static IP: no WINS field for DHCP server
    0000353 DNSMasq doesn't work as DHCP Server
    0000359 Masqed MACs in DHCP Client Table
    0000351 Management.asp page - Java Script Errors
    0000369 Unmask MACs in DHCPTable.asp

    0000344 Clients MACs not shown in full (Status->Wireless)
    0000346 12/02/05 - Can't remove static DNS entries
    0000345 02/12 build: DHCP server broken, DNSMasq not running ?
    0000348 udhcpd does not respect LAN domain setting
    0000342 Reopen: 0000328: httpd hangs in QOS Page (qos disabled) when i press a "Add" button.
    0000343 Info Page - Java Script Errors
    0000350 Change "Status Site" to "Sys-Info Site"
    0000110 Wireless Security page contains errors
    0000333 Wireless Status Page - Encryption Info Out of Place
    0000334 Java Script Error on Port Services Page
    0000331 Java Script Error on Administration Page
    0000111 Access Restrictions page contains errors


    - new wireless client/ap/wds table for info and wireless status

    0000309 BrainSlayer is currently sick, so bug fixing is a little bit delayed
    0000318 Can't setup static ISP settings on dd-wrt v23b 24.11
    0000048 Blocked Services on Access Restrictions Not Working
    0000308 /usr/sbin/rflow missing from v23b2 2005/11/24 vpn build
    0000306 No access to configure SNMP agent in GUI
    0000288 Static IP Internet Connection Type Cannot Save Settings
    0000281 DHCP-Relay: dhcp-fwd not starting => error
    0000279 Formatting in status:wireless
    0000297 wrong netmask in /tmp/dnsmasq.conf

    0000276 openvpn version 2.02 wich is used in the vpn version contains security bugs
    0000269 cgi method show_modules() doesn't (jffs|mmc)/etc/config for files
    0000265 snmpd binary missing from V.23b VPN 2005/11/23 build
    0000272 Status page incorrectly reports DHCP is enabled in Client Bridge mode
    0000273 udhcpc starts new instance of openvpn on every wan lease renewal
    0000275 Cant change Static DNS in Setup/Basic Setup

    - KAID updated to latest version
    0000133 Scheduled reboot lower time limit
    0000250 GUI artifacts in Setup>Basic Setup during client bridged mode
    0000253 SSH doesn't start automatically when first enabled
    0000224 Backup/Restore issue with WDS

    - flashing of larger images than 3.8 mb is now possible (on gs models)
    - some text corrections in openvpn client
    - protocol selection added for openvpn clients
    - reverted ebtables module handling for speed improvement

    - openvpn tunnel route introduced
    - dnsmasq lease delete recoded, handling of lease files improved
    - various build oriented problems fixed
    - changed kernel module handling to get down the binary size

    0000232 VPN Version (11/18/05) disconects...
    0000231 VoIP-Version on 18/11/2005 bricked WRT54GS !!!
    0000229 DNSMasq seems not to give out IP addresses (Nov 18)
    0000242 Disabling logging
    0000240 can't connect via https

    the last regulary feature has now been added. OpenVPN
    this is made for client only connections and can be configured under Administration->Services.
    it works as wireless client as well as with other connection types. use the dd-wrt.v23_vpn
    distribution if you want this feature in your life

    - Motorola support finally fixed and works great.
    - introduced new switch management drivers (thanks Nbd) (not used yet, but will come in v24)

    0000170 WRT54G or GS hangs when (mtd erase nvram) then (reboot) from a telnet session
    0000219 Mem info is in status is gone
    0000224 Backup/Restore issue with WDS
    0000176 router name incorrect in /etc/hosts - symptoms seen in nslookup
    0000221 Admin > Services > DHCPd > MAC field shows extra characters, memory buffer overflow?
    0000161 XBOX Kaid is not in VOIP but KAID Configuration is still in the gui.

    i worked the whole day on the morotola wr850g network issue, so not many updates today
    0000185 Blank QoS Service Page
    0000202 additional lib paths in /etc/
    0000170 WRT54G or GS hangs when (mtd erase nvram) then (reboot) from a telnet session

    trx binary problem fixed for motorola WR850g routers
    wireless mac problem solved for various non WRT models (generic solution)
    0000038 DMZ LED doesn't work on WRT54G v.1.1 with all v23b2 builds
    0000191 lan port 4 gets swapped with wan on wrt g v4 models if you reset the configuration
    0000188 WRT54g v4 can't connect to the internet
    0000148 Memory status incorrectly formatted at the bottom of main status page
    0000194 HTB: bad diff in charge strikes back
    0000190 Using v23 build 14, I cannot use the 4th LAN port. 0000186
    0000186 LD_LIBRARY_PATH is not set in /etc/profile

    0000161 No gzip in 14.11.2005 ?????
    0000167 ipkg broken in V23b 14-11-05
    0000168 DD-wrt v23 B2 141105 SE505 v2 bricked
    0000109 router entry in /tmp/hosts corrupted
    0000097 Router\client network settings showing on front page of GUI
    0000181 Build 14/11: "kernel: HTB: bad diff in charge" messages ...???
    0000037 v23b2 07/11 and 08/11 builds BRICK WRT54G v.1.1 and v.1.0
    0000178 DHCPd static mapping doesn't work

    kernel updated to 2.4.32-rc3
    new option in setup added (client, client bridge only) which allows you to use
    the wan port as additional switch port.
    arp command added

    0000076 probably iptables 1.3.4 breaks fwbuilder scripts
    0000094 2 "DHCP Server" lines in DHCP active IP table page
    0000044 dnsmasq: client lease time 13097 days...
    0000089 pptp client (services)
    0000132 IP, ports, don't need units (s)
    0000008 UPnP broken
    0000145 Rebooting, brings me to unformatted menu


    0000097 Router\client network settings showing on frot page of GUI
    note: new feature added which masquerades macs (administration)
    0000063 Logging fails
    0000084 Missing Menu & No WAN connect (WRT54GS V2)
    0000082 Sipath text correction
    0000092 Wireless_radauth.asp page incorrectly formatted
    0000014 Some pages don't apply changes "on-line"
    0000087 Tab menu error

    motorola works again
    0000050 SI units (watt, mega, second)
    0000053 double static entries in /tmp/hosts
    0000075 Formated help files available here
    0000074 Entries in /tmp/hosts need to be fully qualified
    0000060 DHCP Reserwation don't wort
    0000028 update udhcpc to latest version from Busybox

    additionally the dhcpc vendor id can now be configured by the web interface under

    the WRT54G1.0/1.1 bug is still under investigation. it looks like the network interface comes not up
    to verify i need a serial adapter output

    new udhcpc introduced
    various web gui bugs fixed (wireless mode etc...)
    ddns code changed
    resolved issues from bugtracker:

    0000003 Chilli Does not start in v23beta2 7th November release
    0000017 Dynamic DNS broken
    0000012 Bad password saved
    0000011 mtd erase nvram don't works
    0000027 Wireless Network Mode Not Displaying...
    0000028 update udhcpc to latest version from Busybox
    0000042 Remote HTTPS checkbox can't be disabled in webgui.
    0000038 DMZ LED doesn't work on WRT54G v.1.1 with all v23b2 builds
    0000039 Static DHCP and local DNS issue
    0000047 Transmission Rate saving problem

    new backup/restore code introduced (old backup format is incompatible now)
    Wireless MAC filter crash bug fixed (GUI)
    l7 protocols updated

    busybox upgraded
    iptables upgraded to 1.3.4
    some logging issues fixed
    motorola WR850G support added (use dd-wrt.v23_mini_moto.bin for tftp flashing)
    nocat segmentation fault fixed
    client mode fixed
    some left httpd leaks fixed

    voip build is now really a voip build (sorry for misstake)
    some typos fixed

    chillispot watchdog added and radius retrycount modified (10 now)
    siemens se505 detection enhanced (for those with 00:90:96 macs)
    kernel messages reduced (okay removed, which brings me some free memory)
    disabled HTTP/HTTPS issue fixed (happends if you change somethin in services,hotspot, or keep alive)

    client bridge mode reworked (wpa in bridge mode verified, wpa2 still not)
    ethernet driver changed
    wl500g-deluxe is now fully working with all features. (reboot problem solved too)
    ifconfig enhanced (for supporting multiple ip's per interface)

    linux semaphore code reworked (asus deluxe robo switch support)
    robo switch and vlan config reworked (asus deluxe robo switch support)
    wan support added for asus wl500g deluxe

    Siemens SE505 support finished. works and fully tested (mini,std,voip)
    (see hwsupport.txt for additional notes)
    added linksys wds/wpa fixes

    iptables reworked for memory optimization
    library size optimization added
    possibly tx/rx antenna selection problem fixed

    service restart functions enhanced. (some services arent restarted correctly from the Service GUI etc.)
    Siemens gigaset 505 detection introduced (not finished yet, so dont play around with it)
    iptables fix for upnp (please try it)
    FilterSummary table header fixed

    webgui fix for dhcpd (crashbug cause of missplaced pointer var)
    wbr2g54s typo fix (wireless driver wasnt loaded)
    merge of latest squashfs sources to the lzma squashfs code (decreases memory usage)

    static dhcp table memory fault fixed
    BUFFALO WBR2G54S support code added (thanks Emir Erkocevic)
    fixing funny guy bugs
    (port services, qos services etc, missaligned labels etc.)
    fixed conntrack issue (ftp wasnt working etc.)
    dnsmasq crashbug fixed (dhcp usage if hostname is null)
    dnsmasq leasetime bug fixed

    removed unused web-cgi code
    removed unused linux modules
    httpd (ssl) staticly linked to matrixssl (smaller)
    udhcpd statics fixed
    l7filter fixed
    dnsmasq does now support lease informations too

    dynamic dhcp static lease table added
    dnsmasq dhcp does now support static leases too
    build date added to the header line
    2 new fancy styled added (red and green by Guilty Spark)

    client routed mode missplaced bridge fixed

    catched 2 long term memory leakes in httpd daemon
    possibly crashbug fixed in uclibc (can also cause the strange upnp crashes)
    uclibc pipe function optimized (possibly you get enhanced speed now)
    building bug with std version fixed (wrt54g binary only), sorry about this

    zlib support added for dropbear

    pppoe support for wireless client mode added (does this really work?)
    zero config for chillispot updated
    port forwarding port from/to swapping issue fixed

    additional port forwarding table added (with from and to assignment, yes)
    multicast proxy added

    ssh fixed
    auto disable for backup and firmware upgrade within https environment
    ipkg repository list updated
    kaid removed from voip version due fw size limit
    ebtables is back for qos
    (warning, lowers your network speed if you're using it)
    thats means also, never use qos with LAN/WLAN selection if you want high
    performance. use wan based networking instead

    wireless mac issue fixed (asus only)
    logging issue fixed (auto switching loglevel)
    port forwarding bug fixed (tcp/udp switch)
    port forwarding save bug fixed
    connlimit/connrate added
    internal memory management optimized (webgui only)

    progressive port forwarding added (gui)
    progressive port triggering added (gui)
    mixed readded for client mode
    some internal kernel changes (will be used in future)
    new pptpd version
    new dropbear version

    upnp site added (thx for your great patch nohud)
    wan detection dix (again, thx nohud)
    client mode fixed
    some small asus related fixes added
    symbols for tcpdump added
    matrixssl updated
    new design added (by Daniel Wikar)
    updated pptp client by Cesar Gonzales

    ssh is back (mini version)
    ASUS-WL500G Deluxe is supported now
    wireless mode selection fixed. (mixed mode problem)
    kromos style fixes integrated
    WMM/WME additions within the network code
    another try for a upnp solution

    kernel updated to the very lates 2.4.32-RC1 version
    recoded some function in the broadcom shared lib
    cesar gonzales pptp client updated again
    pptp for dhcp fixed (webgui)

    bridge and adhoc mode added in wireless status and info page
    ftpput readded

    radvd config fixed
    pptp use dhcp added
    upnp code updated

    bridge mode works now with wpa2 and wpa1
    dd-wrt christmas light mode implemented (try to find out how to trigger it)
    preamble settings changed (long, short, auto now supported)
    dhcp dnsmasq button fixed for mini version

    mac filter memory fault fixed
    port forwarding memory fault fixed
    firewall/startup save hanging fixed
    jffs working again (cleaning and enabling can cause up to 3 reboots)
    ap isolation setting fixed
    dhcp-fwd setting index.asp page bug fixed
    robocfg vlan switch configuration utility added
    ftpget readded
    connect/disconnect button fixed on status_router page (pppoe etc.)

    buildprocess redesign
    cesar gonzales ppptp client module integrated
    chillispot updated to latest cvs version (1.0 preview)
    l7 filters updated
    pppoe,l2tp etc. password field fix
    telnet readded

    startup deadlock fixed for first time flashing
    imq device fixed (QOS WORKS NOW)
    Gaming QOS added
    router status page fixed
    ppp fixes for l2tp

    radvd config added
    dnsmasq button bug fixed (can't be disabled if enabled once)
    wireless advanced settings bug fixed (settings lost after reboot)

    dhcp-fwd fixed (/var/run/dhcp-fwd issue)
    wdswatchdog respawning issue fixed
    http deselection bug fixed
    chillispot anyip feature added
    use DNSMasq as DHCP Server added
    dnsmasq upgraded to 2.23
    busybox upgraded to 1.01
    router style setting reintroduced
    chillispot native process watch integrated
    httpd security bug fixed (negative content length)
    sipath fixed (again, i know)
    WanMac GUI fixed (sipath tab missing)

    voip version fixed
    building problem fixed which causes various errors whith services (ssh, chilli etc)

    v4 support working, v4 serial support fixed
    chillispot interface selection fixed
    linux netfilter enhanced
    dhcp store on jffs radio button issue fixed
    remote management for https added
    belkin support added (please do not test, not finished)
    basic version reintroduced
    chillispot security fix (thx tony)
    typos fixed
    ipfilter definition bug fixed

    more v4 related fixes
    sipath problem fixed (chmod)

    license information added within the distribution file
    site survey->join button added
    some more web bugs fixed
    WDS Stability enhanced
    MAX Associated Clients setting implemented (see Wireless Advanced)
    WMM support integrated (see Wireless Advanced)
    latest linksys driver integration

    WBR-G54 support code (untested)
    configuration backup/restore fixed
    playing around with some memory optimizations
    integration of the latest mipsel kernel fixes (thx nbd)
    upnp fix
    wep key input field fix

    snmpd 802dot11 mib integration
    linux wireless extension integration
    site survey is working now
    jffs bug fixed
    nocat is now working correctly
    QOS Services/Filter Services crashbug fixed
    some fixes in client bridge mode
    various web fixes
    http redirect added/smtp redirect fixed
    administration page well structured
    some mem leaks fixed

    small fixes on client mode
    third update this night, again config issues with nocatsplash fixed
    second update this night, recompiled nocatsplash
    nocatsplash (yeah, i know many people are waiting for it but untested) (thx too EWRT team)
    wpa/wpa2 fixes (for client mode and wds, poorly tested but worked)
    ip-up uses now a different way for IPLOCAL and IPREMOTE detection (sipath support)
    shell script cgi support added to the linksys httpd daemon (sipath support)
    http/https enable/disable problem fixed
    lan subnet mask setting enhanced
    new web gui (with 3 selectable styles)
    voip sipath support
    transparent client bridge support
    dhcp forwarding support
    mac filter table enhanced to 100 entries
    wireless speed problem fixed
    kernel 2.4.30 integration

    v22 final:
    dropbear fixed
    wrong client ssid association fix
    bird fix, for disabled routing
    dropbear updated to latest version
    site survey typo fix (title)
    reboot scheduler cron fix

    reboot scheduler web fix
    rflow crashbug fixed
    try to fix the ssid problem
    rflow/macupd script fix
    reboot scheduler initialisation fix (error in script)
    ssid join fix (experimental)
    backup/restore variables updated to include all common modules
    chinese (traditional) updated with latest language file
    ipkg config updated with more options for smbfs and mmc storage support
    mmc/ipv6 only included in full version now
    smtp relay option for forwarding smtp requests to a central server
    more chillispot options in the administration area
    filter changes
    path env fixed
    overclocking code removed again
    more pppoe fixes by ice-man
    pattern header fixed
    pppoecd module fix by ice-man
    asus WL500G support (internally, not included in this release)
    tftp pattern added for specific models
    kernel speed optimization added
    linksys patches removed, bricking many router models
    added latest fixes from linksys sourcecode (stability related)
    routing page fixed
    ipp2p filter updated
    linksys pppoe fix (by ice-man)
    dnsmasq fixed
    pppoe module updated (2.4.3 with some mods)
    MMC/SD Card support added ( look at for HW mod)
    afterburner selection fixed
    dnsmasq updated
    chinese language fix (codepage)
    routing interface selection fixed
    wlconf enhanced for wpa2 support
    new startup code added
    bulgarian added
    chinese (traditional) added
    port forwards now increased to 30 rows
    radvd compiled in now (no web configuration yet)
    ipv6 support (with web configuration)
    source now compiled with gcc 3.3.5
    wrt-radauth mactype and shared key type fixed
    webfiles updated again
    lzma kernel loader updated
    snmp map fixed (old style dd-wrt v20)
    wrt-radauth webmenu fixed
    wrt-radauth mactype fixed
    macupd updated
    dutch added
    portuguese (brazilian) added
    croatian language added
    gnu zebra routing exchanged with bird
    bgp routing code internally added (webcode not finished yet)
    kernel lzma compression added
    dropbear readded in basic firmware
    WRT54G V3 support

    kaid mac config fixed
    chillispot startup fixed
    wireless advanced helpfile updated (thx duality)
    wireless advanced fixed
    Wireless short/long preamble selection added (thx duality)
    wireless access option added in wireless advanced menu (thx duality)
    chillispot dhcp interface selection (lan,wan,lan+wlan)
    chillispot additional configuration added
    client leases stored to jffs2 added (if enabled)
    multilanguage support for German,Spanish,French,Italian
    web server improved
    several web bugs fixed (thx, Cesar and Duality)
    jffs2 is working now
    firmware splittet in 2 versions.
    basic = does not contain dropbear, chillispot, samba and kaid
    full = all features of the common firmware

    heartbeat server ip problem fixed
    Xmit info in info page
    uncounted other fixes so far
    Chillispot 1.0 RC3 implemented

    site survey fixed
    wrt-radauth enhanced with portal function for unauthorized users
    wds-watchdog nvram initialisation fixed
    various web bugs fixed (thx Cesar)

    pppoe fixed

    expert mode enabled by default
    Spanning Tree Protocol selection (disable it if you're using Comcast)
    JFFS2 Config Module (jffs2 is now disabled by default, clean option added)
    jffs init now moved back to preinit script
    ADD/EDIT Services button added to QOS Page
    Reboot Button added on Administration page

    by Cesar Gonzales
    Reboot Scheduler
    WDS Watchdog

    by Ah-Man
    PPPOE Module Type Selection (Linksys PPPoE is now default, RP PPPoE is optional)

    dhcpd fixed
    chillispot upgraded to 1.0 RC2
    chillispot configuration fixed
    wrt-radauth menu is now full english

    jffs2 writeable flashfilesystem support (mounted on /jffs2)
    chillispot implemented
    wrt-radauth, enhanced to support a configureable amount of unauthicated users logged on
    macupd updated with minories latest sources
    dhcpd updated
    mtd command introduced (imported from OpenWRT)
    memory enhancements to free much more space than ever before
    site survey fixed
    static routing fixed
  2. devil-strike

    devil-strike Network Guru Member

    This is useless :thumbdown:
  3. matthiaz

    matthiaz Network Guru Member

    First posting of TheCoseyExpress and it already sucks!!! GO AWAY!!!!
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice