CIFS and windows XP, I'm obviously missing something..

Discussion in 'Tomato Firmware' started by U121, Mar 29, 2007.

  1. U121

    U121 LI Guru Member

    I want to use a shared folder for storing the bandwidth logs on a general storage XP box running more or less 24/7. Problem is I just can't get it to work.. the log says
    Mar 29 01:59:00  user.err kernel: CIFS VFS: Error connecting to IPv4 socket. Aborting operation
    Mar 29 01:59:00  user.err kernel: CIFS VFS: cifs_mount failed w/return code = -145
    I'm assuming the "error connecting to ipv4 socket" means it can't connect to the computer for whichever reason. then the log goes on with recurring
    Mar 29 02:05:43  user.err kernel: CIFS VFS: Send error in SessSetup = -13
    Mar 29 02:05:43  user.err kernel: CIFS VFS: cifs_mount failed w/return code = -13
    which repeats every two seconds for a while..

    I've allowed the router complete access through the firewall and all, and since others are obviously able to make it work all fine I'm wondering what I'm missing.

    thanks in advance.
  2. tstrike2000

    tstrike2000 Network Guru Member

    All you should need to use is the IP Address\Share Name and the workstation user and password to authenticate.
  3. U121

    U121 LI Guru Member

    okay.. now that is weird, after some experimentation I see that using passwords with capital letters is a no go, got it to work after I changed the user accounts password to a combination of letters and numbers ( as before) but no capitalised letters.
    should I report this as a bug perhaps?
  4. pharma

    pharma Network Guru Member

    I think it has something to do with your OS or how it's setup. I just tried under XP SP2 using both the Administrator account and the Guest account and it worked using all lowercase and all uppercase passwords.

    BTW: You can use the "guest" account for CIFS mounts. The pw is the same as the account name.

  5. njeske

    njeske Network Guru Member

    I have my CIFS mount password setup as a mix of capital letters, lowercase letters, and numbers. There may be a local policy on your XP machine that is making an all caps password not work quite right for remote connections.

    glad you got it working though.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice