CIFS + Bandwidth Monitoring Problem

Discussion in 'Tomato Firmware' started by casanova99, Oct 19, 2008.

  1. casanova99

    casanova99 Addicted to LI Member

    Long time reader, first time poster here.

    I run Tomato 1.21 on a WRT54GL v1.1 and it has been running great. I love this firmware and prefer it over DD-WRT. However, I have one strange issue. Whenever I set up a CIFS share in the CIFS client section, and then configure Bandwidth Monitoring to save to the CIFS share, the Bandwidth Monitoring "breaks".

    By break, I mean that if I click on any of the bandwidth graphs (real time, daily, etc.) I get no graph displayed in my browser and an error complaining about rstat not responding. Rebooting the router does not fix it. If I switch back to "Save to RAM (temporary), everything immediately goes back to normal except that I lose all of my bandwidth story :mad:

    I have tried with 2 different CIFS shares on different servers, and both are writable from tomato so this is not a CIFS server, permissions, file system issue. See below:

    Tomato v1.21.1515
    BusyBox v1.2.2 (2008.07.26-14:43+0000) Built-in shell (ash)
    Enter 'help' for a list of built-in commands.
    # df -h | grep -i cifs
    -                       368.1G    128.2G    239.9G  35% /cifs1
    -                         2.8G    248.7M      2.5G   9% /cifs2
    # echo HELLOWORLD > /cifs1/readme
    # echo HELLOWORLD > /cifs2/readme
    # cat /cifs1/readme
    # cat /cifs2/readme
    This issue is repeatable -- even after reconfiguration, after a reboot, hard power cycle, and even a re-flashing. I also have an ASUS WL-500GPV2 that maybe I will test on, but right now I need the stock firmware for the USB storage and printer support.

    Any insight or ideas would be helpful. Thanks in advance.
  2. Mastec

    Mastec Network Guru Member

    All I can add is that it sounds like it's not reading the share folder correctly, I ran in to this. If you are on a Windows machine, what I did was create a new user with name and password. Created a share folder, set the proper permissions. Logged out of that user and logged back in to the main. Then configured CIFS client with path, username and password, no domain. Clicked Save both were mounted.
  3. casanova99

    casanova99 Addicted to LI Member

    Thanks, for the tip. I tried making a new CIFS share and still no go.

    So I have to ask, does anyone have good advice on the implications of saving to RAM (temporary)? Exactly how much data does this occupy and I guess it grows over time? I would like to avoid lots of small writes to the JFFS2 partition or the NVRAM since they both reside on the flash chip, and since I'm having CIFS troubles, that does not leave many options except custom path, which won't help. :confused:
  4. azak

    azak Addicted to LI Member

    I was able to reproduce your issue after redirecting the save file to CIFS.

    What you need to do is check Create new file/reset data then Save on the Bandwith Monitoring administration page.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice