CIFS mount error

Discussion in 'Tomato Firmware' started by lazx888, Dec 7, 2006.

  1. lazx888

    lazx888 Network Guru Member

    Tomato v1 (and earlier) cannot mount SAMBA share.

    No error messages on SAMBA server...

    Any ideas on how to fix this?
  2. Devotedfollower

    Devotedfollower LI Guru Member

    same prob

    same prob here guys, anyone got a solution to this? thanks :)
  3. bokh

    bokh Network Guru Member


    CIFS works here without any problems on FreeBSD 6.1 and Samba 3.0.23d.
    Below is my smb.conf - it might help a little.
    Also I have the WRT54 in the hosts- and lmhosts-file.

       workgroup = WORKGROUP
       server string = Samba %v on %L
       netbios name = FREEBSD
       interfaces =
       remote announce =
       bind interfaces only = Yes
       socket options = TCP_NODELAY SO_SNDBUF=8192 SO_RCVBUF=8192
       security = user
       load printers = No
       log file = /var/log/samba/log.%m
       max log size = 50
       max open files = 4000
       preferred master = No
       local master = No
       dns proxy = No
       comment = Home Directories
       valid users = %S
       browseable = yes
       writable = yes
       create mask = 0644
  4. digitalgeek

    digitalgeek Network Guru Member

    I have had no problems with cifs... in fact (like everything in Tomato) I setup everything from within the gui with out any problems. worked on the first try.
  5. luckman212

    luckman212 LI Guru Member

    me 2... using CIFS with my Infrant ReadyNAS NV+, no problems...... :)
  6. bokh

    bokh Network Guru Member

    In a Dutch forum a guy had the same error.
    Samba gave him this error at first:

    [2006/12/12 21:08:22, 0] smbd/negprot.c:reply_nt1(316)
      reply_nt1: smb signing is incompatible with share level security !
    He tried my smb.conf and changed from "share level security" to "user level security". That helped him! :)
  7. devil-strike

    devil-strike Network Guru Member

    I have the same problem, i have cifs enabled, and the router see the hard disk 50GB/30GB free, but rstats gif this error: The rstats program is not responding or is busy. Try reloading after a few seconds.
  8. bokh

    bokh Network Guru Member

    Sounds like you have a problem with rights on that file to me. Check if you are allowed to write to the remote file by checking the user-permissions on the share.
  9. devil-strike

    devil-strike Network Guru Member

    Thnx, thats whas the problem :D
  10. lazx888

    lazx888 Network Guru Member

    Just updated to samba 3.0.24... still getting the same error.

    The share mounts fine from other samba clients.

    User security level is being used.
  11. digitalgeek

    digitalgeek Network Guru Member

    You could check the permisions on the folder/drive you are sharring, and make sure that the user tomato uses to login has full access to the folder you are sharing. I have problems with this in the past... and check to make sure that the permissions are applied to all child elements.
  12. roadkill

    roadkill Super Moderator Staff Member Member

    SAMBA details

    error -13 is access denied
    error -1 is no permissions
    try to run mount to a smb share to test it that's what tomato is doing

    mount -t smbfs -o username=USERNAME,password=PASSWORD //PATH TO SHARE /MOUNT POINT

    and set your samba to user level security and don't forget to add the user to samba so he could mount the share...
    when mount will work so will Tomato
    good luck
  13. lazx888

    lazx888 Network Guru Member

    Seems to be working now.

    Not sure what was the cause, but here is a summary of all the things I tried:

    - user security level setting in smb.conf
    - update of samba to 3.0.24
    - ensuring the user/password are correct
    - ensuring samba folder permissions are correct

    The last thing I tried before getting tomato to mount the share was using a shorter password (<10 characters). The old password on the share was a random character long password (>20 characters). It mounted fine with smbclient, but tomato could never access the share.

    Investigated this a little more, and the CIFS password box (Administration -> CIFS Client -> Password) can only handle 16 characters.


    Use a password of 16 characters or less.
  14. Soljia

    Soljia Addicted to LI Member

    I hate to be a gravedigger, but I also have the same problem.
    Samba Share Server
    OS: Windows Server 2008
    Internal IP:
    Shared Folder: Router
    Share Users: Administrator, Domain Admins
    Share Permissions: All have full control

    /cifs 1
    Enabled True
    UNC: \\\Router
    User: Administrator
    Password: **************
    Domain: HUMES
    Executed when mounted:
    Total/Free Size: 74.53 GB / 42.64 GB

    Under Bandwidth Monitoring I have CIFS 1 as save location.

    I don't understand, it mounts fine. The user has full control (read and write).

    Again sorry for gravedigging.
  15. port2121

    port2121 Guest

    Soljia, I've spent the last few hours trying to figure out the same problem you are having. A pack of smokes and a break away from the computer later I finally got an idea of something to try, and it f'ing worked!

    This is what I did:

    Set [Save History Location] to RAM (Temporary) then click save at the very bottom

    Go down to [Backup] and manually download (save) the tomato_rstats file to the Share Folder, \Router ,in your case.

    Now go back to [Save History Location], and select CIFS 1, then click save at the very bottom.

    Now you should be able to view the Bandwidth and its subcategories without getting the error, and it should be saving the stats at the frequency you've selected.

    It seems you need a tomato_rstats**.gz in the share folder to start off with , and it does not create one via the CIFS route, so you have to download it manually.

    I imagine this is a problem alot of us have ran into, since this step isn't stated in any documentation (that I could find) for Tomato. Or maybe I'm a

    Hope this helps
  16. sskljdalsk

    sskljdalsk Networkin' Nut Member

    OK, I'm going mad here. Trying to solve the same problem you guys were 4 years ago!

    I've tried dozens of variations and I'm getting no where fast. Tried shares on both of my NASs and in the public folder of my Win8 PC...nothing mounts.

    Can someone please help and point me in the right direction. I am, if course, a Noob, but I am trying!
    Err...ignore this...more digging finally produced results and pointed out the seemingly dumb-ass error ot trying to mount a dir rather than a share. Apologies.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice