CIFS + Ubuntu 7.10 samba shares

Discussion in 'Tomato Firmware' started by paped, Feb 28, 2008.

  1. paped

    paped LI Guru Member

    I am hoping somebody can help I have just upgraded my always on server from XP pro to Ubuntu and I have tried to replicate the CIFS configuration that I had on my XP box with no issues on samba but cannot get it working. I know the shares are working as I can connect to it in XP on my laptop with no issues but all I get with Tomoto is the term "mounting" and in the log file I get the following repeated a number of times..

    Jan 1 00:21:14 router user.err kernel: CIFS VFS: cifs_mount failed w/return code = -6

    I have checked the linux logs for my routers IP and samba is saying that it cannot find the mount point /xxxxx (xxxxx = whatever the mount point is at that time, I have tried a number of different shares)

    I have found a couple of posts saying that I need to upgrade the samba V3 but Ubuntu 7.10 already has this level on Samba so I am a bit baffled as to what can be happening here. As every share that I have tried and failed on Tomato mounts fine in Windows with the same user and password details????

    Does anybody have any ideas of what to try? As I need to get this working so I can keep records of usage on cifs and get snmp working again....

    Thanks in advance for any ideas given.
  2. kevanj

    kevanj LI Guru Member

    Are your CIFS mountpoints defined by name or IP? If by name, can your router resolve the name of your Ubuntu server? If not, try defining the mount points by IP.

    I just set up a share on Ubuntu Desktop using Samba, and my router can mount it OK, mount is defined by IP.
  3. paped

    paped LI Guru Member

    Kevanj thanks for your response I have changed to using an IP address rather than DNS name and it now works....

    but i have notice something funny that I thought I would post in case it helps anybody else, the first time I tried with an IP address it did not work I entered it as \\IP address\directory. So I did some digging on the web and thought that I would give it a try using linux type forward slashes i.e. //IP address/directory. Now when you click save the webpage changes it back to windows type back slashes again i.e. \\ but it worked!!!! and now regardless of back or forward slashes being used so long as I DO NOT used the dns name (us the IP address instead) it works... no idea why it worked or what putting the slashes in the wrong way on the initial attempt did but if your are having problems connecting to samba shares may be worth giving it a try!!!!
  4. Sweets

    Sweets Guest

    I just installed tomato 1.17 on my WRT54GL two days ago, and have spent most of that time trying to get it to do this properly. I'm on Windows XP so not all of the things google came up with applied to me. After trying at least a hundred different things and only having it result in a different error return code, I was about to give up. I honestly wasn't very optimistic that something this simple would be causing my problems, but after trying everything else I didn't see any reason not to give it a shot.

    I should also note that I didn't even have to save for it to change the slashes on me, just changing Firefox tabs from the router's page to this thread and back reverted them to backslashes.

    Anyway, I only joined to thank you, as it's finally mounted. If I hadn't happened across this page I would never have thought to try that. Thank you again. :)
  5. sprice1

    sprice1 Guest

    Holy freakin hell. Im running Ubuntu 8.04.1 and Tomato 1.21 and I had not been able to mount my share for at least a month, until I saw this post. I hate to resurrect a long dead one, but changing the backslash to a foreward slash fixed my issue. I have my folder set as a share and writeable by me, and the UNC path that worked is //, then user name and password

    I joined just to say thanks!
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice