client6_send: transmit failed: Network is unreachable

Discussion in 'Tomato Firmware' started by pnevma, May 14, 2014.

  1. pnevma

    pnevma Network Newbie Member

    I'm using a Asus RT-N12 with the latest version of Shibby's tomato firmware (v117, though the problem also appears with Toastman's firmware, too.).

    When I enable IPv6, it doesn't initially work when the router is started. The log will spout out error lines like:
    May 13 22:54:26 Tomato daemon.err dhcp6c[788]: client6_send: transmit failed: Network is unreachable
    I have to manually go to Basic > IPv6 in the web interface and click Save so that the related services are restarted, and then IPv6 works correctly and the aforementioned error line goes away.

    I'm using DHCPv6 with Prefix Delegation with the default (64) prefix length on TWC.

    I think this is a bug of some sort but I'm not sure. Are there any workarounds I can add as a startup script so that I don't have to manually do this every time my router is restarted?

    Thanks for any help.
  2. vindicatorr

    vindicatorr New Member Member

    I see this is an old thread, but wanted to check in if it "really" worked.
    Do you have a v6 address assigned? google "enable-ipv6-support-for-home-network"
    (note the 3rd image "Verification").
    He used PPPoE while Mediacom uses DHCP.

    I also got that "transmit failed" error and when I tried your fix, my log would start filling up with redundant info over and over every couple of seconds:
    dnsmasq-dhcp router advertisement on br*
    dnsmasq-dhcp IPv6 router advertisement enabled
    daemon info dnsmasq using nameserver
    daemon info dnsmasq read /etc/hosts

    I'm using ToastMan's v7507 that I built a month ago.
    Mediacom seemed to push out v6 recently: google mediacomcable "IPv6 Timeline"

    1) I'm too new to embed links, thus the googles.
    2) Reattempts to Post STILL says I have embedded links which I don't.
    3) Looks like it was the dot between daemon and info causing linksysinfo to think links were being used.
  3. pnevma

    pnevma Network Newbie Member

    Sorry for the late reply, I didn't get notified that there was a new post.

    The issue still persists for me. I'm now using 1.28.0000 MIPSR2-128 K26 MiniIPv6, shibby's build, on the same Asus RT-N12 router. This is with Time Warner Cable.

    IPv6 is definitely working after doing what I said in my original post. I get a 10/10 on test ipv6 for example.

    I've attached a full log of what happens after I reboot the router, wait a minute, and then click Save on the Basic>IPv6 page again, so as to get IPv6 working.

    This line is the first after clicking Save:
    May  8 09:33:13 Norvuc user.debug init[1]: rstats stopped.
    I've also tried telneting into the router manually and doing:
    service dnsmasq restart
    service dnsmasq-dhcp restart
    service dhcp6c restart
    ... but that doesn't fix it, only clicking save on the IPv6 page fixes the problem.

    Attached Files:

    • log.txt
      File size:
      25.3 KB
  4. vindicatorr

    vindicatorr New Member Member

    No worries. I thought this might also be of interest (forums.mediacomcable com/index DOT php?&topic=26599.msg244122#msg244122) (still too new to post a link) especially considering the timing. The guy (snkprescott) worked with an ISP and uses TWC.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice