Comcast DHCP / STP explanation?

Discussion in 'DD-WRT Firmware' started by kjmcdonald, Feb 9, 2006.

  1. kjmcdonald

    kjmcdonald Network Guru Member

    Hi all,

    I've searched the forum for a problem I'm having with many non-linksys firmwares, and getting an IP address from Comcast.

    I stumbled across the suggestion to disable STP as a possible fix. I'm going to try that when I get home.

    Is there somewher I can readup on the answers to the following:

    What are the details of this problem?
    What is STP?
    What do I lose with STP off?
    Why does turning STP off help solve this?
    Is comcast broken?
    Why does the linksys firmware work?


  2. Richieus

    Richieus Network Guru Member

    Hello, I dont know anything about yor problem but STP, if its the one that Cisco use its the Spanning Tree protocol

    Its uses to stop packet loops on multiple switches.

    If you only use the 1 router turning STP off you shouldnt have a problem.

    But im no expert on this protocol i've only ever covered it breafly.
  3. kjmcdonald

    kjmcdonald Network Guru Member

    More Info...

    Well. Now that I'm home Disabling STP doesn't appear to have any effect on this.


    I have a Linksys Cablemodem, wired to a WRT54GS V1.1.

    When It was (or if I go back) running the linksys firmware I have no problems getting a DCHP address from Comcast through my cable modem. I live in Lowell, MA.

    When I stated trying out alternate firmwares, I don't remeber seeing the problem till I loaded Sveasoft Talisman 1.0.4 - though I didn't stick with the others very long so who knows.

    On Talisman whether the cable modem was powered up for a while first, or whether the router was powered up first, I couldn't get an address no matter what I did.

    Finally the work around I found was to plug my laptop into the cable modem directly, and get an address, then plug the GS into the modem, make the GS clone my laptop MAC and renew the dhcp address. This worked, but was a royal pain since a power outage made me do the whole thing again.

    NOTE: Comcast does not have my laptop MAC, the GS gets an address fine with it's MAC using the linksys firmware.

    A recent power outage finally convinced me to look around for another firmware that wouldn't have this problem. I stumbled on DD-WRT and it sounded great. I figured it's code base would be different enough that I''d probably get rid of this problem too.

    I loaded it up, and it rebooted. I glanced quickly to wee if it got an address on the status page I saw that it hadn't, and I went to bed.
    I went to work the next morning, and I researched this problem, found the STP suggestion and I went home to try it. I was surprised when I got home and it was working. I don't know what happenned to start it working since STP was enabled.

    I reset everything (power cycled) to see if it would work again, and it didn't. I turned STP off and rebooted and it still didn't help. I power cycled both again and still nothing. I re-enabled it and wen through it again. Nothing.

    Up till now I had powered the modem on first, waited then router.
    So I tried powering on the router first, then the modem, and it worked. I also tried the switch on the power strip to simulate power returning after a power failure. I tried all these combinations again both with and without STP and STP didn't seem to make any difference at all.

    Why does having the router fully booted before the cablemodem help?

    Anyone have any ideas?

  4. jagboy

    jagboy Network Guru Member

    maybe the cablemodem needs the device that is it going to be attachted to it before it boots so it can get the devices mac address.
  5. Guyfromhe

    Guyfromhe Network Guru Member

    I did support for comcast for about 6 months and I don't remember hearing anything about STP problems or problems with linksys routers infact I helped several people configure linksys routers..;
    STP is on by default even on Linksys' firmware....
    if I were you i'd be doing some packet logging on the internet interface with tcpdump and seeing what the router is sending and getting to find out whats going on... i'd have a hard time seeing a modem needing a device on it before it boots....
  6. Aluminum

    Aluminum Network Guru Member

    Comcast + DD-WRT + STP = no worky for me :cry:

    Comcast + "Disable (disable for COMCAST ISP)" = Time: 23:02:07 up 22 days, 4:18, load average: 0.00, 0.00, 0.00
    ...and gaining :rockon:

    Linksys firmware probably doesn't really have STP even if its on...the stock firmware is just plain weird :drinking:
  7. jagboy

    jagboy Network Guru Member

    did u try to release and renew the ip on the status page.......
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice