Compaq Armada E500 & Linksys WPC54G PCMCIA card

Discussion in 'Other Linksys Equipment' started by LIDeadHead, Jul 28, 2006.

  1. LIDeadHead

    LIDeadHead LI Guru Member


    Im having a frustrating time trying to get a Wireless adapter working in my laptop. I have a couple of HDD's with different Windows O/S's. The factory shipped O/S for my laptop was Win98. I currently use W2K and WinXP Pro. I bought the Linksys adapter, and was surprised how complicated it is to get this card to work woth these 2 O/S's.

    On W2K, I install the driver CD from Linksys first, as instructed. When it tells me to insert the card, the Power & Link LED's just blink on once and then stay off. You don't hear that chime Windows makes when a device is inserted nor do you see the Network Adapter detect. The PCMCIA slots are enabled, but can not be accessed through Control Panel (Could have sworn there used to be a PCMCIA icon). So after about an hour of playing with it, I tried WinXP Pro. Same exact thing happens.

    So I go back to my old Win98 HDD and now when I put in the card, both LEDs light up and stay lit. I didn't proceed to finish then install, because it required IE to be updated to at least 5.5. I just wanted to verify if the card powers up in the slot, in which this case, it did.

    Has anyone run into a similar problem with PCMCIA issues? Any tips will be appreciated. Thanks!
  2. Esquire

    Esquire Mesquire Staff Member Member

    I presume there is no entry in the Device Manager of either OSes under Network Adapters to correspond to the WPC54G?

    You have other PCMCIA devices connected? Are they working fine?
  3. jgutz20

    jgutz20 Network Guru Member

    yea check under the network adapters, they might be disabled and thats why the power stays off if it is in there.
  4. LIDeadHead

    LIDeadHead LI Guru Member

    Esquire - The network adapter is no where to be found in Device Manager. The only NA listed is the onboard Broadcom 10/100 adapter. I even tried to do "add hardware/have disk" that didn't work.

    Jgutz20 - Only NA is the broadcom 10/100 onboard.
  5. jgutz20

    jgutz20 Network Guru Member

    hmmm... im guessing you've looked for some sort of pcmcia driver, maybe also look for a chipset driver for the motherboard
  6. LIDeadHead

    LIDeadHead LI Guru Member

    Yea...I looked for any qualifing drivers from HP's site for the Armada E500. They do not offer a chipset driver. Plain & simple, they will not support this laptop with W2K or XP on it. I checked on microsofts website and they had a couple of tricks Ill try tonight. Ill post the results.
  7. jgutz20

    jgutz20 Network Guru Member

    yea sorry, tough to say, especially if the port and card do in fact work under win98
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice