Compiling firmware for RV042

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by palo_m, Aug 14, 2007.

  1. palo_m

    palo_m Guest

    I tried to compile firmware for RV042:
    1. I downloaded latest GPL code RV042_v1.3.8.1.tgz
    2. I unpacked it
    3. From the ToolChain directory I unpacked toolchain_armsaeb.tgz and moved openrg directory to /usr/local
    4. (this was not mentioned in any readme, but compilation didn't work without it) I updated PATH:
    $ PATH=/usr/local/openrg/bin:/usr/local/openrg/i386-jungo-linux-gnu/i386-jungo-linux-gnu/bin:$PATH
    5. Then I run compilation:
    $ ./
    $ make
    Looks nice, it ran successfully and at the end there was vmlinux created in os/linux-2.4:
    paul@ubuntu:~/src/GPL$ ls -al os/linux-2.4/vmlinux 
    -rwxr-xr-x 1 paul paul 1604912 2007-08-14 15:18 os/linux-2.4/vmlinux
    paul@ubuntu:~/src/GPL$ file os/linux-2.4/vmlinux 
    os/linux-2.4/vmlinux: ELF 32-bit MSB executable, ARM, version 1, statically linked, not stripped
    Not only kernel, also modules were compiled with the cross-compiler...

    So far so good... but what to do now??? To be able to upload firmware to RV042, one needs .rmt file...

    And here I'm stuck and I don't know what to do next. I assume I should unpack official .rmt somehow (how?) and take necessary files from it (e.g. those famous .html files), then use it to build own .rmt file which could be loaded into RV042... Does anybody know how to do this?
  2. akk142

    akk142 Network Guru Member

    Hi, this interests me as well, and I'm going to try and have a go at it.

    Is the vmlinux file perhaps the image? Maybe Linksys takes that file and renames it and then posts it when they're ready?

    How about opening up the files and looking for similarities or patterns. That may provide an answer.

    Let me know how it goes.

  3. Toxic

    Toxic Administrator Staff Member

  4. jlbcrp

    jlbcrp LI Guru Member

    If the linux image was built properly you should be able to load your file ( OS / firmware) using any standard loader that is able to load VMlinux images on an ARM processor.

    You do not require the .rmt files. That's just linksys way of making it simpler for the lame man.

    You need to test his image and make sure it does run (boots) / and works before he loads it. There are many programs that can act as emulaters.

    Once that is done there are many choices as far loaders go. It is standard GPL code. These routers are running a full Linux OS. Just load it as you would any VMlinux image on any ARM based processor. Note the standard intel code is not GPL so don't try the intel loaders.

    That's about as much help as I can give with the information you have given

    A quick side, If you have the cash I would strongly recommend picking up a second unit for testing purposes. Things are going to go wrong. A emulator is no replacement for the real thing. Also make sure you the linksys TFTP utility ready to go meaning downloaded and installed so you can bail your self out if needed. Here's a link

    Also remember these routers are running a full linux OS. Just like Ubuntu or suse. Just a much smaller and more specailized version. If you are not comfortable programming at a OS level your probably better off not to start playing with these things.

    Most of all have fun and enjoy the challenge in your ride that is going to have many up's and downs. Have patiance and just keep pecking away at it.

    Good luck

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice