Computer partially loses internet connection after a certain amount of time

Discussion in 'Tomato Firmware' started by Fox5, Aug 5, 2007.

  1. Fox5

    Fox5 LI Guru Member

    Ok, this happens on more than one computer.
    It happens on a desktop with Windows Vista, a marvell yukon lan adapter, and a belkin 802.11g wireless card.
    It also happens on a thinkpad x41t under ubuntu using the built in atheros wireless card. Haven't tried wired or windows with it.

    After a certain amount of time (I think the timeout time) my computer will partially lose internet connection. It's only partial, as AIM still works, but my internet browsers won't, nor will my desktop widgets. Release/renew doesn't fix things, only rebooting the computer does.

    It happens with more than one version of the tomato firmware. I was using one of the original versions up till recently, and am now on v1.07.1039, both of which have the problem.
    I'm using a buffalo WHR-HP-G54 router.

    Any help in solving this issue would be appreciated.
  2. ifican

    ifican Network Guru Member

    Well I would first try and see if you get that same problem with other firmware. If it is firmware dependent you can focus on just that, however if it is hardware that is causing it then not sure much can be done. On a buffalo router i currently have dd-wrt running and have no issues.
  3. Toxic

    Toxic Administrator Staff Member

    Have a look at the wireless signal tweaking. my initial thoughts would be the Wireless Beacon setting. try lowering the setting to 50. you may also what to try setting the wireless channel to a different channel. 1,6,11 are best. you maybe getting interference from other wifi users in your area at certain times of the day.
  4. katsyonak

    katsyonak Network Guru Member

    I had this problem twice on wired (non wireless) two different machines and routers (WRT54G & WRT54GL). Some programs could connect and some couldn't.
    It only happened once on each machine so I have no idea how to repro this. Restarting the router solved that.
    The firmware versions were 1.06 & 1.07.
  5. azeari

    azeari LI Guru Member

    i suspect the case here lies with the dns servers, could be your isp or router's fault.

    should you encounter the problem again, try resolving a weird url that you hadn't accessed recently. i.e. ping for example. or .au . just make sure you hadn't accessed it recently so it isn't cached.

    If you get unable to resolve errors, you could start narrowing it down from there.

    On the other hand, if it resolves perfectly, at lest 1 problems out of the window
  6. Toxic

    Toxic Administrator Staff Member

    btw what type of WAN connection do you have? Cable or ADSL?

    Cable MTU should be 1500
    ADSL MTU should be 1492
  7. roadkill

    roadkill Super Moderator Staff Member Member

  8. adam217

    adam217 Network Guru Member

    I have also had this happen many times on a wired connection, usually after a long CS gaming session. After exiting I open web browser and get page not found or whatever firefox says, a release and renew of the routers ip fixes it for me.
  9. t4thfavor

    t4thfavor Network Guru Member

    Sounds like a DNS issue since AIM uses ip address of its server, and only needs to resolve it once at startup. I had a bit of the same stuff happening before with a wrt54g, and OpenWRT.
  10. Fox5

    Fox5 LI Guru Member

    Thanks for the quick responses guys!

    Alright, well I haven't tried other firmwares yet.

    It does happen with both wired and wireless connections, so it's not interference. It happens after a certain amount of time, not sure how long but it appears to be a constant amount of time.

    Can't ping anything once the PC loses its DNS servers. Just doesn't find anything.

    Have a cable connection, MTU is set at 1500.

    Didn't try OpenDNS yet. It seems to be a problem on the PC to router connection, not router to Internet. The router is just fine, it's the PC that needs to be rebooted. Happens on ubuntu and vista on my laptop and my desktop. Don't think it happens on my roommate's windows xp laptop, though he may just reboot regularly.

    ipconfig /release
    ipconfig /renew
    Does not fix it.
  11. roadkill

    roadkill Super Moderator Staff Member Member

    can't help you with windows but there has been/is an issue on Ubuntu check /etc/resolve.conf when using dhcp you'll see it has no working
    name server address the dhcp client on Ubuntu is timing out, you can work around it using a static ip or changing the permissions on resolv.conf this happens on certain network adapters.
    Vista is a whole different thing maybe using the DHCP Reduce Packet Size will do some good although it's only for WAN DHCP Client it has worked for me in several cases especially if you have a Cable Modem.
  12. ifican

    ifican Network Guru Member

    My windows machine will do that when they have been running about a week without being rebooted. Once i reboot the machine everything seems to work, i know also sometimes routers have dns issues as stated, to get round it for me i have the router hand out the isp dns server ip's. What happens if you take a machine and plug it into the same port that is having issues before rebooting? If a machine works on that port i would lean towards something on the machines.
  13. azeari

    azeari LI Guru Member

    my XP, and now Vista pc doubling as servers hasn't had that issue though.

    have you tried using the router to ping a url instead of from the windows pc? under tools->ping. this will help us narrow down the issue.

    Also, try keeping stuff like the google ip stored somewhere, and ping the ip when this happens. you can retrieve the ip by simply pinging it'll appear alongside something like this
    Pinging [] with 32 bytes of data:
    the is the ip.

    so basically, this is what you could try.
    1. Pinging the ip address using the pc
    2. Pinging the url using the router
    3. Pinging the ip using the router
  14. ziddey

    ziddey Network Guru Member

    when it happens, trypinging
  15. Fox5

    Fox5 LI Guru Member

    Even after the problem occurs, pings from both the pc and the router are successful.
  16. azeari

    azeari LI Guru Member

    even pings to uncached urls?(strange urls like

    if tts the case, it seems dns isn't a problem here. based on what you've said earlier also, the problem might ultimately lie with the network cards.

    You could try using an alternative browsers like opera and see if it solves anything though./
  17. mmpredmo

    mmpredmo LI Guru Member

    It's a UDP problem

    DNS uses UDP port 53. I have a WRT54G with Tomato 1.07 and my PAP2 VoIP (UDP again) loses connectivity without a physical reboot of the router. Reboot via admin page does not work.

    Any suggestions on correction would be greatly appreciated as I love Tomato except for this issue.
  18. Jwolf24601

    Jwolf24601 Guest

  19. Fox5

    Fox5 LI Guru Member

    Jwolf- I don't know if that's the same problem, internet connection lasts about a day, not 1 to 2 hours. I did have internet connection sharing enabled.

    However, I just started using opendns and while it's not the most optimal solution (can a dns server a couple hundred miles away really be faster than one that's 10's away?), it does appear to have fixed the problem.
  20. azeari

    azeari LI Guru Member

    its probably your isp's dns thats causing the problem then (= its not really abt speed but uptime
  21. digitalgeek

    digitalgeek Network Guru Member

    have you tried a clear nvram and manually reconfig (do not use a saved config)
  22. mmpredmo

    mmpredmo LI Guru Member

    fixed my problem...

    Adding a UPS helped me - voltage must have been dipping and causing some sort of lock in the router. Temps have been 100+ for a while (higher load on utility due to A/C) so maybe that was all it was.
  23. Fox5

    Fox5 LI Guru Member


    Strangely, the problem still occurs if I use opendns on my router, but not if I manually set my pc to use it. Guess the problem is on my pc's end then for some reason, as the problem also happens on a belkin f5d7230 running dd-wrt.
  24. ziddey

    ziddey Network Guru Member

    if you disable the dnsmasq and have the tomato pass the external dns at dhcp itll be fine

    dnsmasq ****s
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice