Conflict between Wireless Router (WRV200) and Switch (SD2008)

Discussion in 'Networking Issues' started by RaUArch, Apr 20, 2008.

  1. RaUArch

    RaUArch Addicted to LI Member

    First of all, let me admit that I'm not a network specialist and have only a limited experience, enough for what I think is necessary to keep a SOHO up and running. And this has worked fine until now....
    Also, if there's a problem, I always try to cover all the pertinent FAQs, forum entries, etc.. before letting out a cry for help. But the following problem is such a cry - I'm completely perplexed.

    General Setup:
    Due to a need for more LAN ports, one WLAN port, and internet access for all computers, we set up the following system (as suggested by Linksys):

    Cable Modem-->Internet/WAN Port Wireless Router (Linksys WRV200)
    1 LAN Port of the Router to a 8-Port Switch (Linksys SD2008 w/ automatic MDI/MDI-X crossover detection)
    To this ethernet switch are connected the following components:
    2 PC Workstations
    1 Laptop (with two network cards, one LAN and one WLAN, each with different static IPs, with the WLAN alone being normally activated)
    1 HP Laserjet 1320N
    1 HP DesignJet 800PS Large Format Printer

    Modem, router and switch are all located in an electrical cabinet, close to one another. From there, a CAT5 network board branches out throughout the entire office (max. cable length ca. 25m).

    Network Settings:

    Static IPs, no DHCP
    For the components AFTER the switch:
    IPAddresses 192.168.1.xx (where xx 10 or above is)
    Subnet Mask:
    Standard Gateway:
    DNS Server Addresses: and
    (the DNS is somehow required by the ISP)

    Router WRV200 Settings:
    Firmware (cold booted and software booted und Factory Defaults of GUI)
    Internet Setup
    Internet Connection Type: Automatic Configuration DHCP
    IP Address "captured":
    Host & Domain provided as required by ISP
    MTU Auto (at 1500)
    LAN Setup:
    Local IP Address:
    Subnet Mask:
    Local DHCP Server: disabled
    MAC Address Clone activated with address expected by ISP
    all other basic setup options left on default settings
    Wireless (including WPA-Personal) and some Portforwarding (under Firewall) functions were also set.

    This system was installed with the first WRV200 router mid-2007 and worked fine for about 6 months. Then certain anomalies starting cropping up:
    -intermittent or slow internet connections from the wired LAN PCs
    -printing commands were interrupted/slow and had to be resent multiple times

    From a LAN PC, I pinged the router and other components and got various loss rates (sometimes 50, sometimes 75%, etc.)
    Also, from the wireless laptop, I could ping the router successfully and internet was great but pinging other LAN components was associated with similar intermittent and varying losses.
    Rebooting the router helped for the first month or so but after that, no more. As we were approaching a deadline and I had little time, I thought: "the router is simply a lemon and
    well, let's replace it"
    Installation of the second router (again a WRV200) with firmware upgrade "seemed" to have fixed the problem....but only for about 3 months. Then the same symptoms
    started cropping up again. As I now have the time to go after it thoroughly, I can describe what does and doesn't work:
    - If I connect all LAN components directly to all available router LAN ports, the system seems to work just fine (but again, in the end I need more LAN ports and hence the switch).
    - If I, however, try to expand this system through the switch, those elements downline from the switch aren't connected. For instance, I can ping the printer if it's on one of
    the router LAN ports, along with a PC, as long as it is also on a router LAN port. As soon as I connect the printer to the switch, and use one LAN port of the router to connect to the switch, I can't ping the printer anymore.
    - However, the switch seems to be fine...because when I connect all LAN components via switch, they can ping one another. But they can't access the router and hence, the internet/WAN.

    As a side-kick setup, I thought perhaps some interference might be involved and took the router out of the cabinet and hooked it up to two available CAT5 slots in the office. These slots then travelled to the CAT5-board in the cabinet and from there, respectively to the modem and switch. Strangely this worked....but only for a couple of weeks and then the above losses started appearing again...and progressively got worse to the point where they were practically 100%. Also, this setup was no end solution either, as it took two up valuable CAT5 plugs in the office area.

    A second side-kick setup: I connected the LAN-card of the laptop, in addition to the already activated WLAN card. As mentioned earlier, each card has its own IP (but both have a gateway address I thought I would be able to acces the other LAN compoments via the switch, and the router/internet via the wireless connection to the router. This doesn't happen though - I can only access one "side" at a time (i.e. I have to turn off the WLAN-card to access other LAN compenents through the switch...or...disconnect the LAN-card and start the WLAN-card to get connection to the router and internet) - hmmm, seems the best of both worlds isn't even possible here.

    And that's where I stand....helpless...although it seems like a basic setup (not even venturing at this point to try VPN or other features on the router).
    It's particularly strange that this DID work as expected for quite awhile but it's as if the system/router went through some kind of idea.

    Any suggestions would be GREATLY appreciated....thanks in advance.

  2. Toxic

    Toxic Administrator Staff Member

    firstly try upgrading the wrv200 firmware to 1.0.38 (beta) this has reportedly been a better firmware than any others. WRV200/

    is there any other wireless access points in your area that are transmitting on the same channel as you? this can cause interference and loss of signal or intermittent pings.
  3. Did you get an answer?

    I read your request with interest, as I am experiencing a similar problem at a company site. You have a bit more knowledge than I do, and I'm afraid the single answer posted doesn't help either of us, but I sure appreciate the clarity of your question.

    If anyone else is reading, (and if you figured this out already, please post back here), I'd like to know why, under circumstances described by RaUArch: why is it true that the wireless in a laptop will not see the network, but using an ethernet cable from the laptop to the switch will see the network.

    Additionally, using that same ethernet cable but going from the laptop directly into a LAN port on the router does not allow the laptop to see the network.

    This will be a DHCP vs. provisioned IP address issue, no doubt, but being in the same murky, untrained waters, I sure would like to know these anssers.

    Thank you all.

    ... Mike
  4. RaUArch

    RaUArch Addicted to LI Member

    a belated response...

    well, I kept checking my email and wondering why I hadn't been informed as to a response to my posting - a month later I finally decided to directly check in here and well, lo and behold, thank you for the responses.

    toxic, will try your suggestions and post the results (positive or negative).

    about the beta firmware version you mentioned: it was (as of a month ago) not on the linksys site and I "believe" I also looked for it here at that time with no luck.

    will check the current download section again....


  5. RaUArch

    RaUArch Addicted to LI Member

    *laughs to himself*

    errr, sorry, toxic....just saw the link you posted for the beta version.

    (sheesh, I should get more sleep....:redface:)
  6. RaUArch

    RaUArch Addicted to LI Member

    So....rather belated response but have solved the above-mentioned problem (which I finally got around or better put "had to " get around):

    - it had nothing at all to do with the Linksys router but rather with the Linksys SD2008 switch.

    - apparently the version 2.x of this switch has its flaws.
    see following links:\personal:sd2008

    I opened the switch, found 4 popped 470uF capacitors and has been running smoothly since without ANY loss packets, etc.. We'll see how long it lasts...

    hope someone appreciates this happy end.


  7. RaUArch

    RaUArch Addicted to LI Member

    (ooops, if it ain't obious...I did naturally replace those popped capacitors. a popped capacitor can also be bloated at the an indication of being bad)
  8. morgan_greywolf

    morgan_greywolf Addicted to LI Member

    *sigh* Linksys equipment ain't what it used to be. It seems to be getting better on some fronts, but when you make equipment designed to be sold at your local electronics retailer for $50-100 a pop, you're going to wind up with very, very cheap components.

    Honestly, the gigabit switch is probably overkill for your environment. I use a very similar setup to yours in my home office, but the network equipment is far older:

    • Linksys WRT54G V6 with DD-WRT micro Firmware v24-sp2-NEWD-Eko
    • Linksys EZXS88W 8-port 10/100 workgroup switch
    • 2 desktop PCs running Ubuntu 9.10
    • 2 Dell laptops with built-in wireless
    • Linksys NAS200 network storage server
    • HP inkjet printer

    The 8-port switch is probably about 5 years old. LAN file transfers rates are okay for most files; largish files can take a bit, though. I don't do enough large file transfers to justify the need for gigabit equipment, but I'm guessing by the DesignJet that you might :) Using alternative firmware on Linksys routers is the only way to go these days: they're throwing VxWorks instead of Linux on their routers these days, and it's often very buggy and slow.
  9. RaUArch

    RaUArch Addicted to LI Member

    true, the gigabit switch rating might be overkill but my general policy is:
    if the price difference is negligible, then buy the newer generation - and here the price difference was peanuts.
    Other specs such as multiplexing, etc. were also "possible" musts. This switch at the time seemed to do everything I wanted without throwing any surprise monkey wrench limitations/compatability problems into my network.
    At the same time, I also thought it was the simplest link in the chain and would never have suspected such odd and intermittent behaviour.

    In the end, it was the internet with its vast amount of accessible user info via forums that offered the solution - but I fear companies are abusing this by sending sloppier beta products onto the market.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice