Discussion in 'Tomato Firmware' started by Vic Fontaine, Apr 15, 2009.

  1. Vic Fontaine

    Vic Fontaine Addicted to LI Member

    Before you say this has been posted to death and I should have searched, I did. I also found many similar situations but nothing exactly like mine.

    My setup is a Linksys cable modem that has a WRT54Gv2 connected to it with 2 wired clients and 1 wireless client. I'm using WDS to connect a second WRT54Gv2 with 1 wired client in my parents' home next door. Both routers are running Tomato 1.21.

    My problem is that I can get my mom connected next door, but when she's on it boots my better half's Dell Inspiron 1200 laptop off. And occasionally the reverse happens. I have everything configured the way it should be so why can't the 2 coexist?

    Previously I had been running a WRT54Gv6 with DD-WRT for my mom's connection but it stayed down way more than up. I thought it was because the router couldn't handle the load due to less memory and possibly the difference in firmwares. So I purchased the 2nd WRT54Gv2 and loaded tomato on it. And that's where I'm at.

    I've cleared NVRAM multiple times. Didn't help. I've cleared NVRAM, reloaded linksys FW, router default, reloaded tomato, cleared NVRAM, and reconfigured. That didn't help, either. I've done multiple power cycles with no success. I've tried 2 wireless cards in the laptop, a linksys WPC54Gv2 and a Dell Wireless 1350 WLAN PC card (both with the latest drivers), to no avail. I've tried both the wireless cards' software and the WZC and still no positive result. I lowered the transmitting power on both routers and nothing. I've changed wireless channels and still no help. I've tried both link with and lazy WDS and nothing. I even tried tomato 1.23 on both 54G's and still no luck. I chose to go back to 1.21 because the laptop previously worked with it. The laptop sometimes goes up for a few minutes then back down for a few cycles before staying down.

    I hope it's not a tomato problem because I really love the firmware. But I'm at a loss as to what the problem could be. I appreciate any help and advice you might give me.
  2. SgtPepperKSU

    SgtPepperKSU Network Guru Member

    This may be obvious, but have to check: the two computers don't have the same network name configured do they?
  3. Vic Fontaine

    Vic Fontaine Addicted to LI Member

    Thanks, but no. The network names are unique.
  4. Vic Fontaine

    Vic Fontaine Addicted to LI Member

    I should also add I've tried using DHCP and static addresses.
  5. Vic Fontaine

    Vic Fontaine Addicted to LI Member

    I've kept trying and I think I found my problem: encryption. I was trying to run WPA-TKIP and it just wouldn't work despite all wireless devices supposedly being WPA able. I switched to WEP-128bit and away we go. I realize WEP isn't as strong as WPA but I've tried to augment it with a permit only wireless filter. It's better than no security at all. Hopefully it just continues to function properly.
  6. fyellin

    fyellin LI Guru Member

    So things don't work with WPA-TKIP, but they do work with WEP-128bit? That does seem quite strange.

    In any case, you're right that WEP-128bit is an easily-broken encryption. You really should be using WPA/AES if all your computers support that, since TKIP has been shown to have some minor flaws.
  7. Vic Fontaine

    Vic Fontaine Addicted to LI Member

    Yeah, WPA would be the best to use but I really don't have an option at the moment. Maybe I'll try buying a new wireless card and see if it will play nice with the network.
  8. RonWessels

    RonWessels Network Guru Member

    Try WPA-AES. Not WPA2-AES, and not even WPA/WPA2 AES. Just plain simple WPA-AES.
  9. Vic Fontaine

    Vic Fontaine Addicted to LI Member

    Neither of the wireless cards had AES as an option under WPA. Thanks anyway.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice