Counter Strike:Source UDP Packet flooding.

Discussion in 'General Discussion' started by Mikeoo17, Jul 10, 2006.

  1. Mikeoo17

    Mikeoo17 Guest

    I've encoutered a fairly common problem with a not so common solution. I have visited numerous forums, performed countless google searches and simply can't figure out how to solve this.

    -When finding servers to play on, a list of about 100-500 is generated instead of the massive 10,000 server lists most enjoy.
    -Double clicking a server does not connnect to the server. It simply opens up an info page showing no players connected and an average latency of 50-100. Refreshing raises the latency to an incredible 1000+ and then to 2000 almost every time.

    The source of the problem is settings on the router (narrowed down by hooking up computers to different routers, re-installing software, making software setting adjustments etc.) It appears that UDP Packets are flooding the system... whatever that means.

    Here is the solution posted on steam
    Hey there,

    Been reading all this stuff and the topic under discussion was EXACTLY the problem I was having - server listing would begin ok then die or slow down stupidly after the first 300 or so.

    I was tearing my hair out trying to play this game I love so much, but finally last week I fixed it.

    I'm running behind a router (AR502, aka Globespan Virata GS8100). At first I thought my probs were just the Port Forwarding and Firewall settings so I did battle with the hellish router "web front-end" (comedically unfriendly!) and set all the parameters as required. Still no decent server listing.

    After hours and hours of trying different things, I finally came across a comment on a web page ( ) about a parameter called "global udp timeout" and how that could make the router "choke" if it were set too high. I searched in vain for this parameter on the "web front end" but couldn't find it - because it simply wasn't there!

    The solution in the end was to Telnet into the router.

    A word of warning, I've read that Telnetting into any piece of kit and fiddling with parameters there can result in your router failing to work at all if the wrong settings are put in there so please please read up on it as much as you can before you go in...!

    Anyways, I had to login to the router admin via Telnet using my usual password then type:

    "modify nat global udptimeout 3"


    "commit" (writing it to the router's memory)


    "reboot" (to restart the router)

    Et voila. Server listings like there's no tomorrow and in-game ping of 40

    Seems the UDP packets were somehow clogging up in the router and this global setting causes them to be purged if they're not in use.

    I say that like I know what I'm talking about, but I don't really - I'm a relative networking newcomer although I consider myself good with PCs generally, so that's just a non-tech thought as to what might have been going on.

    Just thought I'd pass on the "fix" (maybe just a workaround...?) that worked for me. It might of course be unique to my setup - as I say, I'm no programmer or IT tech, so if anyone wants to tell me I've done something REALLY STUPID or missed an FAQ somewhere I'm happy to listen, but from my point of view my system's now got CS Source working nicely and that's more than I had a week ago.

    Only problem I still have now is every so often I get dropped during a game with the message that the program "couldn't connect to the VAC servers", but by the look of the other forums here I'm not the only one...

    Good luck all. Hope this helps.

    Gemo (uk)

    Here is the second solution (very similar)
    hey this fix works with my 205 adsl voyager although, I now get the couldent connect to vac servers bug during game, where as before i dident.


    i managed to fix both problems after a bit of research here are the settings I used dont forget to make a backup!:

    modify ppp global keepalive enable

    modify ppp global pppsesstimer nevertimeout

    modify nbsize maxipsess 512

    modify nat global udptimeout 20

    modify nat global tcpidletimeout 3600

    modify nat global tcpclosewait 30

    modify nat global tcptimeout 20



    You can find these posts here about halfway down the page.

    PLEEEEEEAAAASE HELP. I have a WRT54G v5 and want to resolve this problem ASAP. It's not just me thats having this problem. Seems like a large segment of the CS:S community is aflicted.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice