D-Link DWA110 USB adapter association

Discussion in 'Tomato Firmware' started by Toastman, Apr 24, 2009.

  1. Toastman

    Toastman Super Moderator Staff Member Member

    A while ago ago I pointed out a problem with this D-Link USB adapter.

    This RALINK RT73 based adapter seems to work well with older motherboards with 10/100Mbps ethernet, but on later motherboards with 10/100/1GB ethernet, there is a problem - it doesn't associate properly. The problem began when I changed my motherboard. I think I can confirm there's nothing wrong with the router - the problem is at the adapter.

    This USB adapter comes with a short USB cable extension and stand. Somehow this has an effect on the operation of the adapter. If the adapter is plugged directly into the PC's USB port it will sometimes work perfectly. It does the same when plugged into SOME screened extension cables, especially if a USB hub is on the far end of it. Also, seems like the adapter will work on some of the USB ports and not others. But when plugged into the supplied extension cable/stand, it doesn't associate, although it otherwise seems to be working. There doesn't *seem* to be anything unusual about the cable/stand, it works OK as an extension with anything else I have here.

    An SMC EZ connect "g" USB adapter (atheros) will *usually* work when plugged into the short D-Link extension, but not always. It always works here on any other USB extension cable.

    Mine is a Gigabyte board with Realtek RTL8168C(P)/*111C(P) PCI-E Gigabit ethernet NIC. I've tried this on several newer motherboards and laptops now with similar results, the D-Link adapter usually doesn't work well. There are about 8 people in my building using these adapters and all of them have some problems on occasions.

    Anyone got any ideas on what may be wrong?
  2. darthboy

    darthboy LI Guru Member

    I've tried out an Engenius/Senao EUB3701 (RT73) USB adaptor and it works fine on the motherboard with embeded nforce4 gigabit adaptor. The motherboard is GF6150-based, an Abit NF-M2 nview. Both Vista x86 (in the past) and now Vista x64 too. Using driver version 1.02. EUB3701_102.

    edit: works fine on a USB extension cable which came with a dlink bluetooth dongle.

    No USB extension used. the router is in the sig.
  3. Toastman

    Toastman Super Moderator Staff Member Member

    Funny eh? I have now recorded about a dozen people with problems, many have taken them back to the shop and swapped them out. I've been to see some of the others and got most of them to work by ditching the extension "plinth". I cut one open to see if anything was obviously wrong, they seem to be reasonably well made and they're only a few feet long!
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice