Data corruption, lockups, disconnects

Discussion in 'Cisco/Linksys Network Storage Devices' started by mrfixit5, Aug 11, 2005.

  1. mrfixit5

    mrfixit5 Network Guru Member

    I purchased a NSLU2 and used Acronis 8 to save drive images to the NSLU2. When trying to verify the archive, it usually said it was corrupted, or you would get a read error.

    Purchased 2nd NSLU2, same problem.

    Purchased another type of drive enclosure. Same problem.

    After several weeks of trying different things, I resolved my problem by making a hardware modification to the unit.
    I disconnected the 33 MHZ crystal oscillator from the IXP processor (this is R123) and then jumpered the crystal input of the IXP to the 30MHZ crystal next to the NEC USB chip (crystal leg furthest away from the usb connectors). No more problems.

    Disclaimer: Any modifications you try are at your own risk. You will lose your warranty and may invalidate fcc certification.
  2. yopnono

    yopnono Network Guru Member

    For how long have you been running it since the modification?
  3. yopnono

    yopnono Network Guru Member

    Is this how you did it?

    Remove R123 and bridge from solder point to Y6 leg futhest away from USB.

    See picture:

  4. mrfixit5

    mrfixit5 Network Guru Member

    Yes, this is exactly what I did.
    The jumper must be as short as possible.

    If you look in some other posts, people indicated a heat problem,
    and I found this as well. One of my units would not corrupt any data for a short while after being powered up, while the other seemed to corrupt data much sooner.

    I did all the experimentation on the one that was more problematic.
    I tried using cold spray on various components with no definate results. I tried changing the ram chips, and now it would not power up at all. Reinstalled the original ram chips, then tried changing the 3.3volt and the core voltage of the ixp processor by using pull up and pull down resistors on the voltage regulator, but this did not help.

    The only thing I could think of, was to decrease the processor speed, and I wanted to reduce it as little as possible. I had a 25MHZ crystal, but did not want to reduce it this much, so I thought of jumpering it to the 30Mhz USB crystal.

    Once I did this, I could put the more problematic unit back in its case, wrap it with several layers of paper towel (I drilled the casing full of holes earlier and wanted to see how it worked when hot) and then put a small book on top of it while it was on its side.
    The unit got quite warm inside and kept working.
  5. yopnono

    yopnono Network Guru Member

    Well I also tried this trick, to no success.

    So I guess it's somekind of hardware problem in the unit.
    It's back to the store, and up with a laptop and an ext disk to use as a file server.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice