DD-WRT V22 final sneak

Discussion in 'DD-WRT Firmware' started by BrainSlayer, Jun 30, 2005.

  1. BrainSlayer

    BrainSlayer Network Guru Member

    starting with prefinal5 i released sneak version from time to time to test the current build quality.
    now i will follow up with it with the final version.
    so note "THIS IS NOT THE FINAL VERSION", its just a step to it.
    the good news, i was able to reproduce the wrong ssid association problem and found also a solution for it.

    the changelog:
    v22 final:
    wrong client ssid association fix
    bird fix, for disabled routing
    dropbear updated to latest version
    site survey typo fix (title)
    reboot scheduler cron fix

    and now the important thing, the download link

    the disclaimer is easy. dont use it if you dont know what you're doing.
    i'll update the link from time to time.

    other news:
    i'm now jobless, so i have currently a little bit more time for dd-wrt, but that means also that my financial situation will change dramaticly in near future, if i can't find something new. keep this in mind if you have some pence/bucks left
  2. Thrasher

    Thrasher Network Guru Member

    Thnx for the update Brain.....sorry to hear about your job loss, I wish you every success in getting a new job real soon.
  3. jagboy

    jagboy Network Guru Member

    good luck with getting a job. if you dont mind me asking what was your previous job?
  4. 4Access

    4Access Network Guru Member

    What was the problem with the reboot scheduler? I just upgraded a few WRTs for a client the other day to v22prefinal5 and enabled the reboot scheduler... do I need to worry about it?
  5. BrainSlayer

    BrainSlayer Network Guru Member

    for scheduled reboots on a daily base, there was a error with the cron assignment. and additionally it wasnt possible to select sunday
  6. EnigmaX4

    EnigmaX4 Network Guru Member

    How is the wireless side. Is it still the same as the latest Pre5. Also is the lates Linksys sources added to this version.
  7. BrainSlayer

    BrainSlayer Network Guru Member

    i just fixed the ssid assoc bug. the linksys sources are heavy changed and closed source partially (especially the important ones). so this still takes time. the prefinal5 sources are ready for the new drivers. but this implementation is scheduled for v23. currently the work is just bugfixing to create a good stable final version
  8. Morpheus

    Morpheus Network Guru Member

    Tnx BrainSlayer ;-)
  9. dellsweig

    dellsweig Network Guru Member

    Have you identified what was fixed (in the Linksys Source regarding this:

    - Resolves issue with enabling TKIP after enabling WEP

    It would be nice to get this type of fix in ASAP
  10. bytes2000

    bytes2000 Network Guru Member

    Firmware is awesome but...
    heres my story

    v22 Prefinal 5 full version was working just ok
    but i still had that annoying Counter strike problem.. so I tried the latest linksys firmware for my wrt54gs v1.0 and I had no problems with counter strike, so i saw your release of v22 yesterday and I immediatly flashed my router with it (basic version)... and now my counter strike problems are back!

    So i can confirm again.. this is a dd-wrt bug

    *Notes: When I reported that problem on apr, 09 that pause-resume behavior was happening exactly every 15 mins..
    and then sinde release dunno if it was Jun 11 or 23 the problem was happening exactly every 10 mins.

    Brain check
  11. Lazybones

    Lazybones Network Guru Member

    I find all of these seek releases hard to track.. Why not go with some sort of normal version numbering system?
  12. EnigmaX4

    EnigmaX4 Network Guru Member

    Brainslayer if you are fixing bugs to make this V22 Final Stable, the wireless bug should be a top priority. Because If everything else is fine and dandy the wireless will still suck, until the v23 release.
  13. jagboy

    jagboy Network Guru Member

    what new features are you goin going to put in dd-wrt?

    and will v23 have the new gui?
  14. MBChris

    MBChris Network Guru Member


    Sorry to hear that you loose your job, hope DD-WRT was NOT the reason ... Good Luck to find a new one !

    Anyway bad news are good news somteimes, as you said, its good for the development of DD-WRT.

    Good you found the SSID Bug, now i can use it further !

  15. devil-strike

    devil-strike Network Guru Member

    is no bug in dd-wrt i play also counter-strike and source without problems
  16. zyclone

    zyclone Network Guru Member


    i've found 2 problems/bugs with this latest version :

    - sshd don't allow me to connect (probably caused by the dropbear update)
    - Filters.asp page is broken while using https , aka Access Restrictions page (no problem browsing this page with no SSL)

    thx Brainslayer
  17. jagboy

    jagboy Network Guru Member

    yes ssh does not work.
  18. DevilStick

    DevilStick Network Guru Member


    Due to missing sub-release numbers, I can hardly say which version I am currently running. But I loaded it yesterday night. So I think it's the most current one.

    I had many trouble updating my pre4 to pre5, but this was not pre5's fault. Now with a running pre5-system I recognized some strange behaviour.

    When using SSH to reboot the router, I hangs in a loop. I always have to power off and on, to get a 'clean' reboot.
    Another strange thing are the created zombie processes. I need several tries to have a really clean boot with no zombies. The zombies are *.startup files. At least 6 processes get turned into zombies.

    Does anybody recognize similar bahaviours?

    I hope there will soon be a stable version, because the jffs2 and ipkg-feature is pretty cool. I could install an irc bouncer and ident-daemon. I hope there will follow many useful add-ons.
  19. EnigmaX4

    EnigmaX4 Network Guru Member

    Telnet to the router and typer "nvram erase;reboot"
  20. tanguy15

    tanguy15 Network Guru Member

    DevilStick, I've got exactly the same problems as you.
  21. DevilStick

    DevilStick Network Guru Member


    Are you sure the command nvram erase exists? The nvram command eats every parameter, no matter what you typ, e.g. nvram blabla blubb returns with no error.

    I do not think an erase is implemented, since no nvram value was neither deleted nor set to a default value.

    If pre4 would have a working jffs and ipkg system, I would switch back to pre4.

    pre5 produces lots of zombies and I need to reboot several time, to have a clean system:
     643 root            Z   [nas]
      648 root            Z   [conntrack.start]
      651 root            Z   [dhcpd.startup]
      653 root            Z   [jffs2.startup]
      658 root            Z   [language.startu]
      661 root            Z   [macupd.startup]
      669 root            Z   [rflow.startup]
      674 root            Z   [rppppoe.startup]
      686 root            Z   [schedulerb.star]
      692 root            Z   [smtp-redirect.s]
      697 root            Z   [wdswatchdog.sta]
      703 root            Z   [wrt-radauth.sta]
      707 root            Z   [sh]
      715 root            Z   [miau.startup]
    Other question:

    Why is the bird routing daemon running, when I
    - disabled WAN port (just WDS bridge, no router functionality)
    - disabled dynamic routing under Setup|Advanced Routing
    - disabled Routing under Administration|Management

    Is there a way to prevent the bird to hatch or will I have to take a startup script gun and shoot/kill the bird every time the router boots. :wink:
  22. DevilStick

    DevilStick Network Guru Member

    The more I test pre5, the less I believe that we reach a final version.

    Soft reboots do not work at all (boot loop) and when changing anything under Administration/Management wireless goes down, since wlconfig eth1 up hangs.

    Brainslayer can't you just make a jffs/ipkg backport for pre4?

  23. XCOM7

    XCOM7 Network Guru Member

    I have no idea what pre5 you are testing but the latest stable has not posted any error for me not even the ones you posted.
  24. matthiaz

    matthiaz Network Guru Member

    Well, soft reboot doesn't work, indeed.
    And that the SSH deamon doesn't allow connectioncs is not a desirable feature, right...?

    But besides these little issues DD-WRT runs perfectly fine!
  25. DevilStick

    DevilStick Network Guru Member

    I run prefinal5 basic from 07/06/05 (mm/dd/yy). Is there any newer version?
  26. XCOM7

    XCOM7 Network Guru Member

    Thats not prefinal5 thats final.
  27. DevilStick

    DevilStick Network Guru Member

    I just realized that the page Access Restrictions|Internet Access is only served to half. Output breaks after the time settings.

    I tried IE and FireFox, so I don't think its a browser problem. The source output of this page shows that output is cut right after the time options.

    Does anybody have the same problem?

    I really don't want to switch back to pre4, but the more I use pre5, the more I think about it.

    It's final? Really? Does this mean no more bugfixing? Damn. So I have to flash back.
  28. XCOM7

    XCOM7 Network Guru Member

    No read the tittle.
    Is a sneak preview to final so its not even full final yet any bug report you are posting here torse that release will be fix.
  29. Cyberian75

    Cyberian75 Network Guru Member

    Where did you get that from? I thought the newest build was 06/30/05.
  30. Cyberian75

    Cyberian75 Network Guru Member

    Sebastian, why don't you host your files at sourceforge.net? And you'd put your basic and advanced editions into seperate downloads as it is too large of a download (16MB) right now from a slow host.
  31. EnigmaX4

    EnigmaX4 Network Guru Member

    yes or split up the files because It takes me forever to download the files.

    Has the link been updates recently?
  32. Morpheus

    Morpheus Network Guru Member

  33. Morpheus

    Morpheus Network Guru Member

    do you have a link for this 07/06/05 (mm/dd/yy)
  34. jagboy

    jagboy Network Guru Member

    is that a typo or is there a 07/06/05??????
  35. Morpheus

    Morpheus Network Guru Member

    Yes i think it's a typo.
  36. devil-strike

    devil-strike Network Guru Member

    Slow host? lol i have 20Mbit and i download that file with 2103KB/ps
  37. Cyberian75

    Cyberian75 Network Guru Member

    Most of us are not blessed with that kind of speeds... :roll:
  38. tracer

    tracer Network Guru Member

    yeah got 5mbit line here and getting excellent speeds also.. but mayb sourceforge is a good idea for bugtracking and/or easier access to new releases

    btw .. is there some kind of mailinglist or someting that can inform us when a new dd-wrt version is released?
  39. EnigmaX4

    EnigmaX4 Network Guru Member

    I Pmed brainslayer and this is what he told me:

    "i'm working internally hard on v23 and the new weblayout. expect a new v22 in the next days. i targeted the wireless speed problems in v23 so far and found the solution. but i need some time to migrate the changes into v22 since these changes are very heavy"
  40. Lazybones

    Lazybones Network Guru Member

    Thats GREAT!!!!! the wireless speed issue has been the single biggest problem I have had with Alchemy and DD-WRT!!!! Glad to hear that a fix has been found. :p

    Hope he is having some luck on the job front... Would hate for him to starve working on DD-WRT.
  41. daenigma

    daenigma Network Guru Member

    I agree on the wireless speed issues they are one of two thing I would like to see. The other being WPA2 support again :)
  42. Cyberian75

    Cyberian75 Network Guru Member

    Bug 1: Newly added services do not show up on the QoS page.
    Bug 2: Closing the "Port Service" window after clicking the "Apply" button redirects me to the "Filter.asp" page.
  43. macsat

    macsat Network Guru Member

    Does jjfs2 work in this one ?

    I use pre5, and havent been able to make jjfs2 work at all !
  44. DevilStick

    DevilStick Network Guru Member

    Have you check your nvram configuration?

    After erasing my nvram I had also problems with jffs2. I debugged the start-scripts and added sys_enable_jffs2=1 to my nvram config.

    Just log into your router, then run:

    nvram show|grep jff

    and look for these lines and add missing ones:


    The GUI does not change or add the sys_entries. This was my problem. After adding the sys_enable_jffs2 entry, jffs was mountable rw.
  45. jagboy

    jagboy Network Guru Member

    thank you so much devil strike!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

    i guess the linux penguin in your avatar isnt there for nothing :D
  46. macsat

    macsat Network Guru Member

    Working perfectly DevilStick - Thanks :)

    Now all we need is the wireless-speed-fix I guess ;-))
  47. XCOM7

    XCOM7 Network Guru Member

    There is not going to be a fix for that in v22 the new drivers are only been implemented in v23
  48. marczeeee

    marczeeee Network Guru Member

    I flashed the v22 final, and found a bug (i think). I tried to use ssh to the router (wrt54g, v2.2) and it didn't connected, putty just said connection timed out. Telnet was good. I figured out if I enable ipv6 support I can't connect to the router via ssh. If I disable ipv6, ssh is ok. Is there any chance to do something with this?
  49. marczeeee

    marczeeee Network Guru Member

    I can confirm this bug, newly added services do not show up, but they are there in the add/edit list. It's a bit annoying 'cause I need to add a new one, but I cannot use it.
  50. Cyberian75

    Cyberian75 Network Guru Member

    Thanks for confirming it. Also, if you click "Apply" and then "Close," you'll be directed to the Access Restrictions page instead of re-loading the current page (QoS).
  51. devil-strike

    devil-strike Network Guru Member

    I am Devil-Strike, so you mean DevilStick :wink:
  52. jagboy

    jagboy Network Guru Member

    :oops: yeah i ment DevilStick. sorry :lol:
  53. marczeeee

    marczeeee Network Guru Member

    Well, I found some interesting in this case, I made a reboot and after that the new service was in the list and can be added. So I think this is the way, add all the needed services in the list, reboot and you can use them.
    Maybe there can be more priority levels and the input/output traffic can be separated to be qosed, but these are only whispered dreams... :)
  54. Cyberian75

    Cyberian75 Network Guru Member

    Thanks for letting me know. :)
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice