DD-WRT v23 - Connection randomly resetting?

Discussion in 'DD-WRT Firmware' started by Eluzion, Dec 31, 2005.

  1. Eluzion

    Eluzion Network Guru Member

    So after experiencing issues with my Linksys router, I decided to upgrade the firmware to DD-WRT v23, since the latest Linksys ones were not working too well for me.

    So far, the DD-WRT v23 have fixed the issues I was having with the Linksys firmware, but it has created a new problem for me. The router seems to be randomly dropping/resetting connections anywhere from 5mins of uptime to 30mins of up time. Sometimes it will drop/reset the connections and my computer will show up as "Acquiring network address" and it will reconnect just fine or show up as "Limited Connectivity".

    Since I use my computer mostly for online gaming, this is an extremely annoying problem since it makes it virtually impossible to play any online games. ;)

    Any ideas on what settings I might be able to change to resolve this issue? Much appreciated.
  2. MindlessDrone

    MindlessDrone Network Guru Member

    I am having the same problem. I am up for about 20 mintues and then have to reboot the router!
  3. darknforce

    darknforce Network Guru Member

    Try to change ur LAN ports should be ok my lan port 1 is still blinking even without anyone connected to it try test port 2,3,4 okies?
  4. noddyc

    noddyc Network Guru Member

    Try using a different radio channel. Use static ip addresses instead of DHCP.
  5. Eluzion

    Eluzion Network Guru Member

    This is on both wired and wireless connections. I think the problem is something in the firmware. I never had these problems with the default firmware. I was hoping there would be an option I had checked that might be causing these issues, but I looked through everything (but then again, some of the settings I don't understand, lol).
  6. golfermaster

    golfermaster Guest

    Same problem here.
    Router will hang after ~ 24 hrs.
    I'am not using filesharing or other portconsuming stuff.

    WRT 54G 2.0 DD-WRT 23 final / Normal version.
  7. Asniper

    Asniper Network Guru Member

    Currently having the same problem here
  8. mikez

    mikez Network Guru Member

    I am also having the same problem on my wrt54gs v4 running dd-wrt v23 standard 12/25/05 with 9dBi antennas and the Xmit power at 38mW.

    The connection will reset a random times and I know it's not my dsl provider (frontier). I was using linksys firmware before my upgrade to dd-wrt v23 and everything worked flawlessly, I just wanted to try and boost my signal by changing the Xmit power. Currently I get the same problem as Eluzion is having with it not being able to give me an IP address. Then i get limited or no-connectivity. This is with wired clients and wireless clients. I really need to get this fixed by the time i got back to school for spring semester because i share a cable connection with 7 other people in my apartment building. I might be forced to try a different firmware version...
    any ideas anybody?
  9. groupdelay

    groupdelay Network Guru Member

    I had the same issue, until I realized I had used the WRT54GS.bin file via the web interface upgrade, instead of the Generic .bin file on my GSv2, going from a past HyperWRT version. Also make sure you follow the recommendation that Brain Slayer gives for upgrading the firmware closely.....I didn't do this properly either. http://wrt-wiki.bsr-clan.de/index.p...22Right_Way.22_to_Flash_Your_WRT54G.2FGL.2FGS

    Once I followed the directions I had no more issues. :thumb:
  10. mikez

    mikez Network Guru Member

    ok since i have the wrt54gs v4 i just flashed my router with the wrt54gs v4 MINI instead of the standard version (which i had flashed it with previously). I'm going to try this out and see if this solves the problem. By reading groupdelay's post and reading the wiki i found out that i can't just go right from linksys firmware to dd-wrt v23 STANDARD. It seems kinda trivial but i guess i will give it a try and let everybody know.
  11. groupdelay

    groupdelay Network Guru Member

    Be sure to use the Generic Versions if you are upgrading using the web interface. If using TFTP, then use proper named version based on the router type. :thumb:
  12. brucebeh

    brucebeh Network Guru Member

    make sure you set your DHCP lease time to 1 day.

    1440 minutes (i think)
  13. shadfax

    shadfax Guest

    Put me down as another suffering this same problem. Installed DDWRT this weekend (first went back to linksys stock, then to DDWRT v23). Everything working great except for occasional DHCP issues with "Limited Connectivity" showing up on more than one wireless device.
  14. mikez

    mikez Network Guru Member

    Well it seems that i might have my problem solved. :thumbup:
    after setting the factory defaults and putting the mini version on my GS v4 im almost up 1 day with no problems what so ever.
    Time: 10:17:39 up 23:13

    Before, the router would be up for a couple of hours, and then i would get limited connectivity.

    I suggest to the people who are still having the same problems to do the same, try the mini version, just dont brick your router! 8O
  15. asianangel28

    asianangel28 Network Guru Member

    why do we have to install the mini version first, then the standard version afterwards?
    what will happen If I just installed the standard version only?
  16. spooky75

    spooky75 Network Guru Member

    I'm also experiencing problems with wrt54gsv4: wireless connection often interrupts during large file transfer on a speed around 620 KBytes/sec.
  17. Nimdae

    Nimdae Network Guru Member

    You know, I thought I might have had an isolated issue due to my network setup, but now I see this is something in v23. I did a massive amount of changes to my network recently, which included updating the firmware on my router and my wap, and I have been going crazy trying to find out wireless links are unstable. My wap loses connection and doesn't regain it until I reboot the router, but my laptop seems less affected.

    I'm gonna see if I can revert back to v22 because this is causing too many problems with my network. Heck, I may just go with a linksys firmware if need be. I need my network stable.
  18. phinn

    phinn Network Guru Member

    I am having all these problems too on my WRT54G V4. This is obviously a problem with the new v23 firmware because I have not seen it before.

    I switched to HyperWRT + Tofu12 and everything works great. I would like to switch back to DD-wrt because I really like the web interface but until there is a fix Tofu is really good.
  19. Sjowhan

    Sjowhan Network Guru Member

    I have a wrt54g v2.2 here, and the connection keeps disconnecting (WAN) every 4hours. I have re-flashed my router to the original firmware of linksys to see if dd-wrt is the problem.

    I have already changed the modem of my ISP with another one..
  20. groupdelay

    groupdelay Network Guru Member

    Flash the Mini version then flash the std version and you should not have them problem any more. Also make sure you use the generic versions if your not upgrading via tftp from the original linksys firmware.
  21. vincentfox

    vincentfox Network Guru Member

    WiFi signal drops

    I can specifically document this problem as well.

    Signal dropping and then reacquiring frequently, at least once every hour. Shows on 2 different laptops at same time, which have different WiFi cards so do not believe this is client-side.

    WRT54GS v1.0 unit, equipped with dual 6 dBi omi, client shows this symptom even in same room with WRT. No microwave or 2.4 GHz appliances in operation. No strong signals on nearby channels according to NetStumbler. So it is definitely NOT an interference issue. Or at least not an obviously detectable one.

    Unit flashed via web first to v23-final mini-generic, then vpn-generic, with full long-reset each time.

    All settings configured by hand and double-checked, I've been doing this a while. Running WPA-PSK AES. No changes made to Wireless->Advanced.

    Syslog enabled, nothing shows in there at the times of these events. Well, except for dnsmasq showing the DHCP transaction. I am using dnsmasq instead of dhcpd. The standard dhcpd would quit out without warnings too often.

    Next step, I have another WRT54GS v1.0 unit, I will set it up from scratch, swap, and see if it exhibits the same behaviour. That should eliminate possibility of "lemon" unit from consideration.
  22. MBChris

    MBChris Network Guru Member

  23. vincentfox

    vincentfox Network Guru Member


    I have observed this on 2 different GS v1.0 units.

    Both flashed using standard precautions, first mini then standard version, with long-resets to clear NVRAM.

    First unit with v23-final. Having disconnect problems.

    Thought okay maybe I made a mistake, or maybe bad hardware.

    So I flashed a 2nd GS v1.0 unit with v23-sp1-beta dated Jan 16 2006. Put this unit as main router in household.

    Still observing WiFi disconnects, at least 6 times today, and with only 1 laptop so not a too many clients issue.

    Nothing in syslog, no obvious reason for this.

    I am using WPA-PSK AES, perhaps specific to encryption mode?
  24. MBChris

    MBChris Network Guru Member

    Im sure you tried it also WITHOUT Encryption ?
  25. vincentfox

    vincentfox Network Guru Member

    You know, after current events with GS v5 being VxWorks, I am too depressed to spend more time hunting this bug. Tonight I open good bottle of wine and enjoy a movie.

    Perhaps tomorrow night.
  26. NinjaBoy

    NinjaBoy Network Guru Member

    I have a WRT54GS v2. Flashed from the official Linksys to the DD-WRT mini. Turned off the router for about 5 minutes, then booted up and flashed to the standard. My connection started dropping randomly also. Anywhere from a few minutes to a 10+ hours on my laptop, and usually my wired computer would lose the connection too. I would need to unplug the router, wait a minute, plug back in and the connection would come back.

    I tried resetting the settings back to the firmware defaults, & factory defaults, neither helped.

    Also, when I would turn on my laptop it would take forever to get an IP assigned. Usually it would get a Limited or No Connectivity warning.

    After about a few days time though I flashed to HyperWRT + Tofu and has been stable since (2 days).

    I like the DD-WRT interface much more though and would be happy to switch back soon as the bugs been mashed.
  27. alag

    alag Network Guru Member

    vincentfox: this sounds similar to the issue I have. I have 2 wrt54g's (v3 & v4) running dd-wrt v23, talking to each other. All works fine but when I tried to use wpa-psk I got disconnects about once per hour. Sometimes the connection would come up again in a minute or so, sometimes it won't. I changed security to wep and so far had zero problems.
  28. komUnec8

    komUnec8 Network Guru Member

    Ditto for me. However, I noticed something else which may be a clue to tracking this bug down.

    I have a new WRT54GSV4. I flashed it with mini generic DD-WRT v23, then the VPN version for the WRT54GS and had no issues with the wireless stability.

    Yesterday, I reflashed with the Standard version (to see what the diffs were), and ran into wifi disconnections and very long DHCP negotiation stages on both wired and wireless connections.

    Suggesting that there is a difference between the two versions that may be causing the problems?

    Haven't had the time to look at the differences in the source. Does anyone know what they are and can speculate on what might be wrong?

    If there are diffs between the various versions even in what is supposed to be common functionality to all, should we not make sure we mention exactly which version of the firmware we have loaded (along with which hardware it is on) when describing the problems we are having? eg "dd-wrt v23 voip running on wrt54gs-v4"

    On another track which may be totally unrelated or even normal, (so please kill this as a wrong turn if it is one), I also notice a lot of repeated loading/unloading of some modules during the boot process, which may be normal but looks strange to my inexperienced eyes.

    see partial dmesg dump below.

    vlan0: add 01:00:5e:00:00:01 mcast address to master interface
    vlan0: dev_set_promiscuity(master, 1)
    device vlan0 entered promiscuous mode
    br0: port 1(vlan0) entering learning state
    br0: port 1(vlan0) entering forwarding state
    br0: topology change detected, propagating
    device eth1 entered promiscuous mode
    br0: port 2(eth1) entering learning state
    br0: port 2(eth1) entering forwarding state
    br0: topology change detected, propagating
    ip_conntrack_pptp version 1.9 loaded
    ip_nat_pptp version 1.5 loaded
    ip_nat_pptp version 1.5 unloaded
    ip_conntrack_pptp version 1.9 unloaded
    ip_conntrack_pptp version 1.9 loaded
    ip_nat_pptp version 1.5 loaded
    vlan1: Setting MAC address to 00 14 bf dc 0c 15.
    vlan1: add 01:00:5e:00:00:01 mcast address to master interface
    ip_nat_pptp version 1.5 unloaded
    ip_conntrack_pptp version 1.9 unloaded
    ip_conntrack_pptp version 1.9 loaded
    ip_nat_pptp version 1.5 loaded
    ip_nat_pptp version 1.5 unloaded
    ip_conntrack_pptp version 1.9 unloaded
    ip_conntrack_pptp version 1.9 loaded
    ip_nat_pptp version 1.5 loaded
    vlan1: dev_set_promiscuity(master, 1)
    device vlan1 entered promiscuous mode
    vlan1: dev_set_allmulti(master, 1)
    device br0 entered promiscuous mode
    ip_nat_pptp version 1.5 unloaded
    ip_conntrack_pptp version 1.9 unloaded
    ip_conntrack_pptp version 1.9 loaded
    ip_nat_pptp version 1.5 loaded
    ip_nat_pptp version 1.5 unloaded
    ip_conntrack_pptp version 1.9 unloaded
    ip_conntrack_pptp version 1.9 loaded
    ip_nat_pptp version 1.5 loaded
    ip_nat_pptp version 1.5 unloaded
    ip_conntrack_pptp version 1.9 unloaded
    ip_conntrack_pptp version 1.9 loaded
    ip_nat_pptp version 1.5 loaded
    ip_nat_pptp version 1.5 unloaded
    ip_conntrack_pptp version 1.9 unloaded
    ip_conntrack_pptp version 1.9 loaded
    ip_nat_pptp version 1.5 loaded
    vlan1: dev_set_allmulti(master, 1)
    vlan1: add 01:00:5e:7f:ff:fa mcast address to master interface

    Any ideas why these come and go so much? Is it because the process is related to each device or interface?
  29. vincentfox

    vincentfox Network Guru Member

    I have just loaded openwrt RC4 onto my GS v1.0 unit.

    Same hardware that was experiencing the disconnects.

    So if this goes for a day without constant WiFi client cuts, then I'll know it's the OS and not the hardware.
  30. whozyodaddy

    whozyodaddy Network Guru Member

    I have a WRT45G v2.

    I am getting the exact same problems, although I have never used DD-WRT, but rather Tofu. I think it all began when I upgraded from the linksys default firmware, and switched my computer to wireless.

    In the house, a total of 3 computers use the wireless (two laptops one desktop). The two laptops, located downstairs from the router, disconnect randomly and often - and take forever to assign an I.P., connect, etc. The desktop, located in the room next to the router, recieves low signal strength/speeds and disconnects, although not as often.

    I am going to revert back to linksys firmware and see how it goes.
  31. dellsweig

    dellsweig Network Guru Member

    Re: WiFi signal drops

    Are you sure you dont have interference issues??

    Other wireless networks, phones, other appliance??

    Possibly environmental issues - have you boosted your transmit power - could be an overheat....

    Does the issue only effect wireless??
  32. vincentfox

    vincentfox Network Guru Member

    Did you read the post that you hit the Quote button for? Yes, I promise I'm not a n00b.

    Restating, no 2.4-GHz appliances in the house.

    A few neighboring networks shown by NetStumbler, but not on nearby channel nor strong enough to account for this. They are all on Channel 6 :)

    As I said, I've done this with 2 different GS units, from clean firmware setup so I don't think it's a random thing. A wired desktop PC running Azureus never hiccups. Nothing shows in syslog other than the DHCP renews by the client.

    Happens on 2 different laptops using different WiFi cards, Hawking HWU54D in one, and Intel 2915 in the other.

    Now I would tend to read these DHCP entries as effect, not cause. Because my lease is set for 1-day, and these events are not occuring at half-day interval on the dot like you would expect. Occurs up to 4 or 5 times an hour.

    I'm beginning to wonder about flaky BroadCom drivers. This is something BrainSlayer will have no control over because those are closed-source binaries if I recall correctly.

    One things nags at me though. Wasn't there some hack that raised the clock-speed from 200 to 216 MHz to stabilize something? Perhaps it's not even connected with this problem. According to dmesg|grep MHz my GS v1.0 units show 200 MHz.
  33. vincentfox

    vincentfox Network Guru Member

    *oop ack thpththt*

    Long day.

    I have gone back to using the internal 802.11b card on one laptop, using WEP-128 and no problems noted yet.

    I have to wonder if the other *2* PCMCIA cards are just unstable as far as drivers. Or maybe asking WPA-PSK is too much for my combination of hardware.

    I think at this point I would like to just find a good card with good drivers, and ignore costs. Perhaps cheap cards are too much trouble.


    On the other hand, I have had to swap routers back to the GS v1.0 that is running DD-WRTv23. Since I decided to foolishly try raising clkfreq on my test unit, it goes into this constant reboot cycle.....

    Now I need to unbrick an OpenWRT unit, a new thing for me.....
  34. vincentfox

    vincentfox Network Guru Member


    Saved from my own dumbness by the internet once again.

    Found a posting suggesting FREEZING the WRT. Literally put it in the freezer a while to get it to run stable at 216 long enough to login. Then login in and reset clkfreq back to 200.

    Now back to normal operation.

    Resuming testing with WEP and inboard WiFi card.
  35. whozyodaddy

    whozyodaddy Network Guru Member

    An update from my previous post... I installed the latest linksys firmware, and it seems to be going fine, no disconnects. Although, my internet is slower.
  36. vincentfox

    vincentfox Network Guru Member

    In the last day of operation, using the internal Intel 2915 WiFi card, no WiFi disconnects. So perhaps what I have after all, is card issues, not router issues.
  37. __spc__

    __spc__ Network Guru Member

    If SSIDs are hidden your 'site survey' with Netstumbler is a bit of a waste of time. Try Kismet under Linux...

    I did read somewhere that DD-WRT sometimes had issues with WPA2 (i.e. AES).

    You may also want to run winsockxpfix.exe...
  38. vincentfox

    vincentfox Network Guru Member

    NetStumbler usually does show an entry, and a channel it just leaves the SSID field blank. I feel pretty confident this is not a channel conflict.

    WPA-PSK AES used before, as previously specified.

    I'm going to give this a day of WEP to be certain of my current card and it's driver, then try WPA, and finally WPA2 again. If bumping up the encryption on a working card destabilizes things I'll feel more certain about the problem......
  39. XeviouS

    XeviouS Network Guru Member

    Problem Solved...

    I had this exact problem.

    Turns out that the drop outs were due to DHCP renews (default was 10 mins).

    Setting the DHCP lease time to 720 mins solved my problems.
  40. fizze

    fizze Network Guru Member

    Netstumbler perfectly shows networks also with hidden SSID's.

    Anyway, I've found out that WPA with AES indeed causes problems on my WRT54G v2 with DD-WRT .23 mini.
    I switched back to WEP and even to unencrypted for testing and there were no problems whatsoever.

    Seems that the WPA routines cause some sort of memory leak that crash/hang/reboot the WRT..?

    Anyway, as I experienced random lockups with uptimes anywhere from days to weeks I now set up my WRT54G to reboot once per day, and since then I never had a single issue.

    I used Freeman before, and there I often had to telnet to my DSL modem and reboot it since it and the WRT were locked up BAR....
  41. imataqito

    imataqito Guest

    vincentfox or anyone still reading this thread,

    Has anyone ever gotten to bottom of these disconnect problems? I'm experiencing similar problems as described in this thread with a WRT54GL 1.0 running DD-WRT 2.3 Final (Mini version).

    This problem is really annoying as online gaming is pretty much impossible. I am planning on updating the firmware today to the latest SP1 beta, standard edition, to see if there is any improvement.
  42. ofbarea

    ofbarea Network Guru Member

  43. CoBrA2168

    CoBrA2168 Network Guru Member

    I'm having a similar problem.

    I keep the router connection (connected to router) but i lose the internet connection.

    Im using SP1 RC1 and im still getting it. Never had this many disconnects before. Anyone have a solution yet?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice