DDNS doesn't work with latest Tomato on WRT54G v1

Discussion in 'Tomato Firmware' started by justintime32, Apr 15, 2008.

  1. justintime32

    justintime32 Addicted to LI Member

    I just flashed Tomato on my WRT54G (v. 1) and I like it a lot. I like its clean interface and ajax-ish feel. But for some reason, DDNS doesn't work at all. I've tried a few different services (including a custom URL), but nothing works. In version 1.17, all I got was "Updating" next to last result. With the new 1.18 firmware, I don't even get that. And when I telnet in and run "ddns-update", nothing happens either (it runs for a few seconds, but it doesn't do anything).

    I have it set up in wireless ethernet bridge mode, which may be why it doesn't work, but the router can access the internet (pings and traceroutes work fine) so there must be a way for it to work. This is basically a dealbreaker for me, and i don't really want to go back to DD-WRT, so I hope that I can get this working.
  2. badboyndsu

    badboyndsu Network Guru Member

    I use my v1 with Tomato 1.07 and DDNS works fine. I'd say try to revert back one version at a time until it works, or try to find a copy of 1.07 and use that. Post your findings back in this thread so I know if I can upgrade. ;)
  3. mraneri

    mraneri Network Guru Member

    I'm still running 1.14 and it's working fine.

    Anyone else having DDNS problems with 1.18? Anyone having no DDNS trouble with 1.18?
  4. badboyndsu

    badboyndsu Network Guru Member

    But are you using the v1 WRT54g?
  5. justintime32

    justintime32 Addicted to LI Member

    My best guess is that the DDNS client tries to update using eth1 (the WAN port), which is not hooked up in my router since it's being used as a wireless ethernet bridge. DD-WRT used vlans, I think, which may be why it worked. I'll try flashing it with an older version to see how that turns out.
  6. justintime32

    justintime32 Addicted to LI Member

    I just tried version 1.13, and it doesn't work there either. My best guess is that the DDNS client is trying to use eth1 (WAN), when there's nothing plugged in there. I'm going to investigate this further later tonight.
  7. mstombs

    mstombs Network Guru Member

    ddns working fine for me with latest 1.18 and normal WAN IP by dhcp.

    If the router doesn't have the real WAN IP you can try the option to "Use the external IP checker" and if the router doesn't have internet access - it has no right to be trying to update your ddns entry!
  8. justintime32

    justintime32 Addicted to LI Member

    That's the option that I am using, but the issue isn't that it updates the wrong IP, it doesn't even connect to the DDNS server (which is, in my case, DNS-O-Matic, but I have also tried others with the same result).

    I know that it can access the internet, because I can use the ping and trace tools just fine. The only difference is that it access the internet through br0 (LAN) instead of eth1 (WAN).

    The good news is that I found a workaround. Instead of using the normal DDNS page, I just have a command run every hour:
    wget "http://username:password@updates.dnsomatic.com/nic/update?hostname=all.dnsomatic.com&wildcard=NOCHG&mx=NOCHG&backmx=NOCHG" -O /dev/null
    And that works pretty well. So if anyone else has a problem like this, use DNS-O-Matic and that workaround.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice