DDNS HTTP/1.1 200 OK 11=Error:No space left on device

Discussion in 'Tomato Firmware' started by andy, Aug 12, 2013.

  1. andy

    andy Addicted to LI Member

    I am using :
    Tomato Firmware v1.28.7492 MIPSR2-Toastman-RT K26 USB VPN-NOCAT

    Everything had been working well for some period of time. Today, I suddenly cannot locate my router due to the DDNS problem.

    My DDNS settings :
    Service : Customer URL
    URL : https://www.dnsexit.com/RemoteUpdate.sv?login=xxxx&password=xxx&host=xxx.linkpc.net&myip=
    Last IP Address : 8/12/2013 12:22:20 PM:
    Last Result : 8/12/2013 12:22:20 PM:
    HTTP/1.1 200 OK 11=Error:No space left on device

    I don't know why I get "11=Error:No space left on device" error, the DDNS is not updated and I cannot locate my router by its name xxx.linkpc.net.
  2. shibby20

    shibby20 Network Guru Member

    try add to the url:
    -O /dev/null

    -O /tmp/dnsexit.result
  3. andy

    andy Addicted to LI Member

  4. shibby20

    shibby20 Network Guru Member

    via browser i`ve got the same error. Maybe "they" has some problems?
  5. koitsu

    koitsu Network Guru Member

    Your DDNS provider's filesystem has run out of disk space. File a support ticket with them, call them, or change providers.
  6. andy

    andy Addicted to LI Member

    The router is far away from me, I asked them to use an old WL-520gU to replace the problem router, then the error disappeared. It seems that it is not related to the DDNS provider.

    WL-520gU firmware : Tomato Firmware v1.28.7821 MIPSR1-Toastman-ND K26 USB Lite
    DDNS last result : HTTP/1.1 200 OK 0=Success
  7. koitsu

    koitsu Network Guru Member

    Let me be more clear: between the time the issue started and the time you had someone "replace the problem router", your DDNS provider (dnsExit) fixed their problem.

    Both Shibby and myself visited the relevant DDNS updater URL at www.dnsexit.com in our browsers and we both got the same result -- HTTP 200 OK (which is an absolutely invalid/incorrect response for an error condition -- they need to fix their webserver code to return non-200 status if any kind of error happens! Edit: seems this is "by design" for DDNS -- awful, awful protocol, shame on whoever decided that) but with an actual content response of 11=Error:No space left on device.

    Don't believe me? See their own documentation.

    So to be clear: this issue had nothing to do with the router, firmware, or anything else -- it was an issue with the DDNS provider which they have since fixed. You had someone replace a router that is perfectly fine/good.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice