DDNS Service not updating with proper IP

Discussion in 'HyperWRT Firmware' started by Turbe, Mar 22, 2007.

  1. Turbe

    Turbe LI Guru Member


    I'm running Thibor 16b on a SL and I now have a need to use DDNS.

    My SL is connected (wired) to a actiontec that connects directly to the dsl line:

    DSL------->Actiontec (>( SL(>my network

    I setup my account with DynDNS.org and my host, configured the SL in the DDNS page, I do see my proper currently assigned PUBLIC IP address (under 'Internet IP Address' on that page)... this IP address is actually on the Actiontec, but the SL does see it here.

    I do a force update and check my account on DynDNS.org and I see the update, however, it is being updated with the IP assigned (internal subnet) to the SL ( and not the proper PUBLIC 'Internet IP Address' which does display correctly on the DDNS page.

    What am I doing wrong?

    Thanks in advance!
  2. Turbe

    Turbe LI Guru Member

    Now I went to disable DDNS and I can't, it keeps giving me "Error on Page".. I've also tried after rebooting....

  3. mw1001

    mw1001 Network Guru Member


    I’m having problems with DDNS too.
    My WRTSL54GS is running Thibor17rc3, routing a PPPoE ADSL.
    I use DynDns. In DDNS options the "Internet IP Address" is not the right one, and my router always give me the message "DynDNS does not require updating". Even if I disconnect and reconnect to change the IP, the IP listed at DDNS section doesn’t change.

    I tried reboot, disable, enable the DDNS, etc. Nothing has worked. Any suggestion?

  4. mw1001

    mw1001 Network Guru Member

    Today I made another test, trying solve this problem.
    I restored to factory default, with ‘clear NVRAM’ option.
    After setup all options again and test the configuration, I turned on DDNS again.
    The first time it worked ok. But after disconnect and reconnect, my router keeps the first IP.

    Anybody is having this kind or problem with Thibor 17rc3?

    There is any file that I can delete or edit in wrtsl?

    The wrong IP is in /tmp/ddns.conf and /tmp/ddns.cache. I can edit and change the IP but will not help.
    I tried delete both files and restart the router, and that doesn’t solve the problem. After restart, the files are back in /tmp dir, with the inicial wrong IP.

    I really need the dyndns, and appreciate any help!

    Thanks in advance.
  5. Toxic

    Toxic Administrator Staff Member

  6. mw1001

    mw1001 Network Guru Member

    Hi Toxic,

    I'm a long time user of Thibor’s firmware. The truth is: I only buy routers that are compatible with Thibor’s firmware :)
    I have another 3 Linksys WRTs (2 WRT54GSv2 and one WRT54GL) running Thibor’s firmware and any of then has problems to update DynDns.
    If I switch the WRTSL54GS (Thibor 17rc3) for one WRT54GS (Thibor 15c) DynDns is updated without any problem. So, I conclude that something is wrong specifically with the WRTSL54GS.

    I will try reflash to see if helps, since clear NVRAM don't solve my problem and looks like i'm the only one with this kind of insure.

  7. frenchy2k1

    frenchy2k1 LI Guru Member

    Hi MW,

    you're not the only one.
    I have a SL and I've never succeeded in getting Dyndns to work. In my case, I went from 15b to 17b and both times the Dyndns failed to work (known problem in 15b, but i was too lazy to switch).
    As I use dyndns to redirect to a PC server, I just got this PC to run the dyndns updater client. Dyndns point to several ones in their link section.
  8. Turbe

    Turbe LI Guru Member

    I had to go back to running that DynDNS update client on one of my servers...I could not get the SL to work at all... in fact, I still can't even disable this function in the router, I just had to put in a fake username/password host to prevent it from causing problems with my DynDNS account...

    I do like the fact that the update client has an option to immediately email me when there is a change...
  9. ka9yhd

    ka9yhd LI Guru Member

    As people post here about problems, Thibor will see them and try to duplicate the problems. If he is able to confirm the problems they will get fixed with another release.

    So hang in there, Thibor is only one person with a family and he will get to it as soon as he can.
  10. mw1001

    mw1001 Network Guru Member

    Isn't necessary remember Thibor is doing this for free. We are grateful!
    But report bugs are aways important. So, this thread is not a complain: it's a bug report :p

  11. Thibor

    Thibor Super Moderator Staff Member Member

    ok guys, bug confirmed and fixed here. i'll release a new version when the new sources are released. i understand from cisco that it will be very very soon, although they've been saying that for a couple of weeks now.
  12. lewislin

    lewislin Guest

    Dear Thibor,
    Have you get a chance to release the thibor17 that would fix the dyndns bug?

    Thank you!
  13. plugh

    plugh Network Guru Member

    Or alternatively, could you post a zip/rar/tar of the files changed for rc2->rc3 AND the dyndns fix, so a person could use your rc2 source kit, apply updates, and build an rc3+?

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice