De-bricking: the devil is in the detail

Discussion in 'Cisco/Linksys Wireless Routers' started by pvsutton, Jan 3, 2006.

  1. pvsutton

    pvsutton Network Guru Member


    *Sorry if this post is a repeat, I can't find it on the forum, so I'm presuming that I mucked up the sending. If this is a duplicate would the moderators please remove it, and accept my apologies]

    I used to have a small LAN with 2 routers, an old WRT54G running Satori 4 and a (slightly) newer WRT54GS (v1.0!) also running Satori 4. The two gave me a wireless connection 2 stories away from my cable modem, and allowed me to connect 2 old machines (which won't cooperate with wireless) using cable to the GS. Everything fine, and me complacent.

    Then the GS packed in. I think the transformer went (judging by the intermittent nature of the little green light), and it looked as though my old GS was bricked. Nothing I could do seemed to help (lots of time with the reset switch). I can't find the receipt, so I reckoned I had nothing to lose by pulling it open and trying out shorting pins. Well, I probably didn't identify the pins accurately, but the whole thing looks very dead.

    So I went out and bought a new GS, and - theoretically - struck lucky. My local store (UK) had only one left, which turned out to be a v4. So I looked round the websites, found that I couldn't use Satori 4 on my new router, and looked elsewhere. I tried DD-WRT because it seemed small enough. The first time it looked very bare indeed. The second time the fonts went all corrupted. Third time and it mostly seemed OK, but not everything.

    So I tried again and this time bricked it. Spyware program? AV program? Didn't leave it alone long enough? Didn't re-boot straight afterwards? Didn't do something else? I don't know what I did, but could be any of those, plus some more I haven't thought of.

    (The real answer was that I bragged about how my complicated 2-router, 2-operating system cable/wireless mix of a network was just wonderful. In a word what happened to me was Nemesis - famously the reward of Hubris. Never let the gods hear you bragging.)

    I tried resetting it again, being careful to let it stand for a minute, and being careful to hold down the button for 30 seconds/ 60 seconds / 90 seconds (with and without pauses, resets etc). No luck. So I reckoned that my sanity was worth the extra cash and went to buy a new one.

    But NOW the shops all have only v5 routers. So I'm going to have one last go with breaking open my pretty brick and trying to revive it. And this time I'm reading all the instructions I can find first.

    Trouble is - there are so *many* instructions. So, I'm here for some detailed advice.

    When you've bricked a router, which is the firmware with the best chance of getting itself re-loaded? All the ones that rely on sending codes first are out - my router is deaf. Since it's a v4, I presume I need a small one. I really want to get back to my old WDS system, so it needs to have that capability. I would much prefer to be able to go back to the hard-won settings on Satori v4, but if that's not possible, then I'd like to have a firmware which would be able to talk to the Satori-enabled router downstairs (which is nobly carrying the full load of my internet connection).

    It doesn't look as though I can use the web interface, I suppose I will have to use tftp, but that has problems. One post says don't use the Linksys tftp program. Another recommends that you use it because it will keep trying. In another place I read that all Windows programs take too long, and won't get in before the boot_wait is over. (And I can't change the boot wait time because, amongst other things, I can't talk to the router at all.)

    Then I can't work out exactly what file name to use. Some of the places I've read say to use a file name like "openwrt-wrt54gs-jffs2.bin". Somewhere else said that it was essential that you rename the file "code.bin". Some seemed to say use "<code>.bin" - presumably meaning that you use the filename you downloaded.

    Even the generally very helpful Revival Guide is not wholly clear. My next step is to try the screwdriver-pins 15 and 16 (which, BTW, are almost impossible to locate on the old WRT54GS v1.0 - you have to remove the mini-PCI card and then hope you can locate pin 1). But it does not say exactly what you should do if you do manage to get a signal. Do you wait? (Lack of waiting being a prime candidate for bricking in the first place) Or is this a case where you have to act within 3 seconds? Do you try for new firmware or will you have the old one back? Does anything take it back to the original factory defaults?

    I thought I had done something intelligent when I used the original web-based software to create a backup file. Now I have a file called WRT54GSV4_v1.05.3.cfg sitting on my hard drive, all dressed up and nowhere to go. Is this of any use to anyone at any time?

    Sorry this is so long, but I really need some detailed suggestions. Of course, it might be that I'm not going to get anywhere, and will have to try and find another solution (ignoring partner muttering about wires being a lot simpler, and electricians cheaper than *another* blue brick). But that's another posting.

  2. Couledouce

    Couledouce Network Guru Member

    If you get your WRT back from the brick, do not use your backup file UNLESS you use exactly the same firmware as you used to save it.

    But first things first, get it de-bricked :)

    The most standard revival instructions are these ones:

    Use the Linksys stock firmware to get your WRT back before worrying about which 3rd party one to use for your WDS.

    The "detail" that always helped me was ensuring I used a static IP address for me PC.

    Good luck.
  3. pvsutton

    pvsutton Network Guru Member

    Easy bits first, eh?

    Assuming I can get that bit done , should I use the filename "code.bin" or use the name of the file as downloaded?

    Which tftp prog do you recommend?

    Thanks for reply.

  4. 4EverGreen

    4EverGreen Network Guru Member

  5. vibe666

    vibe666 Network Guru Member

    i'm having similar problems with a wrt54g v2.

    got to the point where i was at 10/half static ip and managed to re-flash it with the original linksys firmware, but after a hard reset i was back to square one with no ip, no nothing and a rapid flashing light.

    i'm thinking that a jtag is my next step, but not sure where to start (for a windows user) or where to get a cable cheaply. i've thought of getting the parts and making it myself, but have looked at the guides i can find for this, and am none the wiser on where to get the bits, or exactly how to get it working properly.
  6. SteelersFANinMA

    SteelersFANinMA Network Guru Member

    vibe666, I'm in the same boat with my G v2. I went out and got a GS v3 in the meantime. It's very nice with Thibor11 HyperWRT! Anyways, for Windows I'd suggest starting here if you haven't already:

    To build the JTAG cable, use this picture: and the .png provided in The pictures in the .pdf are OK for some reference, but don't use them to figure the connections, as you should need a male DB25 connector and the one in the .pdf is female. There is more info. here:, but it's mostly for Linux. I managed to find a place to get the parts,, but I had to travel an hour to get there. I also had to do some improvising in the construction, as the store only had 14 pin ribbon cable, connectors and male headers, (12 pin needed). You can also get the DB25 and 100 ohm resistors at Radio Shack. So far, I've managed to build one cable, but I'm getting errors when using it. When I get a chance, I'll strip it down and rebuild it. As far as buying one, I tried to for the heck of it from here:, but you can only request items through email. I first tried buying a cable from them through PayPal, but they sent my payment back. Next, I emailed them, but they haven't emailed me back yet. I even tried to call them, but only got their answering machine. Oh well, back to the workbench.
  7. Couledouce

    Couledouce Network Guru Member

    Try ebay?
  8. vibe666

    vibe666 Network Guru Member

    thanks for that SteelersFANinMA, I think I'll try building my own.

    is this the correct image?


    there's an electronics shop near me that might have everything i need called maplin. i'll give them a go shortly.

    couldn't find anything on or worldwide unfortunately. plenty of jtags for satellite dishes, but i don't think they are quite the same. who knows, if I get it working again, i might start making them in bulk and selling them. looks like theres a gap in the market for it. :)
  9. SteelersFANinMA

    SteelersFANinMA Network Guru Member

    Yes, that's the pic. Don't follow it for the ground though. It shows even pins 2-12 on the router's side connected to pins 18-25 on the PC side. It should be, any one even pin except for 12 on the router's side to pins 20 & 25 on the PC side as pin 12 may or may not be grounded on different versions of the router. You'll see that in the .png provided in the .zip and read about it in one of the docs.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice