De-bricking the RV082

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by MickLC, Jan 9, 2007.

  1. MickLC

    MickLC LI Guru Member

    I have an RV082 that has failed a firmware upgrade and I'm at my wit's end at trying to get it working again.

    The firmware was at 1.1.x.x, I think, and I upgraded to and then to other firmware I found here (after things died due to the upgrade).

    Here's what things look like at the moment:

    SME100boot> rg_conf_print /
    (description(LAN Ethernet))
    (tz_name(Greenwich Mean Time))
    (release(Jun 25 2004))
    Returned 0

    SME100boot> flash_layout
    Flash layout:

    Section 00 Type BOOT Range 0x00000000-0x000F0000 MaxSize 0x000F0000
    No more information.

    Section 01 Type FLASH_SECT_BOOTCONF Range 0x000F0000-0x00100000
    MaxSize 0x0000FEEC
    Size 0x000002F9 Name 'rg_conf'
    Checksum 0x000182FA Counter 0x00003EC4 Start Offset 0x00000000

    Section 02 Type IMAGE Range 0x00100000-0x00640000 MaxSize 0x0053FEEC
    Size 0x005154FD Name 'Image downloaded from:
    Checksum 0x297F0124 Counter 0x00003EBC Start Offset 0x00000000

    Section 03 Type IMAGE Range 0x00640000-0x00B80000 MaxSize 0x0053FEEC

    Section 04 Type FLASH_SECT_CONF Range 0x00B80000-0x00DA0000 MaxSize 0x0021FEEC
    Size 0x000060AB Name 'rg_conf'
    Checksum 0x00301A9F Counter 0x00003EAA Start Offset 0x00000000

    Section 05 Type FLASH_SECT_CONF Range 0x00DA0000-0x00FC0000 MaxSize 0x0021FEEC
    Size 0x00005EDA Name 'rg_conf'
    Checksum 0x002E9BA2 Counter 0x00003EAC Start Offset 0x00000000

    Section 06 Type FACTORY Range 0x00F80000-0x00FA0000 MaxSize 0x0001FEEC
    Size 0x00000211 Name 'Image downloaded from:
    Checksum 0x000099B6 Counter 0x00000028 Start Offset 0x00000000

    Total 7 sections found.
    Returned 0

    Obviously, I can telnet in, but only if I hold down the reset button while powering up. Other than that, nothing works. The web server is dead. The diag light doesn't flash and the port lights light up when I plug something in, but nothing happens.

    Is there anything I can do to get this working, or do I just have a curiosity on my hands?
  2. heidnerd

    heidnerd LI Guru Member

    Since you can connect and get to openrg, have you tried re-loading firmware then, powering off the RV082, forcing a hard reset and see try it again?
  3. MickLC

    MickLC LI Guru Member

    What I've done has been to re-load firmware and then issue a reboot. That's what got the diag light to stop flashing, but still nothing on actually routing anything else.

    UPDATE: I've now actually tried to re-load the firmware, power off the unit, and then power it back up again. Still nothing.
  4. Toxic

    Toxic Administrator Staff Member

    when you reloaded to did you allow it to reboot on its own?
  5. MickLC

    MickLC LI Guru Member

    This may have been the problem.

    The first time, I was able to use the web interface and then let it reboot. But it seemed to die, so I restarted it. It worked briefly, but then it died and I've been at this point since.

    The last time I tried to load the firmware (using the HOWTO for the RV042) I did unplug it instead of issuing the reboot command, but I've also tried issuing reboot as well as boot -s 2.
  6. Toxic

    Toxic Administrator Staff Member

    have you tried holding down the reset button for 30 secs with power on?
  7. MickLC

    MickLC LI Guru Member

    I think that was the first thing I tried. Nothing happens. Lights don't change.

    Just to be sure I did it for a full 60 seconds just now. The laptop that I have hooked up to it says "No route to host"
  8. DDogg

    DDogg LI Guru Member

    I am hesitant to mention this and you should double check, but I do remember a similar problem with a linksys router - A special hard reset was accomplished by holding down reset button, waiting for reset, unplugging (while still holding the reset) and then replugging in to power after 20 seconds or so (again all of this is while holding the reset button in). Please double check with somebody else before doing this - my memory of exactly how support told me to do this is cloudy - I could be giving completely wrong info.

    The upshot of this style of hard reset, if it is even supported by the rv082, was to completely blow out the firmware so that upon power cycle, a factory type window came up with a simple browse button asking for firmware location. In other words, this returns the router to factory, pre-firmware state.

    For the third time - I may be wrong, completely full of beans, etc. Hell, it may have even been a different brand router. Getting old is hell. Perhaps the ticket is to call support and ask them if there is such a thing as a hard reset on the RV082.
  9. MickLC

    MickLC LI Guru Member

  10. DDogg

    DDogg LI Guru Member

    If you follow cyboc's instructions (pasted below) and still can't reach with a browser, I would try another cat5 jumper and try every one of the 8 ports to rule out a bad port or jumper (even try from another machine). If you still can't hit on any of them I think it must be a hardware malfunction and indeed you do have a new doorstop.

  11. OpticalMan

    OpticalMan LI Guru Member

    I had a similar problem before with my RV082. I was reverting back from a higher rev level. I thought the unit was dead after a lot of hacking. I can't remember exactly what I did to revive it, but I believe I held the reset button for >5 seconds while pluging the power in. Then I went to The page prompted me to browse for a firmware update file. Make sure to set your computer IP address to static on the same subnet for example:
  12. heidnerd

    heidnerd LI Guru Member

    The last bit of advice is good... simple, but I also have been nailed by that in the past -- pc tries to dhcp - router was still in a strange state so pc setup the default 169.x.x.x ms ip address. So connection to would fail every time. ipconfig /release & renew after rebooting the router solves that problem. (if you are using dhcp).
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice