Dead wrt54g v2 after saving configuration in dd-wrt

Discussion in 'DD-WRT Firmware' started by peich9, Apr 11, 2005.

  1. peich9

    peich9 Network Guru Member

    Hi, my router has just died in a strange way.

    It's a v2.0 running dd-wrt pre3.2. It has been running okay for a week with that firmware. This evening I was configuring a wireless network in the router, typed the name of network, hit save button and then changed some advanced settings and hit save again. I did this very quick, when I hit "save" the second time, the wlan led was still off, it had not changed yet to "on". So I think the configuration was kinda messed up.

    Now the router has the power led blinking. I have reflashed the router using the pin 16 method (the only way to get the pings back). But the power led is still blinking.

    Maybe have I damaged the nvram when I did the savings so fast? It's the jtag the only available recovery method now?

    By the way, I have just tried to flash an official firmware and dmz light is now on when I power up the router, but the power light continues the blinking thing. But anyway, I don't think it's related to the firmware, it was working before the savings !!!

    Any help would be greatly appreciated.
  2. Wikking

    Wikking Network Guru Member

    hi,yesterday i had nearly the same problem! after flashing with pre3.2 and loading a nvram backup (made with 3.2). the power led was blinkin all the time. only chioce was to reset using pin-method. but as i finally got pings from the router it wasn't possible to reflash sucessfully with dd-wrt! only firmware that worked (with tftp) was satori! after flashing with satori power led got back to "simple" on!
    So maybe you schuld try this! worked for me!
  3. peich9

    peich9 Network Guru Member

    No, it doesn't work. When I flash Satori, it just keeps blinking. It flashes successfully (or so it seems). When it finish and the router is automatically rebooted, the power and dmz leds stay on, without blinking, but the router is not pingable. Then I try t o hard-reboot but, like before, the power led keeps blinking.

    Thanks, anyway
  4. tl511

    tl511 Network Guru Member

    I had this exact same problem. I kept doing the same thing you did. Every time I would load a tftp image it took perfectly. Then I would reload the router by pulling the plug. I found out this was my problem. I had to leave it up and it will reboot itself when it is done. DO NOT REBOOT IT YOURSELF. Or at least wait until it is operational. I kept doing it too early and it was always staying the same. If you run tcpdump on the interface, just wait and watch for some new activity (IGMP packets from the router). I did this with the latest Linksys software and it worked.
  5. peich9

    peich9 Network Guru Member

    I finally managed to recover the router. I made a JTAG cable; I had to reflash the CFE and erase the NVRAM. Then I could do the pin 16 trick again and I tftp'ed Satori, but when I rebooted the power led was blinking again, although it replied the pings but no telnet access. The reset button didn't work. So finally I erased the NVRAM again with the JTAG cable, and then the router was finally working ok. So I flashed dd-wrt and I have a fully working wrt again
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice