debrick wrt54gs v1.1 ( stuck in boot_wait? )

Discussion in 'Cisco/Linksys Wireless Routers' started by centyx, Oct 20, 2007.

  1. centyx

    centyx LI Guru Member

    debrick wrt54gs v1.1 ( stuck in failsafe? )

    I have a wrt54gs v1.1 that I bricked a couple years ago by upgrading to a bad custom-built sveasoft firmware.

    Tonight, I decided to try to revive it and followed the instructions here, which tell you to short pins 15,16 of the flash during boot and then upload a new firmware image via tftp.

    Shorting the pins got the router to respond to pings, and I am able to tftp a new firmware image ( so far I've tried openwrt-wrt54gs-2.4-squashfs.bin and Linksys's WRT54GSV3.0_4.71.1_US_code.bin ), but after the tftp client reports that the transfer is complete, the DMZ led lights up steady and the router becomes unreachable. Ok, I thought, it's rebooting. I've left it for about 5 minutes and it hasn't come back up.

    After power cycling the router, it still has address ( this should have changed if OpenWRT had loaded successfully ) and the only thing accessible if tftp. No telnet, no http ( in the case of the linksys firmware ), etc.
    The power led continues to blink furiously and the DMZ led blinks slowly.

    It appears as though it's stuck in that phase where I shorted the pins and it stops to let you tftp new firmware.

    Any suggestions/help?


    EDIT: Also, I tried holding the reset button for 30 seconds while power on/boot after firmware upload. didn't seem to help.
  2. centyx

    centyx LI Guru Member

    Finally I got it working. I think my problem was that I wasn't setting the transfer mode to binary in tftp.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice