Debricking an AMD wrt54g?

Discussion in 'Cisco/Linksys Wireless Routers' started by mock1010, Jul 11, 2005.

  1. mock1010

    mock1010 Network Guru Member

    Well, I've managed to brick my router with the sveasoft alchemy 1.0 =(
    I managed to bring it back from the dead once by using tftp during the short duration where the router would respond to pings.

    However, the second time I was not so lucky. It's the same story on the surface: the router responds to pings for about 10 seconds (each ping taking longer and longer) and then it stops responding.
    I can tftp up a new version of the code, but the web interface won't respond, even after a hard reset.

    I've read the debricking guide, but it talks about an intel flash. Mine's got an AMD29LV320D8.

    The spec at
    says pin 15 is RY/BY# and pin16 is A18.
    Are these the right pins to be shorting? I tried it once and it didn't seem to do anything...
  2. mock1010

    mock1010 Network Guru Member

    Well I found some more info
    and gave that a whirl, grounding pin16 to xtal1.
    As soon as it started responding to pings, I tried using the linksys utility to upload a good firmware.
    It accepted the upload, then the red light started flashing. It stopped responding to pings.
    There's no response to http requests... Exactly the same as what happened when I tried to reflash it previously using the reset switch.
  3. miloman

    miloman Network Guru Member

    had same result first time I tried the Alchemy firmware :cry:

    My fix was... command promt set up an ping to the router useing the -t command, short pin 15 and 16 (mine is an intel flash) with the power on and pings came, upload a small firmware (linksys) under 3 mb with the tftp command. If shorting pin 15 and 16 does not work connect pin 16 to the antenna base and use the tftp command again...

    that worked for me

    best of luck to you :?
  4. mock1010

    mock1010 Network Guru Member

    I've tried both those methods, but they haven't worked.
    I just don't see how pulling an address line to ground would have any effect on the flash memory whatsoever...
  5. pcsel

    pcsel Guest

    I have had a bricked WRT54G with the AMD flash in it laying around for a while. I tried grounding pin 16 which is address line A18 (see here Page 7. Not to the XTAL1 can though as this isn't at gnd !! I don't see the point of grounding A18.

    I have also reset the flash by grounding pin 12 which is the flash RESET#. Still no joy.

    I can get the ping to work with VERY erratic TTL's varying from <1ms to 700-800ms after I reset it. Power cycling loses this though.

    The power LED changes it's flash from fast after the reset to four fast flashes and on and then repeats. I can install the firmware but cannot get to the admin screen via http. If I power off it goes back to a fast flashing LED on power on and I cannot connect to the unit again on the default IP.

    Anyone any ideas?
  6. step-hen

    step-hen Network Guru Member

    try to connect using an additional hub or switch to avoid the need for resync on the ethernet port
    did you try to keep reset pressed while powering on for 30 seconds?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice