debricking Netgear WNR3500L

Discussion in 'Tomato Firmware' started by humba, Apr 7, 2010.

  1. humba

    humba Network Guru Member

    I figured I wouldn't cluttert the N mod thread with this... I noticed that while getting a decent enough wireless signal, the connection rate was always way below 300mbit.. mostly even lower than on my WRT54GL with high gain antennas (no change in trx power). So after a wireless survey, I wanted to see how the WRT54GL (still using Tomato 1.11 with the VPN mod) would do using the same wireless firmware as the N mod. Flashing the VPN beta 10 failed because it was too big, so I figured I'd give the original VPN mod, ND edition a try. Switched to the productive net, downloaded the file, forgot to switch back to the test net, and flashed the wrong router which now of course refuses to boot.

    So, long story short, the WRN3500L is brocked, and I don't have a JTAG or USB recovery cable. So I assigned a fixed IP to my computer, started a perpetual ping (ping -t, started the router, and upon getting an answer, try to push the original firmware to the router (tftp -i originalfirmware.chk). According to the threads at myopenrouter, it seems to be timing dependant, butI haven't found the proper timing. Some suggest opening the router and shorting two pins, but I'd rather not void the warranty (I can always argue my way round having an alternative firmware on the router.. usually they swap out anything that doesn't boot anyways), and I got the router from a mail order company so sending back would cost money - so.. has anyone successfully recovered a WNR3500L using the tftp method, and if so, can you tell me precisely what you did, down to the timing.
  2. Porter

    Porter LI Guru Member

    I've once successfully debricked a WRT54-GL who wouldn't let me reset its password.

    From my experience I can tell you that it's very time sensitive. It took me around ten tries to flash the firmware.

    I would advise you to not wait for a successful ping. Just put the tftp-command in a cmd-box (don't hit enter yet), power on the router and immediately after that hit enter. You will have to try to experiment because the timeslot is very small.

    Good luck!
  3. humba

    humba Network Guru Member

    I've tried maybe 30 times.. but no luck. One would hope manufacturers would come up with a more reliable way that doesn't rely on pure chance. I've now opened a case with Netgear.
  4. gingernut

    gingernut LI Guru Member

    Try holding down the reset button on boot. Some other Netgear units go into recovery mode this way.
  5. humba

    humba Network Guru Member

    Unfortunately, the WNR3500L doesn't act like that.
    I can't help but feel a router they tout to try alternative firmwares should have a tried and tested recovery mode that doesn't require you to open the device and void your warranty.

    And since Netgear's case system is broken I can't ask them either.
  6. bogderpirat

    bogderpirat Network Guru Member

    i made a nice discovery trying to unbrick the first wnr3500l i had some time ago.
    i'd bricked it by flashing over a falsely compiled firmware image and it wouldn't boot. i wouldn't get a ping back either, so i figured the only thing left to do was open up the box and see if i could get my hands on a jtag cable somewhere, but as i opened the box, i found that where there should have been pins for a serial console, there were none in my device. the wnr really doesn't have what i'm used to from my wrt54gl in terms of recovery options.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice