Dell laptop Vista won't connect to BEFW11S4

Discussion in 'Networking Issues' started by nath1977, Jun 11, 2008.

  1. nath1977

    nath1977 Guest

    Hi all,

    Im new here so be nice!

    As per the title Im having trouble with a Dell laptop running Vista... It won't connect to BEFW11S4 router :-(

    I've tried resetting factory defaults on the router, tried with no WEP etc etc.

    Basically it doesn't connect with the internal 1395 wireless card. When I use an external USB adaptor it works fine. The internal card driver has been updated with t latest from Dell's site.

    Is this a known issue with this old router. Its a version '3' and the Linksys Firmware is for a version '4' only. Can I risk the upgrade to see if it solves the issue?

    Any help appreciated, thanks.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice