Device list keeps growing Help!

Discussion in 'Tomato Firmware' started by siimo, Jun 5, 2007.

  1. siimo

    siimo LI Guru Member

    Hi I am using latest Tomato 1.07 on WRT54GL.

    I think all the network connections that my network computers are making are showing up on the device list!! all with the same MAC address but different (Real world) IP addresses.

    This wasn't happening when I had double NAT, but then I turned off my ADSL modem's NAT and now all the IP addresses I connect to started showing up as devices... and make firefox crash as theres 100's of them. :(

    WAN Connection is set as DHCP which is connected to a basic D-Link ADSL modem/router called DSL-302G. I have turned off the NAT on it (I think it means it is in the HALF-Bridging mode as i have PPPoA). The IP showing up on Tomato summary page is my WAN IP.

    How do i solve this?
  2. mstombs

    mstombs Network Guru Member

    I guess this is the result of D-Links method of half-bridge called zipb.

    The problem is caused by the way they 'spoof' the WAN gateway - make it equal to the IP address. Does the router get the real ISP Gateway address?

    The effect of this is that the router thinks the internet is local and it 'arps' for everything - the modem 'spoofs' arp replies to direct all traffic to it. The router tracks all the IP/modem MAC address combos in its arp table which was not designed to do this!

    What you may also not like is that the DSL320T I have looked at also still runs NAT so still tracks all your connections and suffers the same P2P problems as before. So you may as well run with double NAT and no WAN IP on the router?

    Further analysis/ solution without replacing the modem firmware is offered by

    You may also see one or two posts of mine on the subject, here and elsewhere!

    If you can confirm the diagnosis above I think the router arp problem in Tomato can be removed by a variant of the Hyperwrt firewall script I have posted here before, fixing the gateway to be the modem IP address.
  3. Talon88

    Talon88 LI Guru Member


    Just use the ADSL Modem Bridge mode &
    use the router to do the PPPoE.

    At [Basic|Network|DHCP Server|Lease Time], set it to 60Mins.
    Then it will remove the Computer at the "device list" every hour
    if the computer is not in use!

  4. BobOki

    BobOki Network Guru Member

    I would like to see support for the Netgear WNR834B series. Its a compact Wireless-N, and other firmwares already support it, and actually quote it as a recommended model over all the other linksys/buffalo/etcetc models.
  5. mstombs

    mstombs Network Guru Member

    If you can you should - but some of us have ISPs with PPPOA only!
  6. siimo

    siimo LI Guru Member

    Hi I can confirm that it is the router arp problem you are talking about. Could you please point me the the Hyperwrt script and how to use it? I am a total newbie at this as this is the first time i am running a nonstandard firmware and now very familiar with linux networking.

  7. mstombs

    mstombs Network Guru Member

    I posted the solution to my pppoa half-bridge problem in here:-

    That it seems to work in Tomato was found here:-

    Your problem is not the same but similar root cause (half bridge modem). I think the following should fix the arp problem, by changing the gateway to that of your modem, as in the external link I gave before

    You can test by copying and pasting the commands into a telnet/ssh session and if they work paste into the "firewall script" through the web interface, which runs every time the WAN IP changes.

    NB Change the IP address in the first line to the LAN side IP address of your modem.

    This deletes the current default route, tells the router where to find the modem, then sets the modem as the new default route.

    Note the first "route del" may give warning messages if the route doesn't exist, but having more than one default route would break internet access!

    route del default gw $(nvram get wan_gateway)
    route add -host $MODEMLANIP dev vlan1
    route add default gw $MODEMLANIP
    if it doesn't work please post the output of the "route" command. The router arp table should now slowly reduce to a single entry of the modem on its WAN side, and you will divert your attention to the modem - are you sure your ISP doesn't work with PPPOE?
  8. siimo

    siimo LI Guru Member

    Thanks a lot for the quick reply. I am at work right now but I will give this a go as soon as I get home.

    Yes I am sure ISP doesn't support PPPoE infact my whole countrys ADSL network doesn't support it! I live in New Zealand. The whole phone network is owned by Telecom and resold to other ISPs so its all the same.

    I forgot to mention earlier, right now the gateway on the router seems to be the same IP address as my external WAN IP address. So the IP address AND gateway are seen as the same.

    Thank you once again. I will report the result when I get home.
  9. siimo

    siimo LI Guru Member

    Thanks mstombs, you are an absolute genius. It worked perfectly. All those sodding external IPs have now disappeared ! :D

    Just one thing though. I tried disabling my WAN (by hitting the Release button on the status window) and enabled it again and these bloody IP addresses started coming back in the device list. So do i need to put this script in the WAN UP tab of the scripts as well?

    Thanks again!! I was considering doing a double NAT again but my modem is so slow it would make it a pain.
  10. mstombs

    mstombs Network Guru Member

    That explains why I have found many links to NZ users with problems with half-bridge, my ISP is PPPOA only in UK.

    This is how D-Link Zipb and broadcom "IP extension" do the half bridge. It seems to be universally accepted by PCs/routers (at expense of arp problem), the out of range gateway method doesn't - but we can patch it! When zipb (patent applied for) was invented I don't think P2P apps were thought of so the arp management problem caused by accessing 100s of external addresses at the same time was not considered.

    Please experiment, Hyperwrt Thibor doesn't have the WAN-UP script, and I have seen a problem caused by making a GUI change and the old gateway slipping back. May be better to move the script to wanup, the only problem I see of doing it in both is warning messages.

    You're welcome!

    When the router table is not full I am not sure it will make much difference to speed.

    As i mentioned above your modem may still be doing NAT, if you can get into it with telnet/ssh, have a look for "MASQUERADE" in the output of

    iptables -L -vn
    iptables -L -vn -t nat

    One more thing - check the DNS servers your router is getting from the modem, the zipb modem firmware I looked at only bothered to pass one ISP DNS server to the router and I can see same bug in the "IP extension" GPL code. This can have a big effect on your web performance!
  11. siimo

    siimo LI Guru Member


    I am only able to telnet into the d-link modem. So i am not sure how to run those iptables commands.

    I followed the instructions here to turn the half-bridging mode on and have also managed to change the modem's lease from 60 seconds to 1 hour since i very rarely have ip changes. Only if i turn the modem off for 15+ minutes my IP changes.

    As for DNS I have already entered my ISPs DNS nameservers into Tomato.

    QoS is working great too :)

    Only one problem I've noticed so far is that my torrent client finds it hard to get connections. On a 1000+ seed torrent i will only have 5-10 connections and Tomato has too many connections on time wait etc waiting to time out. Port forwarding is working fine. I think its a WRT issue that Azureus wiki mentions here
  12. mstombs

    mstombs Network Guru Member

    OK modem telnet only gets you to a CLI, not a Linux prompt, but those instructions tell it to turn NAT off so it should.

    The P2P comments should not apply to Tomato - it has many improvements over the stock firmware.

    If port forwarding not working you usually get no incoming connections, I've not used Azureus for some time it slowed my PC down too much - uTorrent works better for me.

    There's an official torrent for the NERO CD writing demo software, that is usually well seeded/ tracked and can speed test your connection!
    just tested :

    388.1 kB/s (avg. 368.9 kB/s) complete 7m 37s with no incoming connections...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice