DHCP problem with dd-wrt v23

Discussion in 'DD-WRT Firmware' started by mexell, Feb 16, 2006.

  1. mexell

    mexell Network Guru Member

    Hello there,
    the day before yesterday I installed v23 generic on my wrt54gs.

    Everything worked fine; I started playing arund a bit and oops - my notebook doesn't get an IP anymore. Windows (XP Home) just states it's obtaining an IP but I can wait as long as 20 minutes and nothing happens. It seems like getting an IP fails and starts over and over again.

    The other machine (XP Pro) which is connected by cable doesn't have this problem.

    Maybe I should add that I misconfigured the MAC-filter once. When reconfiguring and applying the right settings, I didn't get the "settings applied successful"-screen. After that, the issue came up.
    I changed the settings via my wired machine but there's no difference.

    Greetings from Berlin
  2. __spc__

    __spc__ Network Guru Member

    Connect by CAT5 cable, check your MAC filter settings.

    I once got locked out as the MAC filter setting somehow changed itself...
  3. mexell

    mexell Network Guru Member

    I did exactly what you proposed some time before. But it seemed to change nothing.
    Then I resetted the device to factory defaults. It worked again, but only until I changed the SSID and the channel. The I got factory defaults again and didn't touch the channel setting and the SSID. Now it seems to work, bets are open how long and until which configuration change...

    I think probably I'll downgrade to v22 again.
  4. XeviouS

    XeviouS Network Guru Member

    Ensure that the 'Routing and Remote Access' service is not disabled on your XP Wireless Machine.

    Set your DHCP lease time to something higher than the default 10 mins....such as 720 mins (12 Hours)
  5. mexell

    mexell Network Guru Member

    Everything worked just fine before I upgraded from v22 to v23.

    What made me wonder was the fact that the "DHCP lockouts" happen somehow randomly after changing of settings which don't have anything to do with DHCP, like MAC blocking or SSID/channel changes. (means: I stopped playing around with the settings once I had a stable setup. Thats a bit sad :thumbdown: )

    Greetings from Berlin
  6. west55

    west55 Network Guru Member

    Same problem here. Some times I cant access, cant get IP from DHCP, need reboot router. Can anyone fix this problem ?
  7. eshapurov

    eshapurov Network Guru Member

    This is a known problem with v23 final. You should use SP1 (I use fro m 03-Feb) and the problem is solved there. QoS is also working ok.
  8. t4thfavor

    t4thfavor Network Guru Member

    where can i get the newest release (SP1) the only one on the site is from christmas....

  9. THILE

    THILE Network Guru Member

  10. t4thfavor

    t4thfavor Network Guru Member

    thanks to all I did notice that this doesnt happen to my wrt54gv2 just my wrt54gsv4
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice