DHCP Renew

Discussion in 'HyperWRT Firmware' started by pitch78, Apr 24, 2006.

  1. pitch78

    pitch78 Network Guru Member

    i've a WRT54G V2.0 and i have a problem since i used tofu (v11 and more) and then thibor release (v14).
    (perhaps just a coincidence due to official firmware changes) i'm in Automatic Configuration - DHCP.
    in a first time (from november to february (i'm not sure)) sometimes, the WRT54G wasn't able to renew DHCP. (every 2 to 10 days) then if i checked process : udhcpc and cron didn't run.
    the only way to have my new IP (it change at least every 24h) was to reboot my WRT54G (so it isn't a problem with my modem because with no change on my modem configuration, it works) and i've used my modem and my router in this configuration for over 1.5 year without problems. since february, when i have the problem, udhcpc and cron still run.
    But if i try to manually release and the renew DHCP it still doesn't work !
    one clue perhaps :
    Remaining Lease Time stay at 0 days, 00:00:00.

    One more time the only way to have my new IP is to reboot my WRT54G Please help, i have asked several times and noone seems to know.

    And to answer thibor that still have answer me (thk for attention) it could be my modem, i have waiting for a long time testting my modem or hope next release will repair my problem "naturally" via an official firmware change for example...
    but nothing append.

    that's why i ask one more time help because it is very boring that my connection isn't available only due to my WRT54G (that i love since the begining and more since i have tofu/thibor release that allow me to run Kaid)...

    So Please, anyone help, i really don't know what to do...

    ps: sorry for my english, i hope you will understand me anyway
  2. Thibor

    Thibor Super Moderator Staff Member Member

    i can't see a release fixing your problem, since it is not reproducable here. the issue is not being reported by anybody else so it is more than likely an issue local to yourself, maybe your modem, or maybe your router needs the nvram erasing and reconfiguring. if udhcpc is still running, but it can't acquire a lease; the problem is likely to be with the server than the client, so look carefully at your modem. in the past, i had a modem that would barf out after 48 hours and stop passing the public ip to my wrt. throwing it in the bin and getting another modem cured my fault
  3. pitch78

    pitch78 Network Guru Member

    first of all thank you for attention and response (and obviously your work and firmware)

    "if udhcpc is still running, but it can't acquire a lease; the problem is likely to be with the server than the client, so look carefully at your modem"

    the problem is that if i just reboot my routeur it works...

    i'll try to erase nvram again, hard reboot the router and clean everything i can on my router (don't run kaid,...)
    i will post result here...
  4. Hungyip

    Hungyip Network Guru Member

    I have this problem too during these weeks. Let me know if you fixed it! Thanks!
  5. rotor

    rotor Network Guru Member

  6. pitch78

    pitch78 Network Guru Member

    10 days ok

    ok, it seems to be all right.
    erase nvram + factory default + no startup script (kaid)
    10 days from it and everything is still all right.
    i upgrade to thibor 15 and hope it's really the end of my problem.
    in 10 /15 days i will put kaid back in my startup script and then 10/ 15 days later tell you if it's still ok.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice