dhcp woes with wrt54g

Discussion in 'Cisco/Linksys Wireless Routers' started by jasonl, Jun 2, 2005.

  1. jasonl

    jasonl Network Guru Member

    help! ive got some dhcp issues with my WRT54G-V1 - router is set as DHCP server, my desktop and my laptop (both hardwired) can easily acquire IP addresses from the router, but the laptop -which is a centrino- cant get an IP address on the wireless NIC

    internet connection is not a problem when they're hardwired but the wireless NIC on the centrino just couldnt get IPs....drivers are all updated, tried both win2000 and winxp pro (had to re-install xp pro just to check), all updated service packs, all settings "looks" alright, etc ...even if i set everything manually, i couldnt even ping the router.....now the dilemma, the wireless network connection status shows that the laptop and router sees each other properly, 100% signal strength at full speed (well), but no ping

    can you guys tell me what i missed, i hope its all just settings and/or driver issues (stupidity on my part).....pls dont tell me ive got a bricked wrt

    anyway, everything was working alright using the stock (read: old) linksys FW, i upgraded to hyper2.1 then it starts to play up....upgrade to kaistation FW same prob...ive got a UK WRT54G-V1 router connected to ADSL2MUE in bridge mode

    thanks a lot, sorry for the long post
  2. howardp6

    howardp6 Network Guru Member

    Do you have an Intel Proset 2200bg wireless NIC in your Centrino Laptop. Are you using the Intel WLAN Monitor My daughters Dell 600 has an Intel Proset 2200bg wireless NIC. I removed the Intel client and used WZC service. It was able to connect using WEP or WPA-PSK TKIP. The Intel client worked also, but only with WEP. I had to set the Intel Client to hexadecimal keys, since Linksys only uses hexadecimal keys. Do not use the paraphase key generator since the Linksys router and the Intel Clinet generate different keys. WPA-PSK TKIP is only supported with the wireless NIC. The Linksys WRT54G can uses keys from 8 to 64 characters. The Intel Client will only accept full length keys.
  3. jasonl

    jasonl Network Guru Member

    thanks for the reply howard

    mine has the intel pro 2100 3b wireless mini pci NIC, im using the intel wlan monitor when on win2k and the windows' wireless network status monitor when on winxp...im using hexadecimal keys instead of the passphrase

    still no luck
  4. c1623

    c1623 Network Guru Member

    Wireless not getting DHCP IP

    Have you tried this with no security switched on for the wireless so no WEP or WAP? Just to prove you can actually get a connection and an IP?
  5. jasonl

    jasonl Network Guru Member


    yeah ive tried that, first time it was able to get an IP but could not ping even the dhcp server, then afterwards couldnt get an ip anymore

    just to add, when i was able to get that IP and tried to ping, i got "hardware error" message as a reply

    im quite sure there is connection between them as i can see on my network monitors they're fully associated and "verified" this by turning the wlan (on the laptop) on and off just to see if the monitor see the changes, and it does.

  6. jasonl

    jasonl Network Guru Member


    i uploaded Alchemy V1.0 to the wrt54g in the hope of fixing that dhcp glitch, now i cant ping the damn thing even on ethernet connection

    my ethernet connection is set manually, and i cant ping the router. does the router always have as default ip add regardless of the firmware version installed?

    any way i could get around this without going to the "shorting pins" method?

    the Link/Act and Act LEDs are flashing regularly even if im not doing anything
  7. jasonl

    jasonl Network Guru Member

    ive tried hard resetting the router many times and i still cant ping the router properly, however during its reboot i can get a ping reply for about 6 hops with the response times gradually increasing every hop until i get "request time out" reply

    anyone got any ideas?

    im very near to shorting the pins already.....aargh

  8. jasonl

    jasonl Network Guru Member


    after numerous hard reset, was able to get the router going again but im back to my old problem which is the topic at the start of this thread. i couldnt get an ip address from the router on the wireless side although i can acquire ip addresses on the ethernet side

    BUT if i disable wireless security(WEP), i can get an ip very easily

    any of you guys have any ideas how to overcome this? at the moment im using kaistation firmware

    btw how secure is mac address filtering? its my only form of protection at the moment since im haivng problems when WEP is enabled

  9. bluedog

    bluedog Network Guru Member

    Not very... Your mac address is sent in clear text with the packets when your machine talks to your ap...

    Anyone looking at the packets will pickup the mac address instantly.

    It is better than nothing though..
  10. jasonl

    jasonl Network Guru Member

    thanks bluedog, glad you cleared that one up

    anyway, evrything's alright now....thank goodness!
  11. c1623

    c1623 Network Guru Member

    DHCP on Wireless

    Hi JasonL
    Not sure if you have said if everything is now working but something I learned with the WEP side of things.
    I am sure you know that on the Linksys you select a key and it generates 5 crypted keys you then select which one to use.
    I have found that on the other wireless device using the same key doesn't always generate the same crypt key or sometimes when they ask for the key they don't want you the one you typed on the Linksys they want the one it generated. The fact that it workes with WEP off points to this king of issue. Hope you have got it all working.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice