Did 2.0b4 solve P2P (bittorrent, ...) problems?

Discussion in 'HyperWRT Firmware' started by Avenger20, Jan 22, 2005.


Did 2.0b4 solve P2P (bittorrent, ...) problems?

  1. Yes, it works much better now!

  2. Don't see any difference

    0 vote(s)
  3. No, it was better in 2.0b3

    0 vote(s)
  4. No, have the same problem with any firmware

    0 vote(s)
Thread Status:
Not open for further replies.
  1. Avenger20

    Avenger20 Network Guru Member

    A little poll to see if the p2p patch in 2.0b4 did any good.

    If you are having problems with the new patch, please include the following :

    - Router and hardware revision
    - What the exact problem is (if it crashes, just goes slow, ...) and when you noticed it.
    - If you had the same problem with 2.0b3
  2. Partizan

    Partizan Network Guru Member

    1. WRT54G v2.2 (brand new)

    2. Between 1 hour and max. 4 hours I lose the internet connection. Have to shutdown torrent client, and unplug the router.

    3. Didn't try 2.0b3, because I got it with official 3.03.1 firmware, then tried HyperWRT 2.0b4, and then Alchemy 6.0rc5.0a

    Will do more testing

    Regards, Partizan
  3. hktony

    hktony Network Guru Member

    1. WRT54G v2.2
    2. it works fine for me, but i have set the packet size in the preference of BT client into 4096. If this is changed to "Auto", then the router would hang frequently.
    Here is the sympton, first , the power led flashes and it looks llike to reboot itself. After few time of power led flashing, the router hang, and so need to replug the ac power at the back of the router .

    3. i have never tried firmware 2.0b3, and update it from the official 3.03.1.
  4. cat101

    cat101 Network Guru Member

    1. WRT54G v2.2

    2. Let Shareaza running lastnight, this morning I could not even access the router's admin page. Still, all the lights behaved like if everything was ok. I could see the ethernet and WAN ports blinking.

    3. 2.0b4 is the first version I have used

    Good luck

  5. Hypnotik

    Hypnotik Network Guru Member

    I have the same problem with P2P & BT clients.

    But I don't know if it is really the router...(in my example)

    When i am disconnected from Internet, i must unplug the modem (sagem fast 908 eth) and replug it.

    It can't reconnect himself because the router says "Cannot get IP Address from PPPOE Server"...

    Strange ? anybody have this prob ?
  6. Toxic

    Toxic Administrator Staff Member

    the problem really lies with BT opening too many connections. WRT's and most routers are not built for heavy bandwidth useage. i suggest if possible though to restrict the QOS by at least 20% therefore making QOS max upload of 80% of totaly bandwidth, this may help. dont use any more than 80% you will choke the router.
  7. Avenger20

    Avenger20 Network Guru Member

    Indeed, though this patch should help a bit, but the weakest link will break everything (like the modem or your isp, that could limit the concurrent connections). The best way is to limit the connections in your p2p client.
  8. Toxic

    Toxic Administrator Staff Member

    unfortunately everyone just blames the router. start contacting BT authors and see what they will do.
  9. flexy

    flexy Network Guru Member

    every halfway decent bt client (abc, azureus ?) has the option to limit up/down bandwidth and number of simultaneos connections.

    However, couldnt test new firmware yet since i dont download that much actually :)
  10. Aaron76

    Aaron76 Network Guru Member

    Never had a problem.

    I have a WRT54GS 1.0. Never had a problem with stock firmware or Hyperwrt 2.0b4. I forward my ports (not default ports) for Azureus and eMule, have QOS setup so the kids can still use their connection while I'm hammering the bandwidth, always have a fresh install of windows in a Norton Ghost image file so if I screw anything up, it only takes 2 minutes to restore everything. Don't have Service Pack 2 yet because I couldn't install my sound card driver with it installed.

    1.) People should check to make sure ports are forwarded through router.
    2.) Software Firewall isn't blocking connections to peers.
    3.) UPNP through Azureus is finicky (works sometimes) with my router so I turn off UPNP in Azureus and forward ports maually in router.
    4.) Overlooked: SP2 has a limitation of 10 half-open connections at the same time. This serverly inhibits any P2P program. Patch this one for sure.
    5.) Don't change settings in P2P programs you don't understand. Reinstalling the program doesn't usually help with screwed up settings because the registry keeps these settings for you even if you uninstall the program first.

    I don't think this is a firmware problem, but I could be wrong. Most of the time when I find the solution to one of my problems, it seems like it should have been obvious. Sometimes it helps to doublecheck everything even though you have done so already. Don't randomly change things without keeping track of what you did or it could hurt more then help. Change only one thing at a time and test that. Anyways. . . My 2 cents.

    Keep up the good work with the firmware.
  11. pharma

    pharma Network Guru Member

    Re: Never had a problem.

    For people who want to increase the connection limit to whatever value they want, below is a link to some freeware software that will make the change for you. When you have the software go 'Special' --> 'Connection limit' --> 'Yes, I got it' --> then set your value. This is complete reversable, but the author posts a warning:

    "The connection limit wasn't established by Microsoft without a reason. It should prevent rapid spreading of viruses and worms if a computer gets infected. That's why they limited it to 10 connections at a time... Some applications, like, for example, filesharing tools, can't unfold their capacity when the maximum connection limit is too low. Please don't raise the connection limit if you don't really need it. Look into the event viewer (start->run 'Eventvwr.msc'->system). When you see entries with the event ID 4226, the system is telling you that the connection limit has been reached."


  12. zaphod

    zaphod Network Guru Member

    hi avenger,

    flashed back to hyperwrt 1.4 and its better... think the values werent correct..
  13. Jumbo

    Jumbo Network Guru Member

    1. WRT54GS v1.0

    2. lose the link on WiFi part. Have to reboot router.

    3. No problem in 2.0b3 with increase of NAT table to 4096.
  14. Hypnotik

    Hypnotik Network Guru Member

    > to pharma (and all people who read this post for sure) :wink:

    in my event log i have some errors like IPNATHLP (ID:32003)
    =>> maybe generated by the router ?

    do you know more about this error ? is it why i'm (we are) disconnected from internet when p2p or BT programs are used ? :?

    Thx for your Answers
  15. pharma

    pharma Network Guru Member

    I think people here are still trying to determine the cause for the disconnects some people get, though not all are affected.

    I believe your error is not related ... google will turn-up some useful info on your problem.

    This is one solution that worked for someone with your problem:


    Hope this helps.
  16. elguaxo

    elguaxo Network Guru Member

    I have a WRT54GS.

    Before having the router I connected my computer directly to my ADSL Modem. I never had problems with P2P apps, I use only Emule Plus (eDonkey network) and Azureus (bittorrent). So I can say I have no problems with the programs, the OS, my NIC or ADSL Modem.

    When I began using the router I had the first P2P problems after a few days. The router came with the firmware 2.07.1. I upgraded to hyperwrt 1.4 but nothing changes. Now I am running 2.0b4 and after a week of heavy use it still runs fine, which is an improvement!
  17. Hypnotik

    Hypnotik Network Guru Member

    thx pharma for your answer i try this tonight!
  18. Hypnotik

    Hypnotik Network Guru Member

    i have tried manipulations you indicates me

    But disconnections are still there when i'm using P2P or BT program...

    I precise one thing, when i'm disconnected, my modem can't reconnect by himself! (error msg : Cannot Get IP Address from PPPOE Server)

    thx for all pharma
  19. Hypnotik

    Hypnotik Network Guru Member

    anybody using BitComet to DL some torrents ?

    if yes, is it possible to have optimized settings for WRT54G :p

    thx people
  20. Hypnotik

    Hypnotik Network Guru Member

    nobody ?

    who have wrt54g+hyperwrt 2.04b+adsl modem and DL on P2P without any pb?

    if it is possible anybody can put the maximum connections value in this topic?
  21. Hypnotik

    Hypnotik Network Guru Member

    with 200/100 connections in emule and 10 connections every 5sec i still have disconnections!


    it make me sic!
Thread Status:
Not open for further replies.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice