Did I break something?!

Discussion in 'Cisco/Linksys Wireless Routers' started by SMR619, Jan 27, 2006.

  1. SMR619

    SMR619 Network Guru Member

    About 3 hours ago I read that WRT54G/GL/GS routers have firmware issues and it was best to update them with HyperWRT2.1b1 tofu12, or DD-WRT v23 beta 2, or HyperWRT2.1b1 Thibor
    I 'had' the WRT54G V2 with firmware 4.20.7 but went with installing the HyperWRT2.1b1 tofu12
    Little did I know that my current firmware was not compatable, so I was told, and things did not seem right.I lost connection to the net and could not figure out what the deal was.
    So I then reset default settings in the router, still no net.
    I rebooted PC and router, no go.
    So I figured I would just reinstall the 4.20.7 firmware.So i did and still nothing.After looking around, I see that my IP is not but changed to
    How this happened I have no idea but bottom line is, I am not hooked to my router right now, if hooked up I get different IP and I cant get into my router settings panel to change anything let alone reinstall 4.20.7 firmware.

    My question is, what do I do so I can use my router again?
    My kids are gonna kill me if they cant use their PC in the room if I cant get my router working again.

    If I type in in the address bar ( whenI hook up router ) I get nothing.Never get asked for password or anything.I cant get in!
    I tried typing in to see if that would do it and nothing.
    When I hook up the router, windows looks for IP and sets it to..... but I still cant get online.So long as the router is hooked up, I cant connect to the net.So right now just unhooked it.
    Please help.I hate to have to toss a fairly new router because I screwed up :cry:
  2. jgutz20

    jgutz20 Network Guru Member

    basically if you get the 169.X.X.X address your comp isnt finding a DHCP server, your router probably got interrupted during theflash process or you tried flashing with an invorrect firmware. you could try setting yout ip statically with as DNS and Gateway.

    Otherwise look around about recovering from a bricked router, it might be just as simple as holding the reset button for more than 30 seconds depending on what happened with the flash.

  3. SMR619

    SMR619 Network Guru Member

    I tried the reset button, but no go.
    Im not all that computor savey so whatever is needed to get this right, I will need some instruction.I just want my router back is all and get things back to normal.
    Im also wondering if I can use an older firmware version, like maybe in the 3 series so I dont have to worry about the problem where they (the routers ) track old connections for FIVE days, which causes the router to hang.

    If anyone can help..... :sadbye:

    Quick edit:
    After looking around, it seems my router IP cant be found by windows and is instead giving me that long ugly one of
    I tried manually setting it to but it still isnt doing it.
    I do remember that when in my setup ( when I saw it last ) it was actually reading so I tried that as well and nothing.
    I somehow really messed this thing up and hope I can get it back in working condition.
  4. Cenreyn79

    Cenreyn79 Network Guru Member

    try this. go to your kids computers and use the Command Module (cmd, under "Run") and type in 'ipconfig /all". copy the DNS 1 and 2 and 3 if its available and the DNS suffix. then go back to your router (if you can get in and key these in). Save the settings if possible then use IE6, under "Tools" => "Options" => "Connections (tab)" => LAN Settings and click and reclick the "Automatically detect proxy..." so that it is checked. now try to go to a website. it should work

    always has for me and ive had to reflash my router maybe 20 times in the last month due to the same situation(s).
  5. SMR619

    SMR619 Network Guru Member

    Here is where I am stuck.The IP to the router has somehow changed and I cant get in.So typing in in my address bar I get nowhere.With my router hooked up, I cant get online, not into the Linksys menu to do anything.If I can just get in there I think I can figure out what I need to do.But I cant even get in.
    Somehow when I hook the router up and windows goes to hook it up by giving it an IP, it gives it that long one I posted instead of
    I even tried the firmware exe and it said it could not find the router.
    Even if I manually input in TCP/IP properties with sub and as gateway I cant get my router to work.I think I may have changed something in the settings before all this went to hell.
    I remember seeing in the setup page under local IP address so maybe that messed things up?

    Is there not a tool to reset all this stuff?
    Why is windows giving it a wierd IP? Can it not see it and see the IP is does have even if different?
  6. howardp6

    howardp6 Network Guru Member

    The IP address of is the default address of a NIC in Windows, when an IP Address is not defined. On you router press the reset button for at least 30 seconds to reset the router to factory default settings. Connect your router to a wired NIC. Start the computer. Go to settings or Control Panel and select Network Connections. Right click on the wired NIC and select properties and manually configure the TCP/IP to not, with a subnet mask of and a gateway address of and click the "OK" control button. Start your browser type in and you should be prompted for a password. Do not select detect proxy on LAN settings, since you do not have a proxy server.
  7. SMR619

    SMR619 Network Guru Member

    :cheer: :cheer: :cheer:

    I did not follow the above instructions, but I did get it all sorted out.
    I got hold of Linksys last night and was taken through steps to reset everything.I didnt dare mension installing 3rd party firmware, just that a firmware upgrade went bad.

    So now all is good but still back to my original issue of a slow router on the torrent side of things.This is why I installed the HYPERwrt firmware in the first place, but now being told that it was not supported with the current version I had which is 4.20.7
    I get a lot of things from archive.org and this new 4 series firmware is not so good I hear with any type of high transfer.

    So, should I risk once again to get a better firmware, or just deal with it?

    At any rate, thanks much for the help.I thought I had a paper wieght on my hands :shock:
  8. arturas

    arturas Guest

    I think I have a very similar problem. I installed DD-WRT v22 firmware on my router (wrt54gl). It stopped responding. I am not able to log in to it via web interface. Now, whenever the router is on, the power led is flashing constantly.

    I tried to reset it by holding the reset button for 30 seconds, however nothing happend. I set up the IP of my computer to as suggested, and tried to log in to However I could not connect to the router.

    How can I reset the router to the factory settings? I'd really appreciate for the help.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice