Difficulty flashing RT-N66U.

Discussion in 'Tomato Firmware' started by Lorenceo, Aug 13, 2013.

  1. Lorenceo

    Lorenceo Networkin' Nut Member

    I've recently purchased an Asus RT-N66U to replace my RT-N16 which has been spontaneously rebooting for a while.
    Unfortunately I'm having difficulty flashing the N66U to TomatoUSB based firmware.
    I have tried the following versions, all flashing through the Asus recovery tool:
    tomato-K26USB-1.28.RT-N5x-MIPSR2-108-AIO-64K (Shibby)

    None of these builds work. After flashing and clearing NVRAM the router gets stuck in a reboot loop.

    The following builds seem to work:
    tomato-K26USB-1.28.RT-N5x-MIPSR2-112-AIO-64K (Shibby)

    RT-N66U_3.0.0.4_372.31_0 (Asuswrt-Merlin) (I initially flashed this from the web UI on the stock firmware, and haven't tried it via the recovery tool. Edit: Does not work via recovery tool. Gets stuck in reboot loop like the others.)

    I would like to use a Toastman 1.28.0501.3 build since it is what I have been using for a while, and is a build in which IPv6 works.
    Any help with this would be appreciated. I'd be ok using a Shibby build also, but as with the most recent Toastman builds IPv6 does not work with Shibby.

    My ISP requires VLAN tagged 1492 MTU PPPoE to authenticate and obtain an IPv4 address, and DHCP-PD for IPv6 with a /48 prefix.
    On the Shibby 112 build the router could obtain its v6 prefix, and it did announce it to the LAN, however the MTU on the router advertisements was incorrect, and all clients report Destination net unreachable when attempting to connect to any v6 hosts.

    Edit: The hardware revision of the unit is B1, and the bootloader version is It came with firmware

    Last edited: Aug 13, 2013
  2. shibby20

    shibby20 Network Guru Member

    you have newer revision od RT-N66u with new flash chip.

    changelog of my tomato:
    in v111 you can read "Add support for newer flash chips in latest RT-N66U hardware revision – thx RMerlin and Victek"

    well you have to use my tomato v111 or newer. Victek also add support for new RT-N66u revision. I do know about Toastman.
  3. Lorenceo

    Lorenceo Networkin' Nut Member

    I see.
    Thanks for that. It's a shame IPv6 doesn't work on the newer versions of TomatoUSB yet :(
    It worked on both yours and Toastman's prior to removing radvd, however it didn't announce the correct MTU or prefix.
  4. Toastman

    Toastman Super Moderator Staff Member Member

    Shibby, I haven't added the RT-N66U code yet, been busy, but I will do so soon. Nice work from all concerned.

    Lorenceo, how are you using ipv6? I may possibly add the RT-N66u to the 0501.3 build so that you may use it.
  5. Lorenceo

    Lorenceo Networkin' Nut Member

    Hi Toastman. Thanks for your reply.
    I'm using the following settings to get IPv6 working on my N-16 using v1.28.7501.3. It isn't a perfect solution, but it is better than v6 not working at all.

    Network, basic:

    Network, IPv6:

    I have the following line stored in the NVRAM to announce the correct MTU, as without it radvd defaults to 1500 which breaks many v6 websites.
    nvram set FILE:/etc/radvd.conf="\\A4\\81~~p\\17\\16\\12interface br0\\0A{\\0A IgnoreIfMissing on;\\0A AdvSendAdvert on;\\0A AdvLinkMTU 1488;\\0A MaxRtrAdvInterval 60;\\0A AdvHomeAgentFlag off;\\0A AdvManagedFlag off;\\0A prefix ::/48 \\0A {\\0A  AdvOnLink on;\\0A  AdvAutonomous on;\\0A };\\0A RDNSS 2406:e000::100 {};\\0A };\\0A" 
    The following script runs at WAN up, and is also scheduled to repeat every 3 minutes:
    if top -b -n 1 | grep -v grep | grep radvd > /dev/null
    echo  radvd is running.
    echo  radvd is not running, starting.
    #start the process
    I have to run radvd manually via the script as if I enable it under Network, IPv6 it uses the default radvd.conf, which announces the incorrect MTU to the LAN.
    I have it repeating every three minutes as radvd will crash randomly, taking IPv6 connectivity with it.

    The values I enter under Network, IPv6 seem to be ignored by radvd. For example if I enter my ISP v6 DNS servers and prefix of /48, radvd will still announce a /64 without the DNS servers along with the incorrect MTU.

    A suggestion if you're going to look into this further, It would be very nice if an MTU field could be added under Network, IPv6, as long as radvd will accept the values entered here.

    For what it is worth, IPv6 seems to work properly on both Asuswrt-Merlin and the stock Asus firmware. Although even on these firmwares the incorrect prefix is announced.

    Thank you so much for your interest.

    Edit: I've been using the VLAN build of 1.28.7501.3, as my ISP requires all packets to be tagged as VLAN 10.
    The only reason I bought the N66U is that my N16 has been rebooting at random. I suspect there may be a bug in the firmware, that when the PID number exceeds a certain amount the router crashes.
    Last edited: Aug 14, 2013
  6. Lorenceo

    Lorenceo Networkin' Nut Member

    Any news on that new n66u 0501.3 build Toastman?
  7. Toastman

    Toastman Super Moderator Staff Member Member

    not yet...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice