disconnecting after "hibernate"

Discussion in 'Tomato Firmware' started by lengo lad, Mar 27, 2007.

  1. lengo lad

    lengo lad LI Guru Member

    disconnecting after "hibernate" [solved]

    I've been using Tomato since v1.04 (switched from dd-wrt). I'm presently using v1.05. I love it, almost . . . Here's my problem: after I hibernate (Win XPPro SP2), I struggle to reconnect to the internet (although I can communicate with the router just fine). The goofy thing is that sometimes it's not a problem, other times it is a problem but if it click like mad on a couple of bookmark shortcut icons (firefox 2.0) I can 'force' a connection, and yet other times nothing but restarting my computer will allow me to reconnect. This has been an issue since day one with Tomato. I reset NVRAM when I installed 1.04, again before installing 1.05, and again after installing 1.05. I have stock settings except for increased Tx power (60mW) and IP addresses assigned within DHCP. Am I the only one this happens to? Does anyone have a clue as to what my problem could be? I'd love to keep using Tomato, but my wife is getting frustrated . . . (and, I must admit, so am I). Thanks,

  2. luke-san

    luke-san LI Guru Member

    That is really weird and it must be really frustrating.
    No such issues on my end.

    If you can always connect to the router properly then it must be a sort of dns problem or timeout issue that is causing this.
    Try to check if you can ping a remote url by using it's ip address after hibernate.

    Can you also try to go back to the original Linksys firmware or the dd-wrt one to check if that really resolves the issue.

    Also check if you have the latest wireless nic drivers because I know some of them don't like the hibernate or standby mode.
  3. pharma

    pharma Network Guru Member

    I would first upgrade to Tomato 1.06 -- the problem might not occur. I don't think many firmware developers will go back to troubleshoot "old code" when an upgrade is available.

    Also check your wireless driver settings ... I think there might be some settings there related to Standby & Hybernate. You should first follow Luke-san's advice and see if there are newer wireless drivers available. You should also change any settings back to how they were with 1.04 so you can make an "apples to apples" comparison with 1.05. (if you want to stay with 1.05)

    If all else fails, you can always turn off the hybernate mode so your wife won't be bothered. It will give you more time to find a solution.

    Edit: Just wanted to add this problem never occured with my wireless connections using any Tomato versions. I'm currently using Tomato 1.06.
  4. lengo lad

    lengo lad LI Guru Member

    Thanks, luke-san and pharma--I was beginning to think this thread had been left for dead . . . :frown:

    I'll try v 1.06 (although I don't hold out much hope for it). I've been thinking about going back to original Linksys firmware just to test (I'm getting more comfortable with flashing firmwares by the day :wink: ). And maybe that would help get rid of some 'stray' dd-wrt settings . . . So I'll give those suggestions a try.

    One other quirk to my problem. I started up from hibernate this morning and was immediately able to connect with my e-mail client (Thunderbird, but my web browser was unresponsive (Firefox I clicked through the icons on the 'bookmark row'--and when I say clicked, it's like 50 to 60 times of rapidfire clicking--until one of them went from "Looking up . . . " to "Connecting to . . . " And this morning it worked; some mornings it doesn't and I'm forced to reboot my computer.

    Final details: I have two IBM T42 Thinkpads. One has Intel PRO/1000 MT LAN with Intel PRO/Wireless 2200BG while the second has Intel PRO/1000 MT LAN with IBM a/b/g I (based on the Atheros AR5001X+ chipset). The problem occurs with both machines and all devices . . .

    Well, I'll go flash some firmwares and report back. Thanks again,

  5. ifican

    ifican Network Guru Member

    As mentioned this could be a DNS issue, you state IP is ok so obviously its not that. Next time you try and have an issue try getting to ip via your web browser. If you get a web page then you know for sure its DNS related. If you do not then its something else. You could also try bringing up a command prompt and try ping via name. I.E. ping yahoo.com. If you get DNS resolution but no reply then its something else. Give those a try and let us know.
  6. fastpakr

    fastpakr Network Guru Member

    What 'stray dd-wrt settings' are you referring to? If you didn't do a full NVRAM clear, now's the time.
  7. lengo lad

    lengo lad LI Guru Member

    fastpakr, my op states:

    I don't know exactly what 'stray dd-wrt settings' I'm referring to. :confused: But something's not right . . . I'll try ifican's suggestions and then maybe go back to Linksys firmware and straight on to Tomato 1.06 (clearing NVRAM at every step along the way).
  8. lengo lad

    lengo lad LI Guru Member

    I just had another 'issue'. I typed into my browser and got me to "a web page" :wink: I then tried pinging, and got "Ping request could not find host yahoo.com. Please check the name and try again." So how do I go about resolving a DNS problem???
  9. luke-san

    luke-san LI Guru Member

    ok, so it seems that it's a dns issue then.

    Now the problem is to find out why it is doing this or ... another 'solution' ... bypassing it.
    The problem is time and how much time you are willing to spend at it trying to resolve it.

    A bypass solution that might work is to use the excellent services from http://www.opendns.com/ and use those dns resolving servers 'hardcoded' in your laptop.

    Just put these 2 ip addresses in your networkcards TCP/IP properties as DNS servers

    As I said, this is a bypass that might work but it is not to be considered a fix.
    Try it out and let us know.
  10. paped

    paped LI Guru Member

    you say that you are hibernating XP.... I would personally check to see if your hardware drivers for your NIC card have later versions, I have a similar issue but it is not just on Tomato its any router for me. If I hibernate when it comes back on the wireless card or 10/100 NIC card does not seem to wake up correctly and connect to the router to put itself back in the router ARP tables to say that "I am here on this network". I have got it better by updating the NIC drivers and googling for and running a Windows IP stack repair utility, but it is only better.... The only true fix that I have found is to reboot the PC or shutdown fully rather than hibernating and I must admit my wireless card is the most flaky of the 2 connection options, the 10/100 card does work most of the time when hibernating.
  11. lengo lad

    lengo lad LI Guru Member

    I finally got back to this (playing with the router is weekend work around here!)

    And I think I've got it sorted. I reverted to Linksys firmware (1.06.1) and tested coming out of hibernation. It worked fine for both my machines--wired and wireless. So then I went to Tomato 1.06 (resetting NVRAM before and after flash). Things still seem good--I'm able to connect immediately after coming out of hibernation. So I'm not sure what was wonky, but it seems to be fixed. Time will tell . . . For now I'll mark this [solved].

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice