Disconnection - temporary fix - Do you have explanation?

Discussion in 'Cisco/Linksys Wireless Routers' started by PepiX, Nov 22, 2005.

  1. PepiX

    PepiX Network Guru Member

    I am asking if someone with a better networking knowledge can explain my problem and why it is fixed (very temporary...) this way..

    The problem: I think it is the failry common disconnection problem. My WRT router is working for some time (between 1 hour and 2-3 days) and then.. all of a sudden it freezes its WiFi part..

    Some background: I have had WRT54GV3 and now I have WRT54GSV1.1 (the V3 one got replaced with a V5 one, but I decided to pay some extra money so I can use DD-WRT... not that I am using its possibilities, but I like the freedom it gives...)

    The problem appeared on both when using the original firmware (~V4.01..), then with V4.20, then with Tarifa (almost disappeared) and I have to play alot with DD-WRT (I have tried 11.11 and 18.11 so far) to make it happen really rarely...

    The very strange fix: with WRT54GV3 I could either disable and then enable the WiFi or plug-unplug the LAN I-Net cable and the router started again... with the GSV1.1 the disable/enable bit is not working only plug-out and then back in the LAN cable..

    So... I think it has something to do with internal address tables and eventual reseting of those.. which makes the system work again..

    I just needed some expertice from guys working with it for quite longer than me (I had never played with routers and WiFi till a month ago...)

    Some more details about the setup:

    1 client using Belkin WiFi card (Fragment Treshold = 2304, RTS Treshold = 23436,WEP)
    one cable going in the WRT - my ISP requires it to be put in a LAN port (not the I-Net one..)
    Settings --- quite generic (except that Beacon=50, Fragmentation=2346,RTS=2347,AP mode,Channel=1) --- no router functions are used

    The Question - why is it fixed this way? Is there a way to prevent the WiFi failing to respond? (I see both WiFi and I-Net lights are blinking.. all lights are normal on the WRT...)
  2. jchuit

    jchuit Network Guru Member

    To Pepix

    Did you do a reset to factory defaults, after upgrading to dd-wrt?
    Maybe there is a bad setting stored in your NVRAM, did you use mac_adress clone?

  3. groupdelay

    groupdelay Network Guru Member

    I've experienced pretty much the same issues when using DD-WRT on a v2.0 WRT54GS. Doing a NVRAM clear ended up bricking the unit...but I was able to recover it.
  4. jchuit

    jchuit Network Guru Member

    For resetting to default I think you should use the reset button:

    Press the reset button and hold it.
    Switch router off, by unplugging the power.
    Keep holding the reset button, plug the power cord.
    Now release the reset button after 30 secs.

    All NVRAM settings will (it should at least) now be erased.

  5. PepiX

    PepiX Network Guru Member

    Thanks for your opinions mates.. unfortunatelly:

    - The behaviour happened with two different routers and 4 different firmwares.
    - I have been reseting the units before and after every re-flash (if not always .. usually)
    - I think I did brick my first unit using the methode described above (somewhere I read this is the way to bring the unit into repair-mode.. or something like that..). I did unbrick it 4-5 times after trying to upload latest DD-WRT and at last.. it was hopeless
    - It happens with brand new units.. after just security setting and IP changing to 192.168.XX.1

    AND: What happens when I unplug the cable and then I plug it back in? Why does this resume the connection?
  6. danielhaden

    danielhaden Network Guru Member

    That particular problem was fixed in the latest codebase of Linksys and HyperWRT. Well, there are several things that can cause that problem, but the two major issues have been fixed. See the large file download post at http://www.hyperwrt.org/forum/index.php and you can download Tofu's and Thibor's firmwares (Point-n-shoot interoperable WDS among other goodies) right here at linksysinfo.org's download section.

    Some background: I had this problem develop while running quite a few firmwares.

    The newer versions cleared up the problem for the GS, but one more thing was required to make the V3 "G" happy:
    I had to set the TX antenna to one side (I used left--you use whatever makes the strongest signal) because the antenna diversity chip had been incorrectly installed. You should have the reception set to "auto" but have it transmit on only one side. This problem is not associated with the "GS" model.
    If this problem had been affecting your WRT54G, it will suddenly make more power when you adjust this setting--and you have just fixed it.

    Another thing you can do to give the unit some relief is to set the power output down in the 63-67 mw range. This affects both "G" and "GS" models wherever Linksys has done a sloppy job with the antenna diversity chip. The only way to discover if this is helpful is to test it.
  7. PepiX

    PepiX Network Guru Member

    Thanks very much danielhaden. For now I decided to stay with DD-WRT and try to go for the two possible causes mentioned in the topic.


    For now I set the antenna used to 'right' only. I have already had lowered the antenna output power to 24mw (Default:28, but.. even overpowering it did not previously help, moreover my signal is constantly at 100%).

    I will try the chip overclock after that...

    As a desperate measure I may go for the HyperWRT FirmWare.

    Thanks again,

    P.S.: Is the nvram command written in telnet? (I guess os --- if I have to do that I will search the forum for more details on how-to do it..)
  8. jksmurf

    jksmurf Network Guru Member

    Setting one Antenna TX and one RX makes sense, but how do you actually TEST which side "makes more power"?

  9. jchuit

    jchuit Network Guru Member

    To PepiX

    As Danielhaden did write, this problem is solved, in the latest firmwares.

    Cause: some hardware models have after full-reset faulty settings, in there NVRAM stored. These settings are corrected and stored during startup of the firmware.

    The 'overclocking' is done in the 4.20.xx and 4.30.xx firmware from Linksys. And I think this also implemented in latest dd-wrt.

    This problem has to do with timing and some Ram settings and only happens in models v2.2 , v3.0, v3.1.

  10. danielhaden

    danielhaden Network Guru Member

    Well, I used the reception antenna on the automatic setting.

    Overclocking to 216 with DD-WRT may work just fine. This is automatic with the newer HyperWRT on models that need it.
  11. PepiX

    PepiX Network Guru Member

    It seems so far the one antena usage have done the things better, but... I had too many computer resstarts to be sure... Anyway the problem is not 100% gone..

    Thanks for your help guys :D
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice