Discontinuing this guide.

Discussion in 'Other Firmware Projects' started by cybrnook, Sep 24, 2015.

  1. ymom411

    ymom411 Reformed Router Member

    Worked like a charm! Now I'm having a different problem. Within PUTTY when I run mtd unlock /dev/mtd0
    I get a message saying "mtd not found".

    Thanks for your help!
  2. ymom411

    ymom411 Reformed Router Member

    I just saw the advice you gave Brunoland about the same problem. I just want to make sure that I am doing this correctly.

    Go to Administration --> Upload Setting Tab --> Restore Setting and Upload the mtd-write file and the new CFE.

    Then, go to Tools --> Run CMD --> and from there type the commands.

    Is this correct? Sorry for all the questions, but I just want to make sure I don't mess up the router.

    Thanks once again
  3. cybrnook

    cybrnook Addicted to LI Member

  4. ymom411

    ymom411 Reformed Router Member

    I got it to work. It just wasn't clear to me that I still had to use WINSCP to upload the files and then run the commands within PUTTY. Perhaps it was the fact that it was past midnight and I was drinking whiskey.

    Either way, thanks for all your help. 36_2 installed and very stable.
    Dr Strangelove likes this.
  5. bluenote

    bluenote LI Guru Member

    This seems like a decent deal for the hardware you get, so I'm interested in buying one - but ... what's this about locking them down? Is there more information about how likely I am to receive one like this that is then useless to me?

  6. Dr Strangelove

    Dr Strangelove LI Guru Member

    Summer time here 24-28C and router is working well.
    The router does run a bit hot, but that doesn't seem to create problems.
    I am using Shibby TomatoUSB v138.
    Had the router for over a year now and no issues thus far, fingers crossed.
    Thank you to @cybrnook and all those contributing.

    Name RBP101

    Model Linksys EA6900
    Chipset ARMv7 Processor rev 0 (v7l)
    CPU Freq 800 MHz (dual-core)
    Flash Size 128MB

    Time Tue, 03 Jan 2017 09:47:15 +1300
    Uptime 17 days, 19:19:24
    CPU Usage 0.66%
    CPU Load (1 / 5 / 15 mins) 0.00 / 0.01 / 0.05
    Total / Free Memory 249.64 MB / 224.32 MB (89.86%)
    Total / Free NVRAM 64.00 KB / 28.61 KB (44.71%)

    CPU Temperature 75°C
    Wireless Temperature eth1: 2.4G - 52°C eth2: 5G - 53°C
    cybrnook likes this.
  7. L|NKSYS

    L|NKSYS New Member Member


    Just a hint for those with a newer firmware that doesn't allow downgrades/3rd party firmware anymore. While I was running into the same issue using the normal firmware upgrade function, I was able to bring up the mini webserver using the 30-30-30 method and then use it to flash Brainslayers DD-WRT directly. From there, everything went smoothly.

    Btw, I decided against the Asuswrt-Merlin / XVortex firmware and went for Shibby's Tomato firmware mainly because in Asuswrt-Merlin / XVortex firmware you can't:

    - set the source IP for port forwards through GUI
    - set more than 1 MAC address per host in static DHCP
    - set a custom port for non-secure web access from LAN (stuck with port 80)
    - set more than 1 DDNS (a suggested workaround with dnsomatic might come with security and reliabilty issues).

    Oh yeah, and Shibby has proven recently to be still alive :D

    Anyway, thanks a lot cybrnook for the instructions :)
    Last edited: Jan 17, 2017
    cybrnook likes this.
  8. cybrnook

    cybrnook Addicted to LI Member


    I never tried myself while I had this router, but I was under the impression the mini webserver was only unlocked/available from Asus's Broadcom CFE. Are you stating that units that have (or come with) the latest firmware ALSO have the broadcom mini webserver available? I am not sure if that is really the case......

    As well, 30-30-30 TODAY is a big no no on routers. There have been reports of users bricking their devices on newer ARM based routers. So I recommend against this approach.l
  9. L|NKSYS

    L|NKSYS New Member Member

    Well, all I know is that on my newly bought router where I did the 30-30-30 method a screen came up where it said "CFE mini web server" or smth and there you could upload the firmware and it also had links to clear the NVRAM and reboot.

    Yeah, I read about that warning, but thing is with the new EA6900s you have 2 choices: either stay with the crappy stock firmware which makes the router food for the rubbish bin anyway (if you have more than just very basic requirements) or take the risk and just do it. Btw, I did the 30-30-30 method quite a few times as I switched between different firmwares and executed this after each switch. So the risk can't be that high either. But each to its own.
  10. cybrnook

    cybrnook Addicted to LI Member

    Don't underestimate the trouble you can get in with this. :) Not all routers will be so forgiving. 30-30-30 is only relevant back from the WRT54G days.

    But thanks for the info regarding being able to get to the CFE miniwebserver.

    I think for future, I have found the easiest, and proper, way to reach the CFE webserver is to power off the router (by either switching it off, or unplugging it). Then press the reset button, and while still pressing the reset button power on the router (by either pugging it in, or flipping the switch). This is how to bring up the webserver.

    Hopefully some of the users who also get a new version (like you, who has tested it) will benefit from your trials. Thanks again for sharing the webserver info and providing a nice backdoor to downgrade.

    Sounds very similar to Asus routers at the moment. Where they also no longer allow downgrading directly via firmware. You also have to downgrade via the recovery web server.
    Last edited: Jan 18, 2017
    L|NKSYS likes this.
  11. alwaysup2late

    alwaysup2late New Member Member

    Hi, first post here. I want to share my experience with getting the EA6900 to flash custom firmware.

    I bought the EA6900 in 2014, refurbished got a good deal. When I initially set it up, I enabled the auto-update feature. This made my attempts to flash the initial "linksys-ea6900-webflash.bin" fail because I have the most up to date version of the Linksys firmware: "1.1.42 (Build 174776)". No matter how many times I tried to flash the initial build, it continued to tell me that I had an invalid firmware.

    Luckily enough, under Troubleshooting tab and one of the sub tabs there, I was able to find the option called "Restore previous firmware". I figured at this point in time, why not try it out. After it finished, luckily, I was brought back to the initial firmware that shipped with my router in 2014.

    After that I was able to successfully flash "linksys-ea6900-webflash.bin" and continue customizing my router. Although I flashed a Kong build because I only need the wireless bridge feature, I thought this may be helpful to know for anyone who had a pre mid 2016 router that had been automatically updated to be able to continue with the installation of custom firmware.

    Also, during the couple days of frustration I can also attest that my EA6900 was fine after numerous 30-30-30 resets.
    Leonardo MOrales and OtisQQ like this.
  12. Gorrillasnot

    Gorrillasnot New Member Member

    cybrnook: thanks for this great tutorial/guide and thanks to Merlin and Xwrt-Vortex for the awesome firmware.

    I am having a few issues.

    1. In Xwrt-Vortex /Merlin where does it show what my MAC address are?
    Shouldn't it be on the main page on the lower right under the RAM info? Mine is blank

    I followed info in this guide http://www.dd-wrt.com/phpBB2/viewtopic.php?t=291230 when setting up the MACs in the custom CFE and I may have messed up something.
    The MAC on the bottom of the router is XX:XX:XX:XX:XX:49. I set et0macaddr=XX:XX:XX:XX:XX:49, 0:macaddr=XX:XX:XX:XX:XX:4B, and 1:macaddr=XX:XX:XX:XX:XX:4D is this right or did I mess up?

    2. I cant seem to connect to the router using WinSCP in Merlin.
    Enable SSH is checked and Allow SSH password login is also checked.
    I'm using root:admin as login and pass, but it says access denied.
    what am I doing wrong?

    3. I am still on 378.54_2. I prefer the oldscool log in box pop up over the newer style log in page in 378.56_2 (I have ocd lol), but am I missing anything especailly performance wise by staying on the older firmware?


    Attached Files:

  13. cybrnook

    cybrnook Addicted to LI Member

    1. Please read my second post HERE
    2. Try to set winscp to "SCP" mode
    3. Follow the change log in snb, and determine if it makes sense to you.
  14. apvmtan

    apvmtan Serious Server Member

    Back to my backup EA6900, my wrt1900ac v1 not working well. Now planning to pick up an ac v2 or acs if not, although not a big fan of Tplink stock firmware, I may get a c2600 as my new toy. To be honest, the range of the wrt1900ac is amazing but wifi transfer rate is weaker than ea6900. I like the wrt1900ac look.
  15. Gorrillasnot

    Gorrillasnot New Member Member

    cybrnook: Thanks for the reply.

    scp mode didn't work either. Tried in both Xwrt-Vortex and Tomato. Only can log in when using DD-wrt.

  16. rockkpw3

    rockkpw3 New Member Member

    really nice tutorial.

    i have met issue when i upload the initial Brain Slayer DD-WRT image, the error message said "invalid firmware file", my ea6900 firmware version is currently

    any idea how to fix it?
  17. cybrnook

    cybrnook Addicted to LI Member

    Very first sentence in my first post :)
  18. cybrnook

    cybrnook Addicted to LI Member

  19. rockkpw3

    rockkpw3 New Member Member

    it works well after restore to previous FW. Thanks cybrnook 's great work!!!:)
  20. cybrnook

    cybrnook Addicted to LI Member

    Thanks for the confirmation, I am glad it worked well for you :)
    rockkpw3 likes this.
  21. apvmtan

    apvmtan Serious Server Member

    Thanks, updated to 380.65
  22. rockkpw3

    rockkpw3 New Member Member

    me too. ;)
    BigBossRadio likes this.
  23. Stueybuk

    Stueybuk New Member Member

    Hi, I have read through this whole thread with great interest and was looking forward to buying the EA6900, until I got to the penultimate page which informed me that the recent routers are not allowing this process to happen. I see that you have amended your original instructions to point to a way of going back to an older firmware, but also noticed that you thought this way may be dangerous.
    My question really, is it still worth me buying this router ? Or would something else serve me better ?
    My other options to purchase are the RT-AC66u or the TP-Link Archer C9.
    Thanks in advance for our help,

  24. apvmtan

    apvmtan Serious Server Member

    My wrt1900ac v2 from ebay arrived yesterday. Flashed it with cybrnook's stable Lede build and packed the ea6900 as my back up router. The ea6900 is very solid with vortex merlin firmware. Only thing is the 5Ghz range and throughput is weaker than wrt1900ac with lede. I have a blind spot in my house for 5ghz when with the ea6900 but wrt1900 can reach it without problem. Nonetheless, my router is placed in my work room which is at a corner of the house and transfer between my computer and nas is slower with the WRT1900, so there is some give and take here.

    Not saying the ea6900 is bad, it is a very good and solid router with vortex merlin firmware.
    Last edited: Feb 7, 2017
  25. Stueybuk

    Stueybuk New Member Member

    Thanks for the info, is there and issue with the newer WRT1900ACS apparently the S standing for v2 ?
  26. apvmtan

    apvmtan Serious Server Member

    I am not sure about stock firmware but with lede, I found that transfer between my computer and either my Asustor or Synology Nas is slower with wrt1900 than the ea6900 (ea6900 is faster). So there is some give and take here.

    If you are buying new, shop around. TP link hardware is good but their firmware is not great. I was looking at the TPlink C2600 but too bad the third party firmware support is not mature yet but should be well supported by Lede in the future.

    If you are buying used, the wrt1900 ac v2 or acs and the ea6900 are not bad choices. People are also starting to dump their R7000 and AC66/68 into used market, they are also good choices since third party firmware support are mature for these routers.

    By the way, I don't think any routers that are above AC1900 are worth it ($$$) since most wifi devices could not take advantage from above AC1750 routers. JMO.
    Last edited: Feb 7, 2017
  27. cybrnook

    cybrnook Addicted to LI Member

    If you are buying today, I would purchase a Netgear R7000 or Asus RT-AC68U. It is the most supported model, and is rock solid. Granted it is the same as the RT-AC68U, and EA6900.

    R7000/RT-AC68U supports DD-WRT, Tomato, XVortex (RT-AC68U supports Merlin natively)

    With that said, if you can get an EA6900 for cheap, then yes it is still worth it.
  28. Stueybuk

    Stueybuk New Member Member

    Thanks again for the reply, I have a credit with a specific company that I need to use up. Only options available are EA6900, RT-AC66u or Archer C9. I could possibly add to it for the RT-AC68u if there is that much of a difference.
  29. cybrnook

    cybrnook Addicted to LI Member

    Well, internally the RT-AC68U and the EA6900 are the same router.

    But the asus is more "natively" supported across the board, and does not have the 32k NVRAM bug that the EA6900 has (Hence the reason this thread exists). RT-AC68U is also natively supported by Asus and Merlin, so no worries as to when XVortex stops supporting these models.

    EA6900 just requires more "hacking" to make work okay.
  30. Stueybuk

    Stueybuk New Member Member

    That makes sense, thank you.

    Sent from my iPhone using Tapatalk
  31. apvmtan

    apvmtan Serious Server Member

    @cybrnook, since ea6900 and R7000 uses the same wifi chip, given both with vortex merlin, will it be safe to say that wifi range and performance will be more or less the same with these two? Tia
  32. cybrnook

    cybrnook Addicted to LI Member

  33. apvmtan

    apvmtan Serious Server Member

    Thanks for prompt reply, that means no need for me to get an used R7000 to play around.

    The C2600 is about US$88 shipped here, tempted to get one to play around but to be honest, not a big fan of TP-Link. Looks like keeping the ea6900 as my back up router.
  34. cybrnook

    cybrnook Addicted to LI Member

    Yes, if you already have the ea6900 with the custom CFE, them you already have "a form" of the best backup router available on the market. Hell it's a great primary router. DDWRT, XVortex, tomato all support it.

    And there are still really no devices on the market that run 3x3 1300ac.
    Last edited: Feb 9, 2017
  35. Stueybuk

    Stueybuk New Member Member

    Yep, think I'm going to get the ea6900, cheapest option for me, don't mind doing a bit of work to get it flashed.

    Sent from my iPhone using Tapatalk
  36. BigBossRadio

    BigBossRadio Serious Server Member

    Me too also. So far looking good........ I
    It looks good .. I'll keep you posted Thanks Vortex
  37. Moonelf

    Moonelf New Member Member

    Guys, I just got a new EA6900, the factory FW is, it's locked firmware downgrade and 3rd firmware. I try linksys' TFTP tool, it also blocked. Are there any other method for me to flash it to DD=WRT/OpenWRT/Merlin?
    BigBossRadio likes this.
  38. apvmtan

    apvmtan Serious Server Member

    Read post #607-611 and do it at your own risk.
  39. ThanatosUA

    ThanatosUA Network Newbie Member

    Please, need guide for this case, because of this alert.
    stock Linksys CFE which has 2 x firmware partitions. XVortex's has only 1, so this can cause some anomalies to which you are in a grey area.
    I'd like to have Vortex CFE on board but this alert.. The router can work unstable in future, need guide, please ;)
    My English is bad)
  40. apvmtan

    apvmtan Serious Server Member

    If you are planning to use Xvortex merlin, ddwrt, tomato etc firmware with the ea6900, do the xvortex cfe. There is really no need for the Linksys cfe since because of its 2x firmware partitions, it limit to 32k per partitions and is bad for third party firmware.

    Someone correct me if I am wrong.
  41. cybrnook

    cybrnook Addicted to LI Member

    And the XVortex CFE has the built in mini web recovery server. So that eliminates really any ability to "brick" the router.

    So no worries.... proceed as normal.
    Last edited: Feb 14, 2017
  42. David Chan

    David Chan New Member Member

    Cybrnook first time post here great job!!! i was able to put in stable version firmware 380_65 following your guide. I was wondering if you have a guide to setup proper vpn on EA6900?
  43. BigBossRadio

    BigBossRadio Serious Server Member

    I am curious as to how things are going for you. Have you managed to flash to Merlin/Vortex yet? Can you give us an update on your progress?

  44. BigBossRadio

    BigBossRadio Serious Server Member

    Go back and read Cybrnook's post #304 earlier on VPN which will give you some some good input on VPN
  45. THE_CD

    THE_CD Addicted to LI Member

    Hi there
    Is USB 3.0 port still not working with the latest XVortex Custom CFE ?
  46. cybrnook

    cybrnook Addicted to LI Member

    USB3.0 port has always worked fine with the EA6900 and Custom CFE.

    You just need to disable "Reduce USB interference" in the 2.4 professional settings to set that port to 3.0 speeds. Else it defaults to 2.0.

    This has always been the case, even on Asus routers.
    ThanatosUA and BigBossRadio like this.
  47. Datlore001

    Datlore001 New Member Member

    Can I flash Tomato straight from Xwrt? I'm using the modified Xvortex CFE. Having issues with WAN connection on 380.65 and want to try Tomato.
  48. Jose C

    Jose C Serious Server Member

    I've read the custom cfe for ea6900 work just fine in the ea6700 and I was wondering if somebody can confirm if the procedure on the first post of this topic also work for ea6500v2 being it pretty much the same as the ea6700?

    Sent from my iPhone using Tapatalk
  49. cybrnook

    cybrnook Addicted to LI Member

    Flash through the recovery webserver, then do a NVRAM clear after the flash.
  50. jeremiahbarrar

    jeremiahbarrar Reformed Router Member

    router would not accept the initial dd-wrt bin via web interface.
    30/30/30 reset should be avoided
    Troubleshooting tab > "Restore previous firmware" did not work

    SOLUTION: tftp on router boot

    Keep trying to push the .bin file, it should work eventually
    I used the windows built in tftp client
    Start–> Control Panel–> Programs and Features -> Turn Windows features on or off -> check off tftp
    Set a static IP in adapter settings on your PC ( for PC static IP, for subnet, and for gateway).
    Plug your ethernet cable from the PC to the router (I used port 1) with the router unplugged from power.
    In a command prompt cd to your directory where you downloaded the dd-wrt.bin from the first post of this thread
    Type "tftp -i put firmware.bin" but don't execute yet
    You can use another command prompt to watch for pings but I did not need to
    Plug the power into the router
    You have to be quick here, I pressed enter and started the tftp command at the same time the router was plugged in. You also can try it with a slight delay, or execute the tftp command right before you plug in the power
    The Linksys light on top should be slowly flashing in and out while uploading then you should get an upload successful message on the prompt (and stop receiving pings)
    Just wait for it to reboot and load the new dd-wrt firmware.
    If you have issues with getting the tftp command to successfully upload, keep trying but make sure you unplug the router and plug it back in on each attempt (or use the switch)
    ThanatosUA and cybrnook like this.
  51. FlatEarther

    FlatEarther Network Newbie Member

    I had success installing on an EA6500v2 about a week ago. Had just installed on an EA6900(v1) so figured it was worth a try... Now both units working smooth on xVortex v380.65

    A few things to note different from my EA6900 install: Ethernet ports all changed after xVortex installed. LAN1 becomes WAN. LAN2 becomes LAN1. LAN3 becomes LAN2. LAN4 becomes LAN3. WAN becomes LAN4...
    So connect using LAN2, 3, or 4 to avoid disconnect during the process.
    In Putty used: mtd -f write /tmp/root/new-cfe.bin /dev/mtd0

    That's it. Much thx to cybrnook, merlin, etc for their excellent work... Made this newby look like a pro!
    Both units had Shibby v132 and I was unable to setup a guest network so went looking for another solution.
    This firmware has Guest Network in the GUI so perfect for my needs.
    Jose C and cybrnook like this.
  52. hewfer

    hewfer New Member Member

    If I'm on XWRT-Vortex and want to flash to DD-WRT, what is the correct procedure to do so.
    And being on the subject, where are the DD-WRT builds for the EA6900, I've looked on the DD-WRT site but have trouble finding them.
    Thanks !
  53. FlatEarther

    FlatEarther Network Newbie Member

    dd-wrt com has a post titled "Linksys EA 6900 Install Guide"
    So search for that.
    Can't help on the subject of coming from xVortex, but going back to original firmware might be the way to go...
  54. hewfer

    hewfer New Member Member

    Yeah I already looked at that but the problem is the DD-WRT builds I found are BIN's and I believe we only flash TRX's via XVT's mini web server ... but I'm not sure...
  55. apvmtan

    apvmtan Serious Server Member

    Looks like Xvortex is no longer updating, how's tomato with the EA6900?
  56. cybrnook

    cybrnook Addicted to LI Member

    He is, there have just been no "releases" since 65. He is still actively merging his code with Merlins.
    Makaveli likes this.
  57. RMerlin

    RMerlin Network Guru Member

    There's been two security releases (65_2 and 65_4) which he hasn't picked.
    Makaveli and cybrnook like this.
  58. cybrnook

    cybrnook Addicted to LI Member

    His last merge was 4 days ago, bringing his branch up to " Bumped revision to 380.66 Beta 1" bringing him to 147d88b. I am sure he will catch your latest security commits.
    66_1 would catch all this, no? I think his next release would be your next whole release, not security releases. I imagine his project is getting a little tiring for him...
  59. RMerlin

    RMerlin Network Guru Member

    380.66 would include them, yes, however it still means that for 1-2 months, there were multiple known security issues (with readily available fixes) that are missing. So right now, anyone running XVortex and opening his webui to the WAN for instance can be remotely rooted. Something worth thinking about...
  60. cybrnook

    cybrnook Addicted to LI Member

    Of course, that is a very good point!
  61. Zfactor300

    Zfactor300 Reformed Router Member

    Why would you not setup VPN to the router? Leave the webui to the WAN disabled. To me that makes more sense, no?

    Sent from my iPhone using Tapatalk
  62. voltayer

    voltayer New Member Member

    cybernook, signed up to say THANK YOU! You sir are the man of the day 5/4/17

  63. njm7550

    njm7550 New Member Member

    Thanks a lot for the walk through. It is still relevant. I have a new EA6900 that I just bought from Linksys' web page for 75 USD (not refurbished, brand new). It was unlocked and I was able to do everything you listed without having to apply any hacks to unlock it.
    cybrnook likes this.
  64. XVortex

    XVortex Addicted to LI Member

    I've released XWRT v380.66 just now.
    Because there are a lot of changes, I recommend doing a full reset.
    Let's test.
    Makaveli, apvmtan and cybrnook like this.
  65. cybrnook

    cybrnook Addicted to LI Member

    Thanks XVortex, should be able to test tomorrow!
  66. cybrnook

    cybrnook Addicted to LI Member

    @XVortex , 380.66 up and running without issues on the EA6900.

    Thank you much! Sent a little something your way.
    BigBossRadio likes this.
  67. cybrnook

    cybrnook Addicted to LI Member

    @XVortex , the XHCI patch you applied. was this also corrected on this build for the ea6900?
  68. XVortex

    XVortex Addicted to LI Member

    Makaveli and cybrnook like this.
  69. apvmtan

    apvmtan Serious Server Member

    Just tested, working fine, thanks XVortex 380_66_2
    Last edited: May 17, 2017
  70. Mohsin323

    Mohsin323 New Member Member

    Is this router still worth buying , I can get it for 60 bucks , and I have a 200mbps connection

    Sent from my Nexus 6 using Tapatalk
  71. apvmtan

    apvmtan Serious Server Member

    Should be able to handle 200mbps easily. IMO if you can still tweak the new ones, it is worth it.
    Mohsin323 likes this.
  72. Mohsin323

    Mohsin323 New Member Member

    Well I had the choice between Linksys and Dlink dir 880l and I chose this one even tho the specs are same.

    Sent from my Nexus 6 using Tapatalk
  73. brunoland

    brunoland Connected Client Member

    Hi, I've flashed latest 380.66_2. Had few problems with stability so I did factory restore over GUI.
    Now my 5 GHZ don't work on password as before changing CFE on my own previous time.
    So I've I've thought it corrupted me a cfe and tried to overwriti it again but no success. mtd-write don't work, it doesn't write anything just go on new line, without any error...
    liante0904 likes this.
  74. brunoland

    brunoland Connected Client Member

    You can ignore previous post. It was probably bad flash. I flashed it again and all is working fine.
  75. linuxfr33k

    linuxfr33k New Member Member

    I know this is from a long time ago but can I replace boot with /dev/mtd0? Mine is an EA6400 so I need the mtd-write because nothing on Merlin command line will write to boot in my case mtd0. What are the switches used for the -i and -d? How can we unlock the boot or mtd0 in order to write to it once in Merlin Fimrware? I know its simple in dd-wrt mtd unlock /dev/mtd0. I had to go back twice into Numinit's Little Hacky build for the EA6400 to to be able to try a couple different CFE's and would like to have this available on the Merlin's build rather than going back and forth. I am guessing -d is directory?



    I tried it got a segmentation fault so and it runs just fine on the EA6300v1 (EA6400) with the format you have. I am seeing a lot of wl0 and wl1 mac address entries can't figure out why like 10 of them for 2.4GHz and 10 for 5GHz, looking into this, its the koolshare CFE and not Xvortex although they are exactly the same except a couple extra entries for UUID for example and couple more entries for Mac addresses.
    Last edited: Jun 7, 2017
  76. ferrytrip1

    ferrytrip1 New Member Member

    Hi - I just bought this router used - works fine as it should.

    It came with FW - I rolled it back to

    I cannot get past stage 1 - each time I try to flash with Brainslayers .bin file it tells me its too big.

    Thanks to help with where to start again?


  77. ferrytrip1

    ferrytrip1 New Member Member

    All sorted and working very well

    Thanks for a great post
    Last edited: Jun 13, 2017
  78. ThanatosUA

    ThanatosUA Network Newbie Member

  79. liante0904

    liante0904 New Member Member

    me too i have a same problem.. :(
  80. liante0904

    liante0904 New Member Member

    should i solve to flash again?
  81. brunoland

    brunoland Connected Client Member

    I've resolved with another flash of latest firmware and all went back to previous state with latest firmware with no issue of stability so far.

    Sent from mTalk
  82. liante0904

    liante0904 New Member Member

    then should I flash back to dd-wrt from XVortex and go to again XVortex?
    i dont know XVortex to dd-wrt back method..
  83. brunoland

    brunoland Connected Client Member

    No, just flash again 380.66_2.

    Sent from mTalk
  84. liante0904

    liante0904 New Member Member

    I've tried the 380.66_2 version of Flash, but this issue is still not resolved.
  85. apvmtan

    apvmtan Serious Server Member

    Will be testing Shibby tomato 1.4 soon.
  86. cjapeterborough

    cjapeterborough Connected Client Member

    I have just registered to say a huge THANK YOU to cybrnook(and the other contributors) for the excellent guide to cross flashing the EA6900!
    I received a new EA6900 V1.1 this week(im in the UK) which had the latest Linksys firmware and after manually flashing back to an older had a trouble free upgrade to Xvortex Merlin 380.66.2

    As a previous long term user of an RT-N66U with Merlin its great to be back to my own comfort zone!
    Last edited: Jul 8, 2017
  87. OtisQQ

    OtisQQ New Member Member

    This was extremely helpful - thanks @alwaysup2late. I just got a refurb v1.1 and was stuck. This allowed me to fall back to Linksys firmware version (shipped with 1.42.174776) which let me load the Dragonslayer build and get started.

    And a million thanks to @cybrnook for putting this together!
  88. XVortex

    XVortex Addicted to LI Member

    XWRT-Vortex 380.67 is available and ready for download.
    There are bunch of improvements and fixes in there.
    Please see the changelog for info.
    apvmtan and cybrnook like this.
  89. cybrnook

    cybrnook Addicted to LI Member

    Thanks @XVortex , will load it up soon!
  90. Escabrera

    Escabrera New Member Member

    So I have one of the newer models but not the latest update. I just flashed the initial ddwrt build and the Linksys site says waiting but on my my phone a new wifi network with the name dd-wrt has appeared. What should I do. Just wait and hope for the site waiting screen to end or try and access the dd-wrt network site? I should add that my computer doesn't recognize the connection internet.
    Edit: scratch that all that took was waiting because it eventually finished. I am now running advanced tomato. Thanks for the guide.
    Last edited: Jul 18, 2017
  91. julichan

    julichan New Member Member


    Just saying thanks to everyone here. all your posts were good leads to figure out why my 5ghz wireless didn't work.
    Turns out it wouldn't work between versions 378.54_2 and 380.67 but I'm still forced to go on static channels on last version because the auto option choose the channel 144 which is only for the US... 0.o?

    And thanks xvortex and rmerlin for your great work :D
  92. Leonardo MOrales

    Leonardo MOrales New Member Member

    Hello all,
    I'm new here, so, sorry for newie questions :). I'd like to know if there is any issue running tomato on EA6900 v1.1 (I heard something about 32k nand issue, but I think that this install approach sort out it, right?) and if it's possible or anybody flashed Tomato 140 already.

    Thank you!
  93. Leonardo MOrales

    Leonardo MOrales New Member Member

    Worked PERFECTLY thank you!!
  94. FlatEarther

    FlatEarther Network Newbie Member

    I see Newegg has reman EA6900 today for US$39.99 ....
    Doesn't indicate hardware version if it matters.
  95. cybrnook

    cybrnook Addicted to LI Member

    That's a steal.
  96. FlatEarther

    FlatEarther Network Newbie Member

    Newegg sale price of EA6900-RM now shows good thru Saturday Aug 5...
    US$39.99 (and maybe free shipping)
  97. Mario Sanchez

    Mario Sanchez New Member Member

    Mario here. I have just did the full procedure and I would like to congratulate cybrnook for all clarity in preparing the walkthrough.
    I gone through all the procedure fine. And in the end I did some modifications.
    First, due the fact that I have some blind spots in my place I raised the power of 5GHz to 75% and 2.4GHz to 65%. Also I have a USB 3.0 external HD 2T attached to the usb 3.0 port. I disabled the reduce interference as stated above.
    I use a macbook air connected always in 5Ghz.
    The problem is that I realized some instability playing movies from the 3.0 USB device firstly was streaming ok, but i realized that sometimes the film freezes. I thought would be the power up. reduced back to 50% since were the standards. After doing that, I noticed that by the time i start streaming, the 5ghz radio gone dead. trying to connect to 2.4Ghz, no go. Only way is to reboot the device.
    Have you guys saw some situations like that ?
    I am using the latest firmware version. Do you reccomend some features be set up in the EA6900? Or should I bring back the stock firmware from Linksys to have the router working properly with the usb3.0 device.... I was planning to attach another usb2.0 drive ...
    Thanks in advance for your support.

    Mario Sanchez
  98. Mario Sanchez

    Mario Sanchez New Member Member

    Also, my cable modem has 2.4 ghz wifi and ins side by side with my EA6900. I shut down the 2.4GHz of the cable modem to do not interfere in the router. Is that correct this understanding or I should light up the wifi?
  99. FlatEarther

    FlatEarther Network Newbie Member

    Hello Mario,
    Did you test this hardware (wifi and usb) with the original firmware?
    Does it have the correct 12 volt / 3.5 amp power supply?
    Can you connect the macbook with wired ethernet to the router to test usb setup?
    Last edited: Aug 3, 2017
  100. Mario Sanchez

    Mario Sanchez New Member Member

    YEP, it used to work fine.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice