Discontinuing this guide.

Discussion in 'Other Firmware Projects' started by cybrnook, Sep 24, 2015.

  1. alphabet

    alphabet Network Newbie Member

    As an experiment I tried to go back to stock firmware after seeing this guide on the dd-wrt forum. Well it failed I ended up with:
    1, Working lan and wan ports.
    2, No wifi.
    3, No access to web gui.

    Fortunately it is still under warranty and I RMA'ed the unit. ;)

    When I get the unit replaced I intend to try and run stock firmware on the vortex cfe. With the mini web server I should be able to recover the unit if it is unsuccessful. :)
     
  2. phagenauw

    phagenauw Network Newbie Member

    Hello. I tried the procedure to update the firmware to the xvortex version. All went ok, updated the boot loader with the new cfe (double checked) and finaly got the cfe mini web server.
    At that point i uploaded the xvortex firmware (380_69). During this upload i did not got the conformation the upload was successfull, instead the browser reported the connection was reinitialized.
    After waiting some extra time i switch power off and back on. Then opening a browser again i got the dd-wrt initial web interface back (strange) asking me for a router admin user and password. I did supply these.
    At that point i did a reset of the router (red button) and after this i got the cfe mini web back. So i tried again uploading the xvortex image. This time using another browser. And yes it reported the image was succesfully uploaded and the router is going to be reset.
    After reset now the router pings back, linksys logo is flashing. Then stops, ping is gone, and after some time i got a ping back. This repeat itself over and over. Power off makes no difference, it just is in some kind of loop.
    Now reseting it again (red button) gives the cfe web interface again. Ping will be stable at that point (so the loop is gone).
    But now; how do i got a firmware on my device since up till now it got no success (or is it already dead :( )

    Sorry for the long story (i can even make it longer :) ) but maybe someone will read it and have some hints for me to continue.

    Thanks,
    Petro
     
  3. alphabet

    alphabet Network Newbie Member

    After this step you have to reset NVRAM.

    Turn off router. Now press blue button on the back and turn the power on. Keep pressing blue button until Linksys logo flashes.

    Let it boot up.
     
  4. dekomomo

    dekomomo New Member Member

    Does the procedure work on EA6900 hardware version v2 as well (firmware version 2.0.1.179756)?
    I cannot upload linksys-ea6900-webflash.bin it reports:
    "This firmware file won't work on this router ..."

    Thanks for reply,
    Damian
     
  5. t_riikonen

    t_riikonen New Member Member

    Cybernook: One more huge thank you for creating simple to follow instructions. :)

    I just want to confirm, that I was able to flash the latest EA6900_380.69 FW to my EA6900 v1.1. After installation it initially had the same 5 GHz WLAN problem as earlier discussed in this forum. I succeeded to get it working by setting MAC addresses in the following way:
    et0macaddr=et0macaddr
    0:macaddr=et0macaddr
    1:macaddr=et0macaddr+1

    I of course only needed to change 1:macaddr:
    [SSH to EA6900]
    nvram set 1:macaddr=xx:xx:xx:xx:xx:26
    nvram commit && reboot

    This message is just to confirm that this will still solve 5 GHz problem and newbies don't have to read the whole thread through to find the solution.
     
  6. millcho

    millcho New Member Member

    Thanks for an awesome guide! Up and running Tomato on EA6900 honestly took more time to transfer all my settings than flashing it :)
     
  7. dekomomo

    dekomomo New Member Member

    Which hardware version EA6900 did you install the firmware on?
     
  8. cybrnook

    cybrnook Addicted to LI Member

    First sentence first post should help you.
     
  9. dekomomo

    dekomomo New Member Member

    Hi, also regarding post #808 I have tried all of the above procedures on a new EA6900 v2 and none worked...was unable to access CFE web server pressing the reset, WPS or doing the 30-30-30.
     
  10. cybrnook

    cybrnook Addicted to LI Member

    Not sure then, sorry. I don't have a V2 to test with.
     
  11. joysone

    joysone New Member Member

    Hi all. Congratulation for great job... and now I have Custom CFE and Tomato by Shibby on my EA6900. :)
    I'd like to share my experience and post some question.

    I set MAC address in CFE custom file according the Guide:
    et0macaddr=xx:xx:xx:xx:xx:B5
    0:macaddr=xx:xx:xx:xx:xx:B8
    1:macaddr=xx:xx:xx:xx:xx:B9

    But if I run nvram show command on the router I see:
    et0macaddr=xx:xx:xx:xx:xx:B5
    0:macaddr=xx:xx:xx:xx:xx:B7
    1:macaddr=xx:xx:xx:xx:xx:BB

    everything seems to work, but is this condition consistent?

    Also, when I boot in mini CFE web server, I just see "CFE miniWeb Server" as heading and not "XVT -CFE miniWeb Server". I thing is right but if onyone can confirm.

    Thanks a lot.
     
  12. cybrnook

    cybrnook Addicted to LI Member

    All of that is fine. Good job!

    Firmware calculates it's own values, and the header on webserver is not important :)
     
  13. joysone

    joysone New Member Member

    Ok thanks. Now I want add AirPlay support to my wireless printer and I found a guide from 2013. I can’t post the link for my young forum age :)

    So, do you have experience with the procedure? Or can you suggest most recent guide?

    Thanks. Bye.
     
  14. btidey

    btidey Networkin' Nut Member

    Thanks for the guide at start of thread. I successfully changed a EA6700 over to Vortex cfe / Tomato(Kille-Shibby).

    I did struggle at the final flash using the mini web server where my browser would immediately disconnect as soon as upload was pressed despite repeated attempts.

    I eventually succeeded by turning off PC firewall and by using Internet Explorer instead of Chrome. It is possible I could have made Chrome work by clearing its cache, but I didn't think of trying that before switching to IE.

    One issue I am not clear about is whether with the new cfe I should always flash new firmware with mini web server route or is it safe to use the update within the router firmware itself; e.g tomato administration.
     
  15. Whitewizard

    Whitewizard New Member Member

    I read this and tried my own method again, turns out there are a lot of nvram variables programmed via ttl that are both lost on nvram reset and not included in the inital flash image. Long story short and 6 hours of messing with it later I ended up in the same spot as you. I have updated the guide to reflect this.
     
  16. onjonx

    onjonx New Member Member

    I have a couple questions that need to be answered here goes When editing the CFE with CFEEdit.exe, what is the secret WPS code format under 1:macaddr go? Can you do this without being connected to the internet
    if you downloaded the required files in advance or does it need internet to
    flash the custom cfe? Can you update Xvortex Firmware through the Gui or does it have to be
    through the XVT miniweb server every time? Does reseting the NVram erase the NVram? Can you
    do a factory reset through the Xvortex Firmware normally or do you have to use clear Nvram method holding
    the wps button?

    This MISC:
    #Flashing CFE from within XVortex/AsusMerlin:
    chmod +x ./mtd-write
    ./mtd-write -i new-cfe.bin -d boot

    How do you do this method the MISC part?

    If you already flashed the Cfe, do you have to do it every time you upgrade Xvortex Versions?
    Can you update the guide when editing the CFE to solve the 5ghz issue people are reporting?
     
  17. onjonx

    onjonx New Member Member

    Is Xvortex going to release a new firmware next month or end of this month?
     
  18. cybrnook

    cybrnook Addicted to LI Member

    apvmtan likes this.
  19. hieppo

    hieppo Serious Server Member

    Just flashed 380.69_2 and everything seems to be operational. Only issue is the actual pages and the supposedly links that provide access to IPtraffic and QOS.
    Can anyone tell me if there is some sort of option to enable all the features on the main index.asp? I recenty made the jump to upgrade my firware to the current 380.69_2 from 378.55_2. Back on the old version, I was able to browse both to the QOS and IPtraffic monitoring from the main index page. However, with the latest version, the main index page, I am unable to find any soft of link that I can browse over to those pages. I know the page exist, since i entered the asp name directly and teh page does come up. However, I am perplex to know why the link does not exist on the main page? Was the upgrade missing something?
     
  20. cjapeterborough

    cjapeterborough Connected Client Member


    Few pages back.........
    "Enable BWDPI" under "Tools - Other Settings" and then reboot
     
  21. hieppo

    hieppo Serious Server Member

    Thanks cjapeterborough, that was the exact solution that was needed. I was not able to find any documentation on showing me the changes and how to enable it.
    Thanks again.
     
  22. trixrabite

    trixrabite New Member Member

    Is there a reason for why this guide was removed?
     
  23. cybrnook

    cybrnook Addicted to LI Member

    I don't want it to be a contributing factor to the growing issues being created from the forks of Merlins base. Plus, seems this is no longer relevant for the V2 of this router, so it's dated anyways.
     
    thelonelycoder likes this.
  24. trixrabite

    trixrabite New Member Member

    Tis a shame. I started using this guide as I just received this router and was going through with changing over to dd-wrt and then the guide went missing. I was in a haste and may have done something wrong. now I have the router on Xwrt-Vortex. It loads up the web-GUI initially, but when I go to save and make changes that require a reboot or even if I unplug the router it doesn't do anything after that the Linksys LED in the front blinks for a minute then goes solid no wireless comes up and I get a ping at 192.168.1.1 but no connection to the web-GUI I cant even SSH into the router. it's an EA6900 v1.1 any help getting it work properly would be greatly appreciated.
     
  25. alphabet

    alphabet Network Newbie Member

    If you hurry, its still available on Google cache. ;-)

    Going...Going...
     
    Last edited: Mar 1, 2018
  26. trixrabite

    trixrabite New Member Member

    No... It's gone by the time I checked this post.

    snapshot of the page as it appeared on Feb 28, 2018 01:55:21 GMT

    Same as it is right now.
     
  27. alphabet

    alphabet Network Newbie Member

    Sorry to hear that you weren't able to access the content.
    That said, you can bet its spirit remains and now moves around data centers world wide. ;-)


    If you want a affordable router to convert to merlin, tomato, dd-wrt look at purchasing a t-mobile router.

    Then follow this excellent guide to convert to a full Asus rt-ac68u.
     
    Last edited: Mar 2, 2018
  28. apvmtan

    apvmtan Serious Server Member

  29. alphabet

    alphabet Network Newbie Member

    Found this youtube video.

    See the guide refuses to go away. :)
     
  30. XVortex

    XVortex Networkin' Nut Member

    The XWRT firmware for Linksys EA6900 has been discontinued.
    I kept this router in the project thanks to @cybernook.
    I do not know what happened here, but without his support the project is closed.
    Sorry.
     
  31. crashman

    crashman Reformed Router Member

    Hi guys, I found that guide several months ago with EA6500 v2. Now I've got 2 of EA6900 v1.1 to made and I saw guide is missing. I can't really understand why has been removed when so much information was in one place and very helpful.

    New releases won't be available, fine. But removing of something thas was working fine and agreed with many thanks.. I cannot understand.

    May you make it available again, please @cybrnook!!!
     
  32. cjapeterborough

    cjapeterborough Connected Client Member

  33. cjapeterborough

    cjapeterborough Connected Client Member

    I see the Xwrt-Vortex firmware downloads have now been removed apart from the R7000.
    Is this the end?
     
  34. yooplaboom

    yooplaboom Connected Client Member

    Rest in peace, EA6900 Xwrt-Vortex
    (thanks to cache:http://xvtx.ru/xwrt/download.htm)
     
  35. apvmtan

    apvmtan Serious Server Member

    Anyone remember how to get into cfe miniweb server, I wanted to flash it to DDWRT, thanks.
     
  36. crashman

    crashman Reformed Router Member

    Thanks a lot for help, guys!

    I have everything done almost until the part of actual flashing in miniWeb server. I don't remember that procedure - seconds of WPS pressed and everything else for Xvortex upload to router.
    If you can help with that I can try to put everything together here again.

    Regards,
     
  37. cjapeterborough

    cjapeterborough Connected Client Member

    Look back through the posts maybe try #129?
     
    apvmtan and crashman like this.
  38. crashman

    crashman Reformed Router Member

    Thanks a lot I made it from first time!

    I'll try to put all in a guide here later ;)
     
  39. thelonelycoder

    thelonelycoder Reformed Router Member

    The reason is clear, we don't want to disgruntle Asus. I also have adjusted the compatibility of my ad-blocker script on my website for non-Asus devices. AB-Solution still works with your fork, but only unofficially.
     
  40. cjapeterborough

    cjapeterborough Connected Client Member

    Does this mean the R7000 is doomed also? See its still available for download at the moment.
     
  41. pomidor1

    pomidor1 Networkin' Nut Member

    justwifi likes this.
  42. crashman

    crashman Reformed Router Member

    Hi to all, as I promissed to renew guide from @cybrnook. All credits go for @XVortex and @cybrnook.

    That happened in a separate thread without making any troubles here. So post had beed edited so far.
     
    Last edited: Mar 15, 2018
    hmosquera, XVortex and pomidor1 like this.
  43. RMerlin

    RMerlin Network Guru Member

    If an author decides to discontinue a guide, you should respect his wishes by not reposting it.
     
  44. crashman

    crashman Reformed Router Member

    My purpose is to have everything on one place. I don't want to hurt somebody with that. As I think you are Asuswrt-Merlin author who I read a lot and honour also.
    If I made mistake I'll remove my post, not a problem. I can post it in a new thread if you like or somewhere else.. or nowhere. I wanted to make it helpful as it was for me. I just recreate it by memory, tests and help of other members here.

    I do respect authors, developers and everybody in projects like Asuswrt-Merlin, XVortex, Tomato and Advanced Tomato (GUI interface only). If somebody thinks I made a wrong thing post will be removed. That's now what I made it for.
     
    pomidor1 likes this.
  45. RMerlin

    RMerlin Network Guru Member

    @cybrnook is the one you should ask.
     
  46. cybrnook

    cybrnook Addicted to LI Member

    I think this thread will likely stay around, so you can use it as a resource if it's the conversation points you want to read.

    But I think if you are picking up the rings and running with the ea6900, it would be best to start your own thread. The info in here is here to stay, so you can use that as a resource, but I won't be answering questions etc...

    Posting some steps in the middle of a discontinued thread might not be the best way forward for you.

    From my side, I am no longer contributing to this routers support (I also don't have one anymore to help, even if I wanted to).

    Want to add, nothing against @XVortex either, he was very helpful to me when I first starting knocking on the ea6900, he was very generous with his time. However, the larger picture at hand, I am stepping back from. When it boils down (to me), RMerlin has been supporting his project for quite some years and is a very big name which I respect. XVortex, I also respect, but when he no longer has the R7000 his project will likely end, while Merlin is left with whats left.
     
    thelonelycoder and crashman like this.
  47. crashman

    crashman Reformed Router Member

    Okay so I think best way is a new thread when that's what you think @cybrnook.
    No problem, really!

    I see your point and agree. I know what you mean from personal exparience.
    I'm going to open another thread but hope it's not a problem to mention all of you guys who make that happen, again.
    As I worte all credits go to you.

    Regards,
     
    Last edited: Mar 15, 2018
  48. davejuk

    davejuk New Member Member

    Sorry, I'm confused... I used this guide to upgrade 2 x EA6900s and now I want to do another one. Where can I find the guide now?

    Thanks
     
  49. crashman

    crashman Reformed Router Member

    Into the same section, one thread down..
     
  50. crashman

    crashman Reformed Router Member

    Double post happened..
    Delete, please!
     
  51. badmannen

    badmannen Connected Client Member

    IS anyone running the 2.4G channel on 14 ? .. I try to put it manually but it jumps to any other channel randomly ?

    is there some other setting to enable it to lock into channel 14 ?
    ( if I´m not wrong I use to run it on 14 before and noticed it changed kind of recently, EA6900 btw )
     
  52. XVortex

    XVortex Networkin' Nut Member

    Well, final release 380.70_0 of the XWRT-Vortex for EA6900 is available.
    The focus of this release was to address a couple of security-related issues.
    Please backup your settings and jffs partition data prior to upgrade.

    This is the final release for EA6900. Further development (transfer to the
    NG branch) of this project for this model is not planned, sorry.

    Good luck.
     
  53. crashman

    crashman Reformed Router Member

    Thank you!
     
  54. jtgraves02

    jtgraves02 New Member Member

    I need help


    Sent from my iPhone using Tapatalk
     
  55. jtgraves02

    jtgraves02 New Member Member

    I have linksys ea6900 v1.1 current firmware version 1.1.43.182871. I want to set up so I can use vyprvpn. I'm told I need tomato. Any help would greatly be appreciated. I've tried reading comments but some direction would be awesome.


    Sent from my iPhone using Tapatalk
     
  56. hmosquera

    hmosquera New Member Member

  57. floydo

    floydo Reformed Router Member

    Thanks for your help @cybrnook, RMerlin, XVortex, it was a interesting, educating journey and the EA6900 still performs admirably!
     
  58. BigBossRadio

    BigBossRadio Serious Server Member

    Thanks for your great help over the years... I have to admit that I went and purchased a New NetGear NightHawk AC1900 Model R700 early last year 2017 and have been using it ever since with standard stock software. I had too many other life issues to take care off. Just checking in to see whats happening and to find that you have decided to hang up your Router Guns and retire. I am considering using my old EA6900 as an "Access Point" for extended WiFi range..... attached to the NightHawk via CAT6 Ethernet cable at the other side of the house for wifi connections .... Again thanks for all your great help over the years and wonderful advice when it was needed........ Happy July 4th...
     
    Last edited: Jul 8, 2018
  59. BigBossRadio

    BigBossRadio Serious Server Member

    I had flashed my old Linksys EA6900 v 1.1 Vortex firmware 380-68-4 as of last October 2017. Then I switched to a NightHawk AC1900 R7000 back last October 2017 as my primary router. Life interrupted me with major issues since then so I had not been following things...

    I took my old EA6900 down from the shelf a couple of weeks ago...... Had a hell of a time trying to login to it..... I finally managed to do so today after doing a 30_30_30 reset...... despite Cyberhooks warning not to do so.

    I managed to get it flashed up to the final Vortex release 380_70 with no problems via WebUI and turn it into an "Access Point" connected via Cat 6 cable to do its work at the other side of the house.. Hopefully, that will work out for me.

    Just to add a note I have all the original Vortex files plus lots of others including CFE's etc. So fi you ever need access to them let me know.........

    It was sad to see the Cyerhook guide go........ He did great work........

    It is important that you make sure "newcomers" are aware that this is only for EA6900's Versions V1.0 and V1.1 and not the new generation.............
     
    Last edited: Jul 8, 2018
  60. BigBossRadio

    BigBossRadio Serious Server Member

    Thanks ever so much for all your hard work over the years. I am happy to tell you that I managed to upgrade my EA6900 firmware from 380_60_4 to 380_70 yesterday.

    Everything is working great. I decided to switch it to "Access Point" mode and use it as a secondary router connected via CAT6 cable to my primary router a "NightHawk AC1900 r7000".
    Sorry to see that you are going but thanks for all your efforts.
     
  61. floydo

    floydo Reformed Router Member

    Gotta say I just updated from 68_4 to 70, the last firmware posted. Very smooth. I am playing with an R7800 and have to say the R7800 stock firmware is so much less concise and router more herky jerky than this Merlin/Vortex/Cybernook Asus firmware. I will keep this EA6900 as my primary router even tho it is aging, and once again have to thank you that created it. Solid, smooth, and clean.
    Thanks :)
     
    Last edited: Aug 24, 2018
    cybrnook likes this.
  62. cybrnook

    cybrnook Addicted to LI Member

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice