Disk "Not Formatted" problem - possible solution

Discussion in 'Cisco/Linksys Network Storage Devices' started by excellentdrums, Aug 9, 2005.

  1. excellentdrums

    excellentdrums Network Guru Member

    Disclaimer: I am not a hard drive professional so this might not work for everybody. Also, I was flying blind so these are not necessarily exact steps. There may be gaping holes in the explanation so make sure that you are confident about what you are doing or, at the very least, don't care about losing your data.

    Here's what I did to solve my "not formatted" problem without having to back up my data or reformat.

    - connected the drive direct to my pc running linux
    - ran fsck.ext3 -v /dev/sda2 (filesystem check, -v=verbose, /dev/sda2 the partition of the device, may vary)
    - running this showed that the drive had a bad superblock
    - fsck allows you to use a backup superblock so i had to locate the location of the backups -> I ran mkfs.ext3 -n to determine the location of the backups BE CAREFUL WITH THIS, IF THE WRONG SWITCH IS USED, IT'LL FORMAT THE PARTITION. (the n switch just displays info about what the command will do if you actually format the partition. it'll list backup superblocks by number.
    - ran fsck.ext3 -v -b <alternate superblock number> /dev/sda2. The b switch allows you to use an alternate superblock. using a backup superblock allowed the filesystem check to complete properly.
    - for each error fsck found, it asked if i wanted to fix it. I answered yes to all of them.
    - at the end of the fsck, it gave me stats about what was repaired.

    When this was all done, I reattached the drive to the nslu2, booted it up and checked to see if my users and data was back. EVERYTHING WAS THERE JUST AS I LEFT IT. Yipee!!!!

    Ultimately, I don't know whether the problem was caused by the nslu2 or the drive.

    I think I have hit on the main points but there may be many variables depending on linux distributions, drives, etc.

    Hope this helps some others who were in the same situation as me.
  2. excellentdrums

    excellentdrums Network Guru Member

    fsck also fixed the nslu2 read only problem

    After I fixed the above mentioned "not formatted" problem. I discovered that i had the "read only" problem with my drive. I got everything back but couldn't write to the disk.

    GOOD NEWS! The above process using fsck under linux fixed that problem too.

    Just thought I'd shared.

    I'm still not sure whether the nslu2 or a bad drive is the problem but it seems to be working now.

    Also, in my investigation, I came across a few things that suggested that this all happened because the partitions were not unmounted cleanly. Can't confirm or deny, just a thought.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice