dnsmasq bug?

Discussion in 'Tomato Firmware' started by i1135t, May 18, 2010.

  1. i1135t

    i1135t Network Guru Member

    Hey all, I was playing around with some options for dnsmasq and it appears that the option for "except-interface=" doesn't work. I've tried other options such as "interface=" and "listen-address=" as well, trying to bind it to only a certain interface (br0), with no luck. I am using TB_VPN_1.27 mod and was wondering if it was happening on other routers/firmware builds as well?
  2. mstombs

    mstombs Network Guru Member

    Any log messages? It is possible that the rc code starts dnsmasq with command line "-i br0" which over-rides the custom config?
  3. i1135t

    i1135t Network Guru Member

    Nothing shows up in the log for dnsmasq... Possibly, but can't say for sure as I don't compile. The only way I have been able to test is by setting my OpenVPN interface to bind specifically to an interface that was supposedly free, but errors out stating that address is already in use in the log.
  4. i1135t

    i1135t Network Guru Member

    Any chance of someone compiling a stand-alone dnsmasq binary for tomato so I can test some configurations?
  5. teddy_bear

    teddy_bear Network Guru Member

    dnsmasq in the firmware is started with "interface=br0" parameter in the config file and no command line parameters. Anything you specify in the custom configuration, goes into the config file after all of the default parameters, so it's up to dnsmasq how to handle conflicting settings.

    The dnsmasq is in the firmware - what do you need another binary for? You can do all your experiments with the built-in dnsmasq...
  6. i1135t

    i1135t Network Guru Member

    Ok, well, how dumb of me not to just take that binary... hehe. Thanks for pointing me in the right direction. I'll try a few things and see what I can do. Thanks all!

    -- EDIT --

    OK, looks like dnsmasq will bind to vlan1 no matter what, even if I specifically exclude it in the conf file. I also tried various options and no go, so it isn't working as it should. :(
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice