Does Tomato work on a Motorola WR850G?

Discussion in 'Tomato Firmware' started by caldna, Apr 10, 2007.

  1. caldna

    caldna Guest

    I have a Motorola WR850G v2 wireless router. Does Tomato 1.06 work on it? If so, do I use code.trx? Are there limitations? Thanks.


    Thanks to Jon, the author of Tomoato, I was able to get my WR850G v2 up and running with Tomato 1.06.

    It's only slightly more complicated to do than the standard Linksys routers.

    If anybody wants to try it at their own risk on their WR850G v2 router, here's a how to:
    I cannot confirm if this will work on other versions of the router.

    1. Load the latest official Motorola firmware (v6.14)
    2. After loading the firmware, reset the config in the GUI
    3. Load a DD-WRT firmware (I used dd-wrt.v23_mini_moto.bin) onto the router according to these instructions:
    4. After installing DD-WRT, do NOT reset the config. I had a problem with this step where I could no longer access the GUI after flashing DD-WRT. I just unplugged, hold down the reset button, plugged back in, and after 10 seconds released reset button to get back into the GUI.
    5. Make sure you're aware of the DD-WRT-to-Tomato password problem (
    6. Load any of the Tomato files using DD-WRT. (I used code.bin from the WRT54G folder). Again, I had a problem accessing the GUI after flashing Tomato, but resolved it by doing the unplug/reset/plug/release trick.

    This is a note from Jon explaining the reason for these steps:
    This is a long route since a few of these routers do not setup some critical nvram settings by themselves (loading the Motorola firmware does that), and Tomato does not have a Motorola header (DD-WRT does and can be used to load other firmwares).
  2. roadkill

    roadkill Super Moderator Staff Member Member

    From FAQ:
    What will this run on?

    * Linksys WRT54G v1-v4, WRT54GS v1-v4, WRT54GL v1.x, WRTSL54GS (no USB support)
    * Buffalo WHR-G54S, WHR-HP-G54, WZR-G54
    * Asus WL500G Premium (no USB support)

    Note: Most WRT54G and WRT54GS (not WRT54GL) sold in stores right now are the v5.0+ variety and will not work with Tomato.
  3. der_Kief

    der_Kief Super Moderator Staff Member Member

    it may work with this unit! Here someone runs Tomato on a WR850GP (which isnt officially supported) You should ask Jon about this !

  4. dynamx

    dynamx LI Guru Member

    Got it working also

    I just flashed from ddwrt. After I held the reset button for 30 secs to reset the password to default.
  5. ofbarea

    ofbarea Network Guru Member

    This should work on wr850g V2 and V3 as these units have the same hardware as a WRT54G v2. The wr850g v1 is different and there could be some unknown problems.
  6. TexasFlood

    TexasFlood Network Guru Member

    It does work on a V2 and V3. I can confirm as I've now loaded it on both. I saw several indications that it has specific code support for these models even though nothing is mentioned about this in the documentation.
  7. roadkill

    roadkill Super Moderator Staff Member Member

    e-mail Jon or I think he could answer you on that either that or PM caldna I guess he'll know too...
  8. TexasFlood

    TexasFlood Network Guru Member

    Had a problem show up on Tomato that was also identified on dd-wrt. The issue is the nas daemon dying on WDS remote access point routers. Clients hang when this happens. Recent versions of the the v23 dd-wrt SP3 beta will restart the daemon when it dies. The same thing started happening to me on Tomato. Clients associated with that router were hanging but if I was associated with the main router, I could still telnet in and see with "ps|grep nas" that nas was no longer running.

    ***Update: My conclusion that Tomato static DHCP services seems to have been incorrect. I'm dong a longer term test but as of now this seems not to have been the issue. I now believe that the issue of the nas daemon dying on a WDS remote access point when using WPA as the encryption method, was at fault. This was identified on dd-wrt and patched to restart nas. My testing shows the same symptom on Tomato and probably even on the native WR850G firmware. I'm now testing Tomato on the main router, dd-wrt on the WDS remote access point, and Tomato on a WDS remote router that is not acting as an access point, it will be intresting to see how long the nas daemon stays up on this one.
  9. TexasFlood

    TexasFlood Network Guru Member

    Well, I'm back on Tomato on all my routers now.

    I wrote a kludgey little script that cron runs every minute on the WDS remote access point and restarts the nas daemon if it's not running. As I said, it's a kludge but hopefully will allow me to continue testing Tomato with no clients locking up requiring some sort of manual intervention. Maybe running every minute is overkill but when your client is locked up, it might seem like too long.

    It seems to be working for me. If anyone has the issue and wants to try it, see below, YMMV, tax title & license extra, other disclaimers, etc, :), then....

    Paste the following, everything between the parentheses, not including the parentheses, with no line breaks, into the tomato script window init tab, press the save button, wait for it to complete, the script will run the next time the router is booted.

    (echo \#!/bin/sh>/tmp/checknas;echo if ! ps \| grep [n]as\; then >>/tmp/checknas;echo nas /etc/nas.conf /var/run/ lan\& >>/tmp/checknas;echo fi >>/tmp/checknas;chmod 555 /tmp/checknas;echo "*/1 * * * * /tmp/checknas" >> /var/spool/cron/crontabs/root)

    Note that I'm running WPA PSK wireless security and got the nas parameters from looking at the one running on my router. Do a "ps | grep [n]as" on your router and make sure that the parameters are same before trying (should be OK as most of the parameters are actually not entered directly but in a file created by the firmware based on your config). I tested it on my router from a telnet session before proceeding. From a telnet command prompt, I killied the existing daemon with "killall nas" then tested it by running it again with what I thought to be the right parameters (with & to background of course). In my case it seemed to worked so I proceeded.

    You can change it as you like, to run less frequently, etc. You might want it to reboot rather than run the nas daemon again. I'm still testing to see which approach works better. What it does, at router boot time is create a short script named "checknas" in the /tmp directory, to check for the nas daemon running and re-run it if not, set the script permissions to allow it to be run, and add a cron line to run it every minute.

    The end result is script /tmp/checknas that looks like:

    if ! ps | grep [n]as; then
    nas /etc/nas.conf /var/run/ lan&

    and the following line added to the root cron:

    */1 * * * * /tmp/checknas

    If you aren't having the issue, then it ain't broke, don't fix it!

    ** The whole issue seems to have gone away since switching to WPA2/WPA mixed mode. I was using WPA for WDS interoperability with dd-wrt. But I'm all tomato for the moment, so no reason not to do mixed mode now. nas must be happier running in this mode. The other issue I had was all sorts of flakey stuff when I had multiple access points close to each other. I have two on the second floor, one of which provides wired port access for an old printer and a small NAS storage unit. So I just set that one to WDS only and have the other one handle all the wireless client access. It seems to be stable in that configuration, so I'm leaving well enough alone.
  10. tcsoft

    tcsoft LI Guru Member

    i've tried to install tomato 1.19 on my wr850g v1 yesterday. it didnt work. first i installed the original firmware 6.1.4. then i tried to do a firmware-upgrade through the webif. the router didnt boot up again.
    afterwards i flashed the original firmware via tftp again (because the bootloader only accepts trx-files with motorolaheader). now i flashed dd-wrt through the webif which WORKED. dd-wrt runs perfectly.
    but then again: upgrading to tomato with the dd-wrt webif-fw-updater does give me an error ("Upgrade failed").

    what should i try next? or is tomato not compatible with wr850g version 1?

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice