Discussion in 'Cisco/Linksys Network Storage Devices' started by Albs, Feb 25, 2008.

  1. Albs

    Albs LI Guru Member


    I have a Dreambox which records films (TS-format) and so on via my network on my NSLU2. This works perfect.
    Now I have bought a NAS200 and the following thing apears: I get an hickup every 5 to 10 minutes or so.

    Two of my friends also have a NAS200 and have the same problem.

    I don't get it; the NSLU works perfect and this NAS200 doesn't :confused:

    Has anyone an idea what it can be ?

  2. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    This might be caused by the rather old Twonky that's on the NAS200. Try the beta V71 firmware or read my Telnet/Twonky thread to run the latest Twonky manually.

    Let us know how it went!

  3. Albs

    Albs LI Guru Member

    But I don't use Twonky, or does it use that without me knowing it ?

    It's just a matter of streaming the TS-file to the Dreambox as far as I know. Or the other way around in case of recording.

    One of my friends upgraded the firmware but that did not help.
  4. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    I'm not familiar with the Dreambox but I figured since you said you were streaming media, that you were using NAS200's built-in UPnP (DNAS) media server which is Twonkyserver. To test whether this is true, you can try disabling the media server in the NAS200 web interface and see if you can still play something that's on the NAS200 harddisk.

    If your Dreambox can still play video from the NAS200 even when the media server is disabled, it means it's reading it directly off the harddisk via SMB or FTP. Unless you're playing some kind of high-quality HDTV stream, the 4 Megabytes per second that the NAS200 is able to supply, should be enough, even for a Transport Stream. The V3.4 R71 beta version of the firmware can make it 6MB/sec if you reformat your disk in non-journaled mode (this makes the NAS200 use ext2 instead of xfs).

    Maybe the problem happened during recording and is caused by missing frames or corrupt parts of the file? Try copying the file to the harddisk of your PC and play it there with Nero Showtime or another player that's capable of playing TS files (probably VLC can do it too; MS Mediaplayer and probably most other players cannot).

    You may also want to try one of the many software tools for TS analysis, to check for problems in the file, and to find out what the bitrates are. That way you can verify that the bitrate of the file is low enough for the NAS200 to keep up (4MB/sec is about 40Mbits/sec; I don't think I've ever seen TS files with bitrates above 20Mbits/sec but it's been a long time since I worked with TS streams). If the TS file has errors in it, the problem happened during recording and probably can't be fixed, at least not in the files you already have.

    If nothing helps, you may have to set up a Telnet daemon on the NAS200 and reformat the data partition of the harddisk using a bigger blocksize or something (not sure if that's possible, I've never needed to fiddle around with block sizes in Linux file systems). Or use two harddisks in a Raid 0 (striping) configuration, although this might make things worse because the NAS200 implements RAID in software, not hardware.


    (PS I assume that you're using an internal harddisk inside the NAS200, not an external USB)
  5. Albs

    Albs LI Guru Member

    At this moment my NAS200 is at a friends, he wants to test it for me. When I get it back I'm goint to upgrade it with the new firmware and than I'm going to reformat the disk in that non-journaled mode. See if that helps.

    I'm quit sure the problem occures during the recording.

    And yes, I'm using an internal harddisk.

    Thanks for your answer.
  6. bobbyshafter

    bobbyshafter Addicted to LI Member

    Albs i am trying to set up my nslu2 with my 500s ,having problem getting it to work.
    I created a private share with password ,get it to mount ,but when i try to record i get "failed due to inaccessable "
    Can you please tell me how you got your woring.
  7. Albs

    Albs LI Guru Member

    Hi Bobbyshafter,

    He does mount good ?
    Do you have a dir called movie created in your share ? There has to be that directory. Your Dreambox has access and write-rights on that share ?

  8. bobbyshafter

    bobbyshafter Addicted to LI Member

    Thanks for the response, should i make it a private share ?
    Here is what i have ..I created a user dm then a private share dm2 with movie in that share.
    Got it mounted but when i try to record i get the message "timer failed due inaccessable ".
  9. Albs

    Albs LI Guru Member

    does user dm have read- and write-rights ?
    It should work this way.

    What do you mean by: private share ? A share only for one user ? That is not neccesary. Just a share called dm and a user that has all the rights to that share.

    Than use that share and user in the mount-section of your Dreambox.
    Via the web-interface:

    client directory: /hdd
    server directory: dm2
    user: dm
    password: *****
  10. bobbyshafter

    bobbyshafter Addicted to LI Member

    Thanks alps i got it working ,there was a problem with my slug.I got it working by flashing with unslung .
    Next i will be flashing with BarracudaDrive.
    I tried telenet into into the unit without success,any luck with that.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice