Dropping connection after 3 hours with WRVS4400N

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by pollisoft, Feb 7, 2008.

  1. pollisoft

    pollisoft LI Guru Member


    I got a problem with my WRVS4400N router for a while now. I got the V1.1.03 FW version installed and everything seems to be working fine.
    I use the router as a gateway, and I get the following public ip settings from my ISP when I use the automatic settings:
    IP: 83.254.aaa.bbb (privacy) :halo:
    GW: 83.254.ccc.ddd (privacy) :halo:
    Subnet mask:
    plus 2 DNS servers

    The router is assigned to
    subnet mask:

    I set up my LAN (consisting of one wired PC, one wireless PC and one NAS) to use the following settings:
    IP: / /
    Subnet mask:
    plus the two DNS servers

    As stated above, everything (internet radio, surfing, FTP and torrent download) works perfectly ok, for a while. After a couple of hours I cannot surf the web, most addresses just does not work. Most of them can be found through DNS but nothing is displayed. If something is displayed, the download is VERY slow.
    On the other hand, the torrents currently on down/upload are not affected.
    Most internet radio stations does not stream music anymore.
    I can connect to MSN, ICQ and Google talk.
    This behaviour is the same whether I enable or disable firewall/IPS/allow external PIN request and so on.

    On the LAN, all file connections works ok with the same transfer rates as the first hours.

    It seems like there is some DNS issue regardning the WAN connection, but why does this start after some hours???
    In another thread, I read that Linksys routers have problems when the WAN subnet mask is wider than the on the LAN side. I therefore just changed my WAN settings to to the same settings I got but changed the subnet mask to I have yet to see if it helps.

    I tried to downgrade the firmware to 1.0.16, but then the router shut down all communication, including internal, after the same time.
    To remedy this problem, I have to restart the router almost every time I want to use the internet. After the restart, everything works ok again...
    Have anyone else seen this issue?

    I know I have written quite a long description, but if someone bothered to read this far, please help me... :redface:

  2. blake_

    blake_ LI Guru Member

    Have you tried setting the wireless to G mode instead of N if you have it enabled?
  3. pollisoft

    pollisoft LI Guru Member


    yes I have, but it doesn't help.

    Update on the widened subnet mask. This did not help either. One thing happened though, after the ~3 hours, my ISP changed the ip (I forgot to say that I have dynamic IP) so then all connections dropped.

    I tried leaving the router on over night without any computers connected, and this morning there was the same behaviour when I started one computer. I tried to ping myself, the WAN GW and some other computers on the internet. All computers had a response time of ~3 ms on average. When I tried to connect to those computers, no data was downloaded. But no packets were dropped either.

    Could it be that when when my ISP, on intervals on ~3 hours, check if I'm still connected disrupts the router somehow?

    Right now, I'm trying to work around the problem by connecting a second router to work as the local GW as follows:
    WAN<->2nd GW<->WRVS4400N (as router only)<->LAN connections

    Let's see if that works for more than 3 hours.
    But honestly, this is not the way you should have to solve this problem, is it?

  4. pollisoft

    pollisoft LI Guru Member

    After 8 hours, the connection to the WAN is still valid, and Internet is working without any problem with the setup above.
    Isn't that strange?
  5. DocLarge

    DocLarge Super Moderator Staff Member Member

    Is your connection xDSL or Cable? A majority of the issues we've seen with a "majority" of the vpn routers after the WRV54g has been the inability to function properly on PPPoE and PPPoA connections...
  6. tony4d

    tony4d LI Guru Member

    If its anything like the WAP4400N then its completely unstable when using WPA or WPA2 security. If you're using WPA try changing to WEP and see how things work out.
  7. pollisoft

    pollisoft LI Guru Member

    It's Cable, through Comhem, a swedish ISP. I called their support to see if I can connect through anything else but DHCP, but they refused to help me since "it's obviously the routers fault".

    Thank's for the tip. Currently, I'm using WPA2. I'll change to WEP and see if that helps. But still, the issue occurs on the wired network aswell.
  8. pollisoft

    pollisoft LI Guru Member

    A quick update.
    After rearranging my network as follows, the WRVS4400N has been online for 2 days without any trouble.
    I will test without the second router when new firmware is available.

    WAN <--> Netgear WGT624 (connected via DHCP) <-subnet connection-> WRVS4400N (connected to Netgear via static ip) <--> LAN

    What do you think, is this a compatibility issue between the ISP and Linksys?
  9. jdreif

    jdreif Guest

    I have the exact same problem and have also been using WPA instead of WEP. Do you have any updates? Did switching to WEP make any difference? Thanks
  10. pollisoft

    pollisoft LI Guru Member


    no, switching to WEP did not solve the problem for me. In some forums, people say that this happens when the IPS feature is not activated. I will try to activate IPS again and see if that solves it.
    If you solve it, please post.
    Good luck!
  11. mawinter

    mawinter Guest

    No wireless unless a wired connection is or has been recently used

    My wireless connection also drops out after some time but I can always get it to reconnect if I connect at least one machine with a wired connection, even if only for a few seconds. It seems the wired connection triggers the router to send out the address to the wireless connections. This will continue to work for minutes to hours, even after the wired connection has been disconnected. I have tried None & WPA2 security, upgrade firmware to 1.1.03, and got a refurbished router shipped out that does exactly the same thing. Linksys tech support seems to think it is my machine, opsys, or environment that is causing the problem but it works the same on 3 different machines, including a MAC vs two Dell laptops. Also it worked fine for many months until I upgraded to new firmware because router started dropping connection to internet modem (no longer a problem with new firmware)
    Got any ideas?
  12. Nukelas

    Nukelas Guest

    I have the same problem as described when trying to use the router with "Bredbandsbolaget" 100Mbit connection (Its not static IP). Something is bugged badly with this router.
    When using 1.1.03 the router looses its WAN IP and doesnt update it if not rebooted. This happens in periods of 1-3 hours. The IPS functions is set "off" cause the speed gets badly reduced. If going back to 1.0.16 the router doesnt lose the connection but the MAC/IP function isnt there... :(
    Nah.... just to send it back and buy a cheaper router that works?
  13. VipeTecH

    VipeTecH Addicted to LI Member


    The same error have I on my router ...
  14. darwinmach

    darwinmach Addicted to LI Member

  15. pollisoft

    pollisoft LI Guru Member


    the FW in the post above fixes the error described in this thread. Thanks!

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice