Dynamic DNS with Custom URL does not automatically update?

Discussion in 'Tomato Firmware' started by leesiulung, Oct 19, 2008.

  1. leesiulung

    leesiulung LI Guru Member

    It appears my Tomato flashed router will not automatically update my dyanimc dns with custom url. I'm running Tomato v1.11.

    I entered it correctly into the "Dynamic DNS 1" section selecting "Custom Service" and supplied the correct URL. I left the "Force Next Update" unchecked....

    Any suggestions? There seems to be no option of how often to update the dns (although it probably does it when it detects the ip is changed, but still)....
  2. leesiulung

    leesiulung LI Guru Member

    Nobody has any idea? Does anyone use this feature and can at least confirm it works?
  3. SgtPepperKSU

    SgtPepperKSU Network Guru Member

    I use it. My IP address very seldom changes (many months between changes), but I'm pretty sure it worked the last time it did.

    What makes you think it isn't working? Has your IP address changed without updating your dyndns provider? Or is it just because it didn't initially set the IP when you first entered the URL? If it's the latter, you have to check "Force Next Update" to get it to update when an IP change hasn't occurred.

    If you really want to test it, I guess you could do the following
    1. Power off modem
    2. Change WAN MAC address on Router
    3. Power on modem
    4. Hope the IP address assigned is different
    5. Check if your dyndns was updated
  4. leesiulung

    leesiulung LI Guru Member

    Well, the feature didn't work for me.

    I noticed my external ip and the ip on the dynamic dns did not match due to me changing ISPs recently. So I hit save and made sure "force next update" is checked.

    It said the update was a success, but my dynamic dns ip did not change. I then checked the URL and it is a success... really odd...

    Any suggestions?

    The only thing I can think of is the '@ip' part isn't working. I'm using it in following format:

    https : // mydynamicdns.com?someid=somethinghardcoded&pass=somehardcodedpass&ip=@ip
  5. SgtPepperKSU

    SgtPepperKSU Network Guru Member

    My dynamic DNS update URL doesn't take an ip parameter, so that may be the difference. Have you tried leaving off the '&ip=@ip'? Your provider use the IP of the requester in that case. Without knowing the provider (assuming mydynamicdns.com is a made up example), I can't be sure, though. There could be a bug in handling '@ip'.
  6. azak

    azak Addicted to LI Member

    Try @IP not @ip. If that doesn't work then https: may not be supported.
  7. leesiulung

    leesiulung LI Guru Member

    Oh my G! It worked.... That is silly.

    Thank you both of you for assisting me. Much appreciated! ;)
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice