E3000 slows down network running victek Tomato

Discussion in 'Tomato Firmware' started by Mad Ed, Mar 17, 2011.

  1. Mad Ed

    Mad Ed Networkin' Nut Member

    Hi guys,

    having following problem, which I have tried to solve via the search in several forums already, but cannot find a way to solve. So put my hopes on you now.

    I have a TS-419P Qnap NAS and two laptops connected to an E3000.

    I have connected both laptops as well as the NAS and a laptop directly without the E3000 to test the circumstances under which the problem occurs. I also switched cables around to eliminate the problem.

    Following happens: If I directly link the laptops or the laptop with the NAS I have transfer rates of 8-9 MB/sec. As soon as the E3000 comes into play (is being connected), the speed drops to 2-3MB/sec. All this on a 100-Lan. I tried also one laptop with Gb-lan and had the same problem the speed drops from high speed to 2-3 MB somtimes even down to 512 kb/sec.

    The E3000 is running the latest version (16.03.11 downloaded) of Victek Tomato for E3000.

    I hope you can help, as I am working on this for half a year now and getting frustrated.


    Mad Ed
  2. jondlou

    jondlou Networkin' Nut Member


    I am running the same router and firmware. I believe it may be the Samba version you have built into the firmware. Try enabling SSH and running a terminal or PUTTY program to run this mega script. Be warned that you will end up reformatting your harddrive with optware that way, so you may have to be careful with files. You can manually use IPKG to get Samba 3.5, however, but it was always a pain for me to configure it's settings just right from scratch. That may be the best option if you have no way to reformat a drive for this situation. I can stream movies pretty well with more consistent averages, and I keep my wireless settings overclocked. I would say I get over 1 mb per a second unless the wireless has some interference pretty badly all at once. I think the main bottleneck is the actual Samba version for file reading and transferring. The weird part is that you have to log in to your router i.e. to find your Samba settings once you are running it with its web interface known as SWAT. If you already have optware installed this should be easy to configure. If not, try this script I am referring to that does optware for you, and it is specifically written for any tomato (i.e. our new one)...


    Any other questions or even suggestions are awesome, since I have not been posting much, but I am bored with no one who understands this or who is interested in this type of networking. I am actually considering turning my major towards programming and networking, but I am learning in some areas still (we always are).

    Hope this is helpful one way or another, I just feel glad you have the same equipment. Take care!

  3. Toxic

    Toxic Administrator Staff Member

    what version of firmware do you have on the QNAP? are jumbo frames enabled on NAS or the router?
  4. shibby20

    shibby20 Network Guru Member

    have you enabled QoS or BW limiter?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice