E4200 bricked? Need help

Discussion in 'Tomato Firmware' started by cchhat01, Jun 13, 2012.

  1. cchhat01

    cchhat01 Serious Server Member

    So I saw some movement over at out friends at openwrt.org regarding 4716 based chips. I got awfully ambitious and decided to make some changes in broadcom based diags and netconfig and flashed my local build of openwrt... should have known better ::sigh::

    I had initially locally built Toastman build and used the webbased upgrade page within Tomato to upgrade to Openwrt.

    After that no avail. Here's what happens.
    When I power on the device, the Cisco led and the ethernet activity leds comes on and almost immediately.
    The Cisco led (after coming on) flashes slowly 2 times and then stays solid for about 20-22 seconds, then just goes off. The ethernet activity lights stay on.

    I tried pinging the router, and its unreachable. I've tried to force a "management mode" as i've read on another thread (where the Cisco led flashes rapidly) so that I can tftp the linksys firmware. Doesn't work. Infact, its just intermittent in the sense that sometimes I can get it to the point where the led flashes rapidly by holding the reset button down immediatly at power-on, but the router isn't responding.

    What does happen and I find strange is that I've tried sending off the firmware via tftp as soon as the router is powered on (and the only thing that is connected to the router is my desktop via ethernet on port 1), and it starts to accept the firmware update however, the linksys firmware is too big and after accepting about 8MB the transfer is aborted.

    received ACK <block=15743>
    sent DATA <block=15744, 512 bytes>
    received ACK <block=15744>
    sent DATA <block=15745, 512 bytes>
    received ERROR <code=3, msg=transfer cancelled>
    Error code 3: transfer cancelled
    Sent 8060928 bytes in 17.0 seconds

    during this process the cisco led blinks slowly (not rapidly) and it continues doing so even after the process completes. Throughout this process the router is responding to PING.
    64 bytes from icmp_req=1 ttl=100 time=0.582 ms
    64 bytes from icmp_req=2 ttl=100 time=0.296 ms
    64 bytes from icmp_req=3 ttl=100 time=0.260 ms
    64 bytes from icmp_req=4 ttl=100 time=0.254 ms
    64 bytes from icmp_req=5 ttl=100 time=0.260 ms
    64 bytes from icmp_req=6 ttl=100 time=0.246 ms
    64 bytes from icmp_req=7 ttl=100 time=0.282 ms
    I've even tried uploading tomato firmware which happens to be less than 8MB and it still fails... I've tried stripping out the first 32 characters from the bin file (essentially the trx file) and that too fails.
    What are my options. Does anyone have any knowledge on reviving the router via JTAG or serial cable that can help me revive this device?
    All help will be appreciated greatly.
  2. mstombs

    mstombs Network Guru Member

    Have you tried the dd-wrt mini build that is less than 4MB?


    Definitely recommend serial console when debugging on any router - its easy to break Ethernet comms!, with this you should be able to see what is going on and stop the boot and "nvram erase" which can break reboot loops - note you need a 3.3V converter, some Linksys routers have serial console via an external port. Don't know about the E4200 CFE but sometimes the reset button, which should reset the nvram to defaults, doesn't work - the rest_gpio is not hardcoded its stored in the possibly corrupt nvram!
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice