E4200 Toastman latest - WiFi speed drops

Discussion in 'Tomato Firmware' started by Devileyezz, Mar 16, 2012.

  1. Devileyezz

    Devileyezz LI Guru Member


    I have E4200 v1 running Toastman latest.
    A couple days ago, our WiFi started crawling. Everyone is on the 2.4GHz band. For more than a week, all our servers, and the router were right next to each other. I thought maybe that's the issue and moved the router a few inches away from the whole pile of electronics.

    I have about 20 computers connecting to this router via WiFi, and I have 2-3 wired servers connecting to it. These 20 PCs have average ping times of above 150ms and sometimes over 200ms. When it slows down, it's over 2000ms!

    I was on Victek and didn't know what to do, so I moved to Toastman, and I still see this to be slowing down. Another issue is one of the servers runs a network software, so it's PC <-> WiFi -> Router -> Wired server. And it's still slow.. I'm unable to figure out what the issue is.

    Please help.
  2. Devileyezz

    Devileyezz LI Guru Member

    PS: Just noticed .7496.2 by Toastman. But the folder doesn't mention E4200 explicitly, but I see files for E4200. (I also noticed it's an RT version, which means no 5Ghz)
    OT: Which version is really the latest for E4200 that's very stable? I don't care enough for 5Ghz
  3. Toastman

    Toastman Super Moderator Staff Member Member

    Yes, you can use an RT version provided you don't need 5GHz. But I very much doubt it will make any difference, as you've already tried Vic's version and mine, and both are the same. Something has changed at your location. You must find out what it is.

    I would start by erasing NVRAM and reconfiguring from scratch. Just a bare basic setup and see if things return to normal. If they do not, then start looking for other causes.
  4. Devileyezz

    Devileyezz LI Guru Member

    Got it. Did the erasing, and now things seem to be better.
    However, I have an OT question. I have a couple wired servers that have their own static IP requests. Unfortunately, these don't show up in the device list. How come? I want to see all devices on the network regardless of how they have their IPs.
  5. Toastman

    Toastman Super Moderator Staff Member Member

    Just add them to the Static DHCP list, even thought they'll never actually poll for an IP.
  6. Devileyezz

    Devileyezz LI Guru Member

    Isn't that more like a hack instead of a fix tho? I'd expect to see all devices routing traffic through the router to be displayed somehow, right?

    Plus, I'm going to have to go looking for their MACs. :/
  7. bl00513

    bl00513 Networkin' Nut Member

    Hey Toastman, I too am running into the same issue. I downloaded the most recent VPN/Nocat build for the 4200. What's different in my situation is that I flashed right out of the box. Also, wired clients worked like a champ. My setup was pretty basic too; I simply put the E4200 on a subnet from the 2Wire router/gateway my ISP issued. 2.4Ghz connected anywhere from 1Mbps ~ 5.5Mbps. The 5Ghz did better at about 8Mbps, with the occasional spike to 70ish Mbps. I tried clearing NVRAM and even reflashed to the previous build. Each yielded the same result. I flashed back to the Stock firmware from Cisco, and it's working like a champ, with the obvious exception of the terrible interface and lack of features.

    Do you have any thoughts or suggestions? Have you seen this before on any other builds? I really don't "Need" the NoCat portal. I could always just try the VPN build or something. Thanks in advance !!!!
  8. LanceMoreland

    LanceMoreland Network Guru Member

    Not sure why you are having these issues. I am running Toastman's VPN version for the E4200 and can take all my ISP can give me on the 5 GHz connection which is the same as I get on a wired device. Make sure in the Advanced Wireless section you have "Frameburst" Enabled and if you are running an Intel wireless card you must enable "WMM" in the same Advanced wireless section.

  9. bl00513

    bl00513 Networkin' Nut Member

    Do you know if Frameburst is enabled by default? If not that may have been the issue, as I did not manually enable it. However, I only had one client attached at a time, so do you think Frameburst would have made the difference? Also, most of my clients have broadcom or realtek chipsets.
  10. LanceMoreland

    LanceMoreland Network Guru Member

    Frameburst is not enabled by default, WMM is. I doubt this was your entire issue but I get much better throughput with Frameburst enabled. WMM with an Intel wifi chipset is a big deal (you will only connect at 54G speeds with it disabled). Also, make sure your 2.4 GHz channels are set to 20 MHz channel width. 5 GHz channels work well at 40 GHz width for me but there is no congestion in my area on the 5 GHz channels. Run a site survey with Inssider and and make sure you are on the more open channels. I also found that the higher 5 GHz channels worked better in my case (153 and 161). Give it another shot.
  11. bl00513

    bl00513 Networkin' Nut Member

    My 2.4GHz channel was set to 20MHz width and on channel 7 (only open channel) - I got about 1~5Mbps
    My 5GHz channel was set to auto width and auto channel but selected 153 and 40MHz width. The max I got from this SSID was about 8Mbps. I've got the same setting now on the stock firmware and it's working great. Any thoughts?
  12. Dr Strangelove

    Dr Strangelove LI Guru Member

    I'm surprised.

    1-5 mega bits per second ... you guys must be approx 20-30 metres from the router???? OR have really bad WiFi cards in your client devices.

    Some mobile phones running single channel 802.11n won't play well with routers set to 40Mhz channel width on 2.4Ghz.

    I've had no problems in my environment with my Linksys E4200v1 using Toastman firmware.

    At 15metres in my 2.4GHz 40MHz(two channels) environment, I get an average -62dBm signal.
    Peak: -59dBm
    Low: -67dBm.
    It's been that signal strength for ages.

    I have the Transmit Power set to 100mw on the E4200 and that's really it.
    I've played with long and short preambles (Linksys RE1000 range extender does like short), 802.11n Preamble and WMM.
    I've even overclock the CPU, but none of that provided any noticeable differences other than the transmit power option.

    At 15metres from the E4200v1 I get a very consistent 75Mbps ftp read/get file transfer throughput. (approx 4 walls)
    At the same distance I've had peaks of 101Mbps and lows of 62Mbps.

    My connect speed at 15metres is around 162-108Mbps

    My ADSl2+ data speed is 12.2Mbps at the modem and at 15metres from the E4200/modem I am still able to realise that speed.

    My 2.4Ghz noise floor is approx -84dBm

    I general only have a notebook (DW1520 half mini card 2.4GHz/5GHz) and Android 802.11G active at any one time.

    At approx 3metres from the Linksys E4200 2.4GHz (40Mhz) 300Mbps connection speed using command prompt terminal and ftp I can get over 130Mbps read/get downloads.

    Write or put speeds are always slower and around 90Mbps at 3metres from the router.

    Using my 802.11G Android mobile gets 9.8Mbps at 15metres, but does drop the signal every now and then as it's not got the most powerful transmitter.
    Peak: 75dBm
    low: -90dBm with drop outs.
    7.4Mbps read/get at 15Metres from the E4200v1 on 802.11G 20Mhz (XPERIA X10i) using Android AndFTP

    This is over a range of firmware over the last 6 months.

    Client WiFi cards always have a big part to play and it's not just the WiFi router.
  13. bl00513

    bl00513 Networkin' Nut Member

    That' the strange part, My tests were literally right next to the router. I tried multiple devices also. I tested with two Laptops, both wireless N. One was a realtek chipset, the other intel. I also tested w/ an IPad2 and My HTC Rezound. Until I flashed back to stock all my speed tests were consistently low. I did however have the transmit power set to default. I don't think that should have been an issue though, as I was less than a foot away from the router each time. One thing I should note, my router was a Cisco Refurb (from Cisco). Is it possible they maybe replaced an Antenna or radio with something one might not normally find in the standard V1 ?
  14. Dr Strangelove

    Dr Strangelove LI Guru Member

    If it's hardware related, you'd probably get similar indicators on both Linksys and Tomato fw.

    Transmit power won't change anything when within metres of the router.

    Within a few metres, 6 feet or so you should get a 2.4GHz signal of around -32dBm as seen by inSSIDer.
    You should get around 110-130Mbps ftp transfer speeds at those distances on a 300Mbps client.

    Maybe try a Tomato Toastman E4200 standard fw build and use the build defaults to test.


    Out of interest, what does the 2.4GHz WiFi interface say your connection speed is?

    On a 300Mbps wireless client within 2 metres the connection speed should be 300Mbps.
    If there are 802.11g devices nearby this could drop to 54Mbps.

    BUT even if this was the case, you'd still get around at least 12Mbps when right next to the router on a 54Mbps connection.

    Even better just have one test Wireles device active as this'll reduce any CSMA/CA oddities.

    Very strange.

    Even vanilla Tomato firmware couldn't degrade the WiFi signal that much
  15. bl00513

    bl00513 Networkin' Nut Member

    On the router my 2.4GHz speed showed anywhere from 1Mbps to 5.5Mbps, and a speed-test was always consistent with my connection speed. So, I don't think it was erroneous. This seemed to be the case for both bands, but 5GHz usually was a little faster @ around 8Mbps. I think my next step will be to try a vanilla version of Tomato and see what my results are. I am already realizing the extent of the limitations of stock firmware.
  16. bl00513

    bl00513 Networkin' Nut Member

    Just thought you guys would be interested in hearing this.... I'm am still running the stock Cisco firmware and last night I ran into the same problems. My connection speed just dropped into the single digits out of no where. I connected with a patch cable and the speed was great. There is obviously something wrong (hardware related) with this router. I'm going to try my luck at exchanging it. I'll flash Tomato on the new one and keep everybody posted.
  17. Sushi1808

    Sushi1808 Serious Server Member

    The original firmware for the e4200 v1 is really rubbish. The signal was bad, speeds were fluctuating, the range was worse than with my 6 years old Belkin.
    I tried numerous different settings, it was better but it still sucked...

    Then i discovered Toastman's tomato firmware.

    The flashing process is the same as with the original firmware (really simple).

    I have used this firmware - http://www.4shared.com/file/KOjVG1Ge...0K-12874.html?

    But you can use other firmware from this link - http://www.4shared.com/dir/v1BuINP3/...an_Builds.html

    !!!Just make sure that it has e4200 in it's filename.!!!!

    Instructions for flashing are in the link below, in the third post


    The configuration is easy - first you need to find the channel which works best for you in your enviroment, and i also enabled FRAMEBURST and set preamble to SHORT.

    I now have a ultra stable connection, the speeds have tripled, and the range is superb.

    Syslink should be ashamed that we need to flash custom firmware for their products to actually work:/
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice